LDraw.org Discussion Forums

Full Version: Creating stickers
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5
(2018-07-17, 18:08)Travis Cobbs Wrote: [ -> ]
(2018-07-17, 17:49)Johann Eisner Wrote: [ -> ]Wanted to try Scott's program. But no matter what I do, I always get the error when starting the .ocx file is missing. Although I have already copied them to the system32 folder. :-(

If you are running 64-bit Windows, you probably need to copy any ocx files to the SysWOW64 folder instead of the System32 folder. Also, you probably need to run regsvr32 from the command line:

http://www.ctimls.com/Support/KB/How%20T...er_dll.htm

That was the solution.
Many thanks.

Best Regards
Johann
(2018-07-17, 17:32)Roland Melkert Wrote: [ -> ]
(2018-07-17, 4:55)Knud Ahrnell Albrechtsen Wrote: [ -> ]Hi Roland

I am currently using Scotts.
I have tried yours now but it doesn't look like MLCad og LPUB3D supports your program.

Textures are a fairly new LDraw feature so not all software supports it (yet).

LPub should support it trough LDView though.

MLCad doesn't support textures as it is not maintained anymore.

Hi  Roland
I have now started using LDCad instead and it looks lige it supports textures.
But I have run into a couple of problems I hope you can help me with.
the first one i whitespaces in the image path. How fo I get it to handle this?
I have tried both:
T:\folder\My Folder\sticker.png
and
"T:\folder\My Folder\sticker.png"
and
'T:\folder\My Folder\sticker.png'
but it will not accept the path if there is whitespaces.
If I copy the sticker to C:\temp\Sticker.png then there is no problem

The other issue is that when I open the sticker.dat file in LPub3D with sticker in C:\temp it does not show the sticker, only an empty square.
The renderer in LPub3D is set to LDView.

Sticker in LDCad
[Image: ldcadsticker.png]
Sticker in LDView:
[Image: ldviewsticker.png]
Sticker in LPub3D
[Image: lpub3dsticker.png]
LDView 64bit version is 4.4 Alpha 2
LPub3D version is 2.2.2
(2018-08-25, 7:10)Knud Ahrnell Albrechtsen Wrote: [ -> ]the first one i whitespaces in the image path. How fo I get it to handle this?

I checked the sourcecode and you're right it will only use the first "word" as the filename, this because it can be followed by other stuff.

This is a bug, and will be fixed in 1.6c.


(2018-08-25, 7:10)Knud Ahrnell Albrechtsen Wrote: [ -> ]The other issue is that when I open the sticker.dat file in LPub3D with sticker in C:\temp it does not show the sticker, only an empty square.

Are you sure lpub is using the same LDView exe as when you run it standalone?

Secondly I'm not sure the current LPub3D version copies the texture files to its temporary output location (from where LDView generated its images). You might need to do that manually.
(2018-08-25, 17:04)Roland Melkert Wrote: [ -> ]
(2018-08-25, 7:10)Knud Ahrnell Albrechtsen Wrote: [ -> ]the first one i whitespaces in the image path. How fo I get it to handle this?

I checked the sourcecode and you're right it will only use the first "word" as the filename, this because it can be followed by other stuff.

This is a bug, and will be fixed in 1.6c.


(2018-08-25, 7:10)Knud Ahrnell Albrechtsen Wrote: [ -> ]The other issue is that when I open the sticker.dat file in LPub3D with sticker in C:\temp it does not show the sticker, only an empty square.

Are you sure lpub is using the same LDView exe as when you run it standalone?

Secondly I'm not sure the current LPub3D version copies the texture files to its temporary output location (from where LDView generated its images). You might need to do that manually.

Hi Roland
Thanks for the answers.

I will look forward to the fix in 1.6c Smile
(2018-08-25, 17:04)Roland Melkert Wrote: [ -> ]
(2018-08-25, 7:10)Knud Ahrnell Albrechtsen Wrote: [ -> ]the first one i whitespaces in the image path. How fo I get it to handle this?

I checked the sourcecode and you're right it will only use the first "word" as the filename, this because it can be followed by other stuff.

This is a bug, and will be fixed in 1.6c.


(2018-08-25, 7:10)Knud Ahrnell Albrechtsen Wrote: [ -> ]The other issue is that when I open the sticker.dat file in LPub3D with sticker in C:\temp it does not show the sticker, only an empty square.

Are you sure lpub is using the same LDView exe as when you run it standalone?

Secondly I'm not sure the current LPub3D version copies the texture files to its temporary output location (from where LDView generated its images). You might need to do that manually.

the next problem is to get the stickers shown when rendering in POV-Ray.
Is this possible???
Currently this is the issue.
Stickers in LDView (4.4 a):
[Image: dsb_ic3_ldview.png]

Stickers in POV-Ray (3.7)
[Image: dsb_ic3_povray.png]
LDView's POV export does not support textures. I think LDCad's POV export does support textures (although I'm not 100% sure of that). I have spent a fair amount of time trying to support textures in LDView's POV export, but haven't had any success. I haven't totally given up, but I'm not willing to promise anything at this time.
(2018-08-27, 16:54)Travis Cobbs Wrote: [ -> ]LDView's POV export does not support textures. I think LDCad's POV export does support textures (although I'm not 100% sure of that). I have spent a fair amount of time trying to support textures in LDView's POV export, but haven't had any success. I haven't totally given up, but I'm not willing to promise anything at this time.

Hi Travis

thanks for the reply.
I am using LDcad .6b
I cant seem to find an export option in any of the menues??
(2018-08-27, 18:07)Knud Ahrnell Albrechtsen Wrote: [ -> ]I am using LDcad .6b
I cant seem to find an export option in any of the menues??
view/edit views/export
or
alt+e
(2018-08-27, 18:57)Roland Melkert Wrote: [ -> ]
(2018-08-27, 18:07)Knud Ahrnell Albrechtsen Wrote: [ -> ]I am using LDcad .6b
I cant seem to find an export option in any of the menues??
view/edit views/export
or
alt+e

thanks
does it have a problem with whitespaces?
when i try to export LDCad creates the folder but then shuts down without creating the pov file.
(2018-08-27, 19:30)Knud Ahrnell Albrechtsen Wrote: [ -> ]thanks
does it have a problem with whitespaces?
when i try to export LDCad creates the folder but then shuts down without creating the pov file.

For the pov export all needed png's are copied into the pov export destination using generated names so spaces should not matter.
But if LDCad crashes during the export it might be the cause of it on that side, I'll have to look into this some more.
It would help me, if you send me your model so I can test it myself using similar input.

You can prevent the space in folder names by using relative filenames only (place the png in the same folder as the .dat)
Pages: 1 2 3 4 5