LDCad 1.6 (win+linux)


LDCad 1.6 (win+linux)
#1
Hello all,

I finally managed to finish the final 1.6 version of LDCad.

Mostly bug fixes and some scripting tweaks.

I've also added a new example/animation featuring the 8852 set.

       

As always the latest version can be downloaded here:
http://www.melkert.net/LDCad/download

This will be (99.5% certain) the last 1.x version excluding one or two maintenance (1.6a etc) versions.

This because I want to concentrate on setting up a new (HQ) LDraw rendering engine. This project might lead to a 2.0 version but I'm not sure of that jet.
Reply
RE: LDCad 1.6 (win+linux)
#2
(2017-06-13, 20:28)Roland Melkert Wrote: Hello all,

I finally managed to finish the final 1.6 version of LDCad.

Hi Roland,

Thanks! I think I found a bug though.

When I click Conditional Edges Method in the Prefs > LDraw menu the Static Edge Color is toggled.
Jaco van der Molen
lpub.binarybricks.nl
Reply
RE: LDCad 1.6 (win+linux)
#3
(2017-06-14, 7:41)Jaco van der Molen Wrote: When I click Conditional Edges Method in the Prefs > LDraw menu the Static Edge Color is toggled.

Stupid c++ switch statements Smile

This has been in all 1.6 versions I think, I'll fix it in the next maintenance version as you can switch it back and its a non often used option anyway.

Thanks for reporting (although I wished you did so 2 days earlier Wink  )
Reply
RE: LDCad 1.6 (win+linux)
#4
Hi Roland,

Something else very strange:
On my "old" Windows XP machine when I select one or more parts and want to select none I press Ctrl-shift-A to deselect nothing happens. It does not work.
The stranger part is that when I use remote control program like TeamViewer it does work!?
Even on my Mac.

What could this be?
I can remember it did work on previous versions of LDCad?
Jaco van der Molen
lpub.binarybricks.nl
Reply
RE: LDCad 1.6 (win+linux)
#5
(Yesterday, 19:57)Jaco van der Molen Wrote: Hi Roland,

Something else very strange:
On my "old" Windows XP machine when I select one or more parts and want to select none I press Ctrl-shift-A to deselect nothing happens. It does not work.
The stranger part is that when I use remote control program like TeamViewer it does work!?
Even on my Mac.

What could this be?
I can remember it did work on previous versions of LDCad?

The only thing I changed between those versions which could influence XP/hotkeys is the upgrade of the GCC compiler I used for windows builds

I'll have to check on my own ancient XP system to see if this is a universal problem.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)