LDCad Part Snapping missing/errors


Part Snapping missing/errors
#1
This is intended to be a catchall thread to let Roland know about missing/problematic part snapping info.

Note: make sure that the part you are reporting is official
Reply
RE: [LDCad] Part Snapping missing/errors
#2
75181 (Turntable Flat Base 4x4) is missing snap info
Reply
RE: [LDCad] Part Snapping missing/errors
#3
55817, Wheel 21x56 with 8 Spokes Armoured. No snap info for pinhole and the 8 holes on the sides.
Reply
RE: [LDCad] Part Snapping missing/errors
#4
All the flex-system hoses have no snap info.
Reply
RE: [LDCad] Part Snapping missing/errors
#5
The various components of the old 6x16 train assembly are missing snap info. I've added my own, as follows:

In the 6x16 base plate itself (736.dat), I added female snap cylinders for the two magnet holders, and for the two axles:

Code:
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 6 12] [pos=0 39 -140]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 6 12] [pos=0 39 140]
0 !LDCAD SNAP_CYL [group=axleR4] [gender=F] [caps=none] [secs=R 4 80] [pos=-40 42 -100] [ori=0 -1 0 1 0 0 0 0 1]
0 !LDCAD SNAP_CYL [group=axleR4] [gender=F] [caps=none] [secs=R 4 80] [pos=-40 42 100] [ori=0 -1 0 1 0 0 0 0 1]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=S 6 4] [pos=-50 8 -150] [grid=2 16 100 20]

In the magnet holder (735.dat), I added a male cylinder for mating to the base, along with a pair of point snaps on the magnet itself (for coupling two magnets together):

Code:
0 !LDCAD SNAP_CYL [gender=M] [caps=one] [secs=R 6 12]
0 !LDCAD SNAP_GEN [group=mag] [gender=M] [bounding=pnt] [match=group] [pos=56 -5 0]
0 !LDCAD SNAP_GEN [group=mag] [gender=F] [bounding=pnt] [match=group] [pos=56 -5 0] [ori=-1 0 0 0 1 0 0 0 -1]

And in the wheel/axle shortcut (243c02.dat) I added the male cylinder snap for mating to the base:

Code:
0 !LDCAD SNAP_CYL [group=axleR4] [gender=M] [caps=none] [secs=R 4 80] [pos=-40 0 0] [ori=0 -1 0 1 0 0 0 0 1]

Feedback/suggestions welcome!
Reply
RE: [LDCad] Part Snapping missing/errors
#6
60478.dat, Plate 1x2 with Handle on End. Mirror doesn't work correctly. Probably missing info
Reply
RE: [LDCad] Part Snapping missing/errors
#8
(2020-01-02, 2:06)Orion Pobursky Wrote: 60478.dat, Plate 1x2 with Handle on End. Mirror doesn't work correctly. Probably missing info
That one isn't symmetrical in the X direction. Mirroring only works without shadow info for parts that are x symmetric.

If you don't want to wait on the update it's easily fixed by adding a mirror meta to the part (shadow) using a 'base flip' of whatever axis is symmetrical (Z in this case).
Reply
RE: [LDCad] Part Snapping missing/errors
#7
(2019-12-31, 2:30)Orion Pobursky Wrote: This is intended to be a catchall thread to let Roland know about missing/problematic part snapping info.
Good idea.

I'll try to include things posted here in the next release, but keep in mind I'm already working on the 1903 parts.
Reply
RE: Part Snapping missing/errors
#9
15207 has no bottom snap info
Reply
RE: Part Snapping missing/errors - 99012
#10
99012 (Technic Rotor 1 Blade 8L with Peghole and Axlehole) is missing mirroring info (and inherited connectivity can be refined).
Code:
0 !LDCAD MIRROR_INFO [baseFlip=Z]
0 !LDCAD SNAP_CLEAR [ID=axleHole]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=A 6 20] [pos=0 30 0] [ori=-1 0 0 0 1 0 0 0 -1]
Reply
RE: Part Snapping missing/errors
#11
I have problems with part-snapping of roller coaster tracks on top of other parts, i.e. 25061 (90 degree), 26561 (ramp), 34738 (S-shape), 26599 (S-shape lower)... They snap perfectly "under" another part, but not on top of it - so I let them snap below and move 2 plates (16 LDU) upwards. I don't know if this is my fault or if the parts are missing snapping info.
Reply
RE: Part Snapping missing/errors
#12
(2020-03-10, 20:09)Stefan Frenz Wrote: I have problems with part-snapping of roller coaster tracks on top of other parts, i.e. 25061 (90 degree), 26561 (ramp), 34738 (S-shape), 26599 (S-shape lower)... They snap perfectly "under" another part, but not on top of it - so I let them snap below and move 2 plates (16 LDU) upwards. I don't know if this is my fault or if the parts are missing snapping info.
This is the symptom of no snapping at all. It works from top because the part inherits connectivity of studs, but there is no common structure on plate bottom to allow subparting and inheritance.
Reply
RE: Part Snapping missing/errors
#13
Part 6628 is missing bar connectivity inside pin section:
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 4 18] [pos=20 0 0] [ori=0 1 0 1 0 0 0 0 -1]
See set 42106 for usage example.
Reply
RE: Part Snapping missing/errors
#14
I've finished the snapping info for the 1903 library.

I also processed all thing people mailed me about and things mentioned above up to message #13.

Thanks for all whom contributed.

You can (always) download the latest seed file at:
http://www.melkert.net/action/download/shadow.sf

Just replace the old one in LDCad's seeds location  (subfolder of the exe file).

Some notes

@Orion
I can't find 75181, did you mean 61485 ? although that one has snapping info.

"All the flex-system hoses have no snap info."
They do have info, but only for the end caps, or did you mean the bended parts. LDCad doesn't support that at the moment, maybe in 1.7

@N.W.Perry
I applied your #5 definitions with some minor changes which should make it somewhat easier to use. Feel free to review.
Reply
RE: Part Snapping missing/errors
#15
(2020-03-14, 2:50)Roland Melkert Wrote: @Orion
I can't find 75181, did you mean 61485 ? although that one has snapping info.

Yes. (75181 is the set I was working on). Unless the info is in this update, then my current shadow library does not have it

(2020-03-14, 2:50)Roland Melkert Wrote: "All the flex-system hoses have no snap info."
They do have info, but only for the end caps, or did you mean the bended parts. LDCad doesn't support that at the moment, maybe in 1.7

Not the bent ones, the straight ones. And it would be helpful to have this info for the middle section.
Reply
RE: Part Snapping missing/errors
#17
(2020-03-14, 2:50)Roland Melkert Wrote: @N.W.Perry
I applied your #5 definitions with some minor changes which should make it somewhat easier to use. Feel free to review.

Everything looks good to me!
Reply
RE: Part Snapping missing/errors
#16
The door element 60616a does not snap into 60596 (but for example 60623 does) and the window element 57895 does not snap into 57894.
Reply
RE: Part Snapping missing/errors
#18
(2020-03-15, 10:51)Stefan Frenz Wrote: The door element 60616a does not snap into 60596 (but for example 60623 does) and the window element 57895 does not snap into 57894.
Did you update to the above shadow?

Because only 57894 doesn't have snap information in that version.

I'll add 57894 to the next update.
Reply
RE: Part Snapping missing/errors
#19
(2020-03-16, 19:19)Roland Melkert Wrote: Did you update to the above shadow?
On the tested installation: not yet, sorry. Sad
Reply
RE: Part Snapping missing/errors
#20
The hose reel 2585 does not snap into the hose reel holder 2584 (with shadow.sf). Not a problem, but maybe nice to have. Smile
Reply
RE: Part Snapping missing/errors
#21
There’s no snap info for the center pin in the 2x2 Turntable (3680 and 3679)
Reply
RE: Part Snapping missing/errors
#22
15207.dat is missing bottom stud connectivity. I copied from 30413.
Reply
RE: Part Snapping missing/errors
#23
I am not sure, if this is so wanted.
The middle hole of the Servomotor (99498) have no info.


Attached Files Thumbnail(s)
   
If nothing goes right, go left.
Reply
RE: Part Snapping missing/errors
#24
15301 shooter bottom is missing connectivity.
Code:
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 6 4] [center=true] [pos=0 -2 -30] [grid=1 4 0 20]

Snapping for arrow is kind of missing in 15400 shooter assembly. I propose
Code:
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 5.5 9   R 4 35.9   R 4 45.1] [slide=true] [pos=0 8.446736 -48] [ori=-1 0 0 0 -0.017452 -0.999848 0 -0.999848 0.017452]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 5.5 9   R 4 35.9   R 4 45.1] [slide=true] [pos=0 8.446736 48] [ori=1 0 0 0 -0.017452 -0.999848 0 0.999848 -0.017452]
...questionnable, but works well!
Reply
RE: Part Snapping missing/errors
#25
Pneumatic valve with axle hole 19474

No information on the hose connections
If nothing goes right, go left.
Reply
RE: Part Snapping missing/errors
#26
(2019-12-31, 2:30)Orion Pobursky Wrote: This is intended to be a catchall thread to let Roland know about missing/problematic part snapping info.

Not sure if this would need a new thread, but I'm introducing a new (shadow) meta in 1.6d

!LDCAD HINTS

It can (also) be used to override the rest rotation of parts in the part bin.

I used it to rotate panels so their pattern is faced forwards.

If anyone thinks other parts need rotating let me know.
Reply
RE: Part Snapping missing/errors
#27
Microfig 85863.dat (or rather its sub-part -s01) is missing bottom snap info.
Reply
RE: Part Snapping missing/errors
#28
28326 (Car Mudguard 4x3x1) has no bottom snap info
Reply
RE: Part Snapping missing/errors
#29
30301 has wrong bottom info
Reply
RE: Part Snapping missing/errors
#30
(2020-04-02, 9:55)Gerald Lasser Wrote: 30301 has wrong bottom info

??
Can't find that number.
Reply
RE: Part Snapping missing/errors
#31
(2020-04-02, 10:59)Magnus Forsberg Wrote: ??
Can't find that number.

Typo: 30201
Reply
RE: Part Snapping missing/errors
#32
(2020-04-02, 15:04)Gerald Lasser Wrote: Typo: 30201

These kinds of mistakes happen when I go trough too many parts in one go Smile
Reply
RE: Part Snapping missing/errors
#33
Round tile 2x2 (14769.dat) is missing the connection on the center underside stud.

For that matter, I've noticed that snapping info is not generally included for any of the in-between underside studs/tubes on 2x or larger parts (not to mention the space between studs on the top surface). I'm sure this is intentional and I can fully understand the reason.

But I think it's worth including for the 2x2 round tile, since having that connection is fundamental to the (re-)design of the part.
Reply
RE: Part Snapping missing/errors
#34
(Yesterday, 17:42)N. W. Perry Wrote: Round tile 2x2 (14769.dat) is missing the connection on the center underside stud.

For that matter, I've noticed that snapping info is not generally included for any of the in-between underside studs/tubes on 2x or larger parts (not to mention the space between studs on the top surface). I'm sure this is intentional and I can fully understand the reason.

But I think it's worth including for the 2x2 round tile, since having that connection is fundamental to the (re-)design of the part.

Yes those are missing on purpose.

The main reason being the LDCad snapping engine only searches for a single connection pair when dragging stuff around. So the middle 6ldu hole would make it snap 'wrong' 95% of the time.

That said, you might be right about this part being used more often in that way.

This is the exact reason I'm considering adding a 'priority' property to the snapping metas in 1.7, which should reduce the false matches considerably.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)