LDraw.org Discussion Forums
[LDCad] Part Snapping missing/errors - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: LDraw Editors and Viewers (https://forums.ldraw.org/forum-11.html)
+--- Thread: [LDCad] Part Snapping missing/errors (/thread-23807.html)

Pages: 1 2 3 4 5 6 7


Part Snapping missing/errors - Orion Pobursky - 2019-12-31

This is intended to be a catchall thread to let Roland know about missing/problematic part snapping info.

Note: make sure that the part you are reporting is official


RE: [LDCad] Part Snapping missing/errors - Orion Pobursky - 2019-12-31

75181 (Turntable Flat Base 4x4) is missing snap info


RE: [LDCad] Part Snapping missing/errors - Orion Pobursky - 2019-12-31

55817, Wheel 21x56 with 8 Spokes Armoured. No snap info for pinhole and the 8 holes on the sides.


RE: [LDCad] Part Snapping missing/errors - Orion Pobursky - 2019-12-31

All the flex-system hoses have no snap info.


RE: [LDCad] Part Snapping missing/errors - N. W. Perry - 2020-01-01

The various components of the old 6x16 train assembly are missing snap info. I've added my own, as follows:

In the 6x16 base plate itself (736.dat), I added female snap cylinders for the two magnet holders, and for the two axles:

Code:
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 6 12] [pos=0 39 -140]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 6 12] [pos=0 39 140]
0 !LDCAD SNAP_CYL [group=axleR4] [gender=F] [caps=none] [secs=R 4 80] [pos=-40 42 -100] [ori=0 -1 0 1 0 0 0 0 1]
0 !LDCAD SNAP_CYL [group=axleR4] [gender=F] [caps=none] [secs=R 4 80] [pos=-40 42 100] [ori=0 -1 0 1 0 0 0 0 1]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=S 6 4] [pos=-50 8 -150] [grid=2 16 100 20]

In the magnet holder (735.dat), I added a male cylinder for mating to the base, along with a pair of point snaps on the magnet itself (for coupling two magnets together):

Code:
0 !LDCAD SNAP_CYL [gender=M] [caps=one] [secs=R 6 12]
0 !LDCAD SNAP_GEN [group=mag] [gender=M] [bounding=pnt] [match=group] [pos=56 -5 0]
0 !LDCAD SNAP_GEN [group=mag] [gender=F] [bounding=pnt] [match=group] [pos=56 -5 0] [ori=-1 0 0 0 1 0 0 0 -1]

And in the wheel/axle shortcut (243c02.dat) I added the male cylinder snap for mating to the base:

Code:
0 !LDCAD SNAP_CYL [group=axleR4] [gender=M] [caps=none] [secs=R 4 80] [pos=-40 0 0] [ori=0 -1 0 1 0 0 0 0 1]

Feedback/suggestions welcome!


RE: [LDCad] Part Snapping missing/errors - Orion Pobursky - 2020-01-02

60478.dat, Plate 1x2 with Handle on End. Mirror doesn't work correctly. Probably missing info


RE: [LDCad] Part Snapping missing/errors - Roland Melkert - 2020-01-02

(2019-12-31, 2:30)Orion Pobursky Wrote: This is intended to be a catchall thread to let Roland know about missing/problematic part snapping info.
Good idea.

I'll try to include things posted here in the next release, but keep in mind I'm already working on the 1903 parts.


RE: [LDCad] Part Snapping missing/errors - Roland Melkert - 2020-01-02

(2020-01-02, 2:06)Orion Pobursky Wrote: 60478.dat, Plate 1x2 with Handle on End. Mirror doesn't work correctly. Probably missing info
That one isn't symmetrical in the X direction. Mirroring only works without shadow info for parts that are x symmetric.

If you don't want to wait on the update it's easily fixed by adding a mirror meta to the part (shadow) using a 'base flip' of whatever axis is symmetrical (Z in this case).


RE: Part Snapping missing/errors - Orion Pobursky - 2020-02-21

15207 has no bottom snap info


RE: Part Snapping missing/errors - 99012 - Philippe Hurbain - 2020-02-23

99012 (Technic Rotor 1 Blade 8L with Peghole and Axlehole) is missing mirroring info (and inherited connectivity can be refined).
Code:
0 !LDCAD MIRROR_INFO [baseFlip=Z]
0 !LDCAD SNAP_CLEAR [ID=axleHole]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=A 6 20] [pos=0 30 0] [ori=-1 0 0 0 1 0 0 0 -1]