LDCad Part Snapping missing/errors


RE: [LDCad] Part Snapping missing/errors
#5
The various components of the old 6x16 train assembly are missing snap info. I've added my own, as follows:

In the 6x16 base plate itself (736.dat), I added female snap cylinders for the two magnet holders, and for the two axles:

Code:
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 6 12] [pos=0 39 -140]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=R 6 12] [pos=0 39 140]
0 !LDCAD SNAP_CYL [group=axleR4] [gender=F] [caps=none] [secs=R 4 80] [pos=-40 42 -100] [ori=0 -1 0 1 0 0 0 0 1]
0 !LDCAD SNAP_CYL [group=axleR4] [gender=F] [caps=none] [secs=R 4 80] [pos=-40 42 100] [ori=0 -1 0 1 0 0 0 0 1]
0 !LDCAD SNAP_CYL [gender=F] [caps=one] [secs=S 6 4] [pos=-50 8 -150] [grid=2 16 100 20]

In the magnet holder (735.dat), I added a male cylinder for mating to the base, along with a pair of point snaps on the magnet itself (for coupling two magnets together):

Code:
0 !LDCAD SNAP_CYL [gender=M] [caps=one] [secs=R 6 12]
0 !LDCAD SNAP_GEN [group=mag] [gender=M] [bounding=pnt] [match=group] [pos=56 -5 0]
0 !LDCAD SNAP_GEN [group=mag] [gender=F] [bounding=pnt] [match=group] [pos=56 -5 0] [ori=-1 0 0 0 1 0 0 0 -1]

And in the wheel/axle shortcut (243c02.dat) I added the male cylinder snap for mating to the base:

Code:
0 !LDCAD SNAP_CYL [group=axleR4] [gender=M] [caps=none] [secs=R 4 80] [pos=-40 0 0] [ori=0 -1 0 1 0 0 0 0 1]

Feedback/suggestions welcome!
Reply
« Next Oldest | Next Newest »



Messages In This Thread
RE: [LDCad] Part Snapping missing/errors - by N. W. Perry - 2020-01-01, 1:41

Forum Jump:


Users browsing this thread: 1 Guest(s)