LSynth and MLCAD not happy.


LSynth and MLCAD not happy.
#1
I need help guys, LSynth will not work for me and I have spent that last 4hrs going around in circles.

Windows 7/64bit
MLCAD 3.30
LSynth 3.1
Everything installed in the typical locations
mlcad.ini file set correctly

I have everything and I mean everything exactly as is written in holly-woods tutorial. When trying to run LSynth the command console (system32\cmd.exe) says the following, 'C:\Users\J' is not recognized as an internal or external command, operable program or batch file. The system cannot find the path specified. I had to take video of the console pop up and slow it down and freeze it to see what it says. I also get the first pop up shown on holly-woods troubleshooting page. I DO have the correct path set in the ini file though so this is what's confusing me!! I even set the wrong path and it took away the ability to even add a LSynth command in MLCAD, so MLCAD is reading the ini. I'm not getting any of the other errors so I don't know. any help would be greatly appreciated, thanks.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#2
Hi,

get a try with the latest AIOI:

http://www.ldraw.org/GetStarted-Win.html

w.
LEGO ergo sum
Reply
Re: LSynth and MLCAD not happy.
#5
Willy Tschager Wrote:
-------------------------------------------------------
> Hi,
>
> get a try with the latest AIOI:
>
> http://www.ldraw.org/GetStarted-Win.html
>
> w.


Okay just did a clean and fresh install of the linked AIOI, didn't edit anything and it still doesn't work. MLCAD gives me the ability to "add a command" in LSynth but when trying to run it seems like Windows is freaking out for some reason.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#3
It looks like something is having trouble with a path containing spaces. You could possibly fix that yourself with quotes, or try the latest AIOI like Willy suggests.
Reply
Re: LSynth and MLCAD not happy.
#4
I'll give the latest AIOI a try. I do have quotes in the ini path to deal with the spaces however. It's odd because if the path isn't correct, MLCAD will not find LSynth to even allow you to make the first command.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#8
I believe lsynthcp.exe is the correct executable. So the Path is "C:\Program Files (x86)\LDraw\LSynth"? I don't remember seeing the (x86) before. What version of Windows is this? Is it 64 bit? Maybe the problem isn't the path. It could be a problem calling the 32bit executable, or some sort of issue with permissions.
Reply
Re: LSynth and MLCAD not happy.
#9
Yep, the (x86) is the program files location for 32bit stuff. The All in One Installer refers to 64bit and that location on the page so I can only assume it has been tested and worked for others. This is my first time though running this setup on this system so I haven't a clue.

I have even tried to run that exe as well as MLCAD in compatibility mode just in case but that didn't work either. I did give all associated files full control in permissions thinking that was it was well, obviously no luck.

This issue is killing me, I need it to work.

I guess the big question is why am I getting this warning - 'C:\Users\J' is not recognized as an internal or external command, operable program or batch file. The system cannot find the path specified.

If I have the correct path and I am getting this warning...
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#10
What's the path to your home directory? Does it have a space in it after the J?
Reply
Re: LSynth and MLCAD not happy.
#11
Nope so space, J&J, maybe it doesn't like the "&"
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#12
maybe. On unix that character is reserved for running a program in the background.
Reply
Re: LSynth and MLCAD not happy.
#6
Here is a short video showing what is going on. All is stock as per the AIOI. I did modify the scan list only in the ini as you will see. If you do a pause/play while I get the error message you can read what it says.

http://youtu.be/T20MaRtiN7A
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#7
Is there supposed to be a LSynth.exe file in the root LSynth folder? The only exe that I have is the lsynthcp.exe in the bin folder.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#13
I have tried it with both programs right from root C: though, it didn't help.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#14
I'm not sure what you mean by that.

Can you run lsynth on the command line?

"C:\Program Files (x86)\LDraw\LSynth\lsynthcp.exe" "c:\somewhere\myfile.ldr"
Reply
Re: LSynth and MLCAD not happy.
#15
sorry, I had all the software installed in C:\LDrawAPPs at one point.

I did run it in the command line but not to a file as you have just suggested, I will give it a go. Thanks for the suggestion.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#16
Wait, I just peeked at the source code. Looks like it needs a second ldr filename for the output.
Run this for help on command line usage.

"C:\Program Files (x86)\LDraw\LSynth\lsynthcp.exe" -h
Reply
Re: LSynth and MLCAD not happy.
#19
I stuck in the root to be easy... BUT there's been a development.

I created another admin account without a symbol in the name and installed the AIOI again and it WORKED!!!!

Could it be because of the "&" in my User name?? What am I going to do about that now...
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#22
Ah, looks like you beat me to it.
Reply
Re: LSynth and MLCAD not happy.
#17
Yep, figured that one out the hard way LOL...

It said something of a clue I think... "Failed to open file C:\LSynthtemp.ldr for reading"

Maybe my whole PC is messing with the permissions. Going to have to look into this I think.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#18
I'd guess that file doesn't exist. Why would it be in the root directory?

What was the exact command line that produced this message?
Reply
Re: LSynth and MLCAD not happy.
#21
Anyhow, if I had to guess at this point I'd say MLCad is trying to make a temporary copy of your ldr file to pass to lsynth, and it wants to make it somewhere in your home directory structure. But that & is confusing it so maybe it tries to put it in the root directory where it has no permission.

I'd consider changing your username from j&j to something normal like jnj.
Reply
Re: LSynth and MLCAD not happy.
#23
I did change my user name but sadly it didn't change the directory name, I'm searching for a solution to that. Can imagine it could be a little tough since so many things are tied to it.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#20
Hey Don, thanks so much for the help so far, I wouldn't have even dreamed this issue up.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#24
I'd do a google search. There's gotta be someone else who's managed to change the directory name.
Reply
Re: LSynth and MLCAD not happy.
#25
Ouch. This sounds painful. good luck...

"You cannot change the name on the
User account folder, only the Username itself. The only solution there would
be to create a new user folder for yourself and copy the data from your
current one into it.

How to Copy User Data to a New User Profile
http://support.microsoft.com/?kbid=811151

Note that one step not listed in the article is that after creating the
destination profile you must log into it once first to create the necessary
file structure before you do the copy procedure."
Reply
Re: LSynth and MLCAD not happy.
#26
Thanks Don. I found some instructions on how to change the directory name and as crazy as the idea sounded I decided to give it a try.
I used this link: http://www.sevenforums.com/tutorials/147...-name.html

It worked and now LSynth actually works BUT... I noticed some things are broken, for some reason Thunderbird won't launch external links anymore and I'm sure I will find more issues. Changing an entire account directory name must have some consequences.

Good to know we solved the problem. Hopefully this thread may help other crazy people who put symbols in their usernames.

Thanks again Don for all your help, greatly appreciated. (tu)

sorry Don, spelled you as Dan...
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#27
Hei!

The ampersand "&" is very often used in programming languages. In the commandline the "&" is used to separate multiple commands on one command line. Cmd.exe runs the first command, and then the second command.

But there is a way to "escape" this function:
You have to add an "^" before the "&". So your path, that you have to write, would be something like this: "C:\Users\J^&J"


Martin
Reply
Re: LSynth and MLCAD not happy.
#28
Thanks Martin, it was a poor choice for me to use that in my user name, im very surprised that no other program was effected until now. All fixed though so I am happy.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#29
It would be nice if you could sum up the above in a paragraph I can add to my troubleshooting page:

http://www.holly-wood.it/lsynth/troubleshooting-en.html

Thx, in advanced,

w.
LEGO ergo sum
Reply
Re: LSynth and MLCAD not happy.
#30
For sure, I'll take care of it when I get home tonight. But to put it simply, a user cannot have a symbol in the name of their user folder. Haven't tested how it would react with a symbol in any folder in its path, probably just a bad.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#31
Willy hope this is okay, if not feel free to add or take away as you wish. If there is anything else you need please advise.


You run LSynth and see a Command Prompt box flash (or stay depending on computer speed) stating the following 'C:\Users\(part of your username here) is not recognized as an internal or external command, operable program or batch file. The system cannot find the path specified. and also get No Synthesis as well as the MLCAD dialog box stating "LSynth execution failed!" Possible cause - MLCAD is unable to access the LSynth application folder due to a symbol (ie. @#$%^&*) in your username. Solution - Install MLCAD along with LSynth onto another user account with a standard user name, create an account if needed. If it fixes the problem you can transfer all your files to the new user account (long way) or (short way) you can change your user name properly by following these instructions LINK. You can NOT just change your user name in the user account settings. You need to make a change in the windows registry to change all the associated folders. Applications that are not integrated into the Windows system may need to be re-installed. ie Java Programs.
______________________________________________
OS = Ubuntu 14.04 LTS (64bit)
Reply
Re: LSynth and MLCAD not happy.
#32
Many thx Jason! I'm gonna push this with the next update of the site.

w.
LEGO ergo sum
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)