LDraw.org Discussion Forums

Full Version: LSynth and MLCAD not happy.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
I need help guys, LSynth will not work for me and I have spent that last 4hrs going around in circles.

Windows 7/64bit
MLCAD 3.30
LSynth 3.1
Everything installed in the typical locations
mlcad.ini file set correctly

I have everything and I mean everything exactly as is written in holly-woods tutorial. When trying to run LSynth the command console (system32\cmd.exe) says the following, 'C:\Users\J' is not recognized as an internal or external command, operable program or batch file. The system cannot find the path specified. I had to take video of the console pop up and slow it down and freeze it to see what it says. I also get the first pop up shown on holly-woods troubleshooting page. I DO have the correct path set in the ini file though so this is what's confusing me!! I even set the wrong path and it took away the ability to even add a LSynth command in MLCAD, so MLCAD is reading the ini. I'm not getting any of the other errors so I don't know. any help would be greatly appreciated, thanks.
Hi,

get a try with the latest AIOI:

http://www.ldraw.org/GetStarted-Win.html

w.
It looks like something is having trouble with a path containing spaces. You could possibly fix that yourself with quotes, or try the latest AIOI like Willy suggests.
I'll give the latest AIOI a try. I do have quotes in the ini path to deal with the spaces however. It's odd because if the path isn't correct, MLCAD will not find LSynth to even allow you to make the first command.
Willy Tschager Wrote:
-------------------------------------------------------
> Hi,
>
> get a try with the latest AIOI:
>
> http://www.ldraw.org/GetStarted-Win.html
>
> w.


Okay just did a clean and fresh install of the linked AIOI, didn't edit anything and it still doesn't work. MLCAD gives me the ability to "add a command" in LSynth but when trying to run it seems like Windows is freaking out for some reason.
Here is a short video showing what is going on. All is stock as per the AIOI. I did modify the scan list only in the ini as you will see. If you do a pause/play while I get the error message you can read what it says.

http://youtu.be/T20MaRtiN7A
Is there supposed to be a LSynth.exe file in the root LSynth folder? The only exe that I have is the lsynthcp.exe in the bin folder.
I believe lsynthcp.exe is the correct executable. So the Path is "C:\Program Files (x86)\LDraw\LSynth"? I don't remember seeing the (x86) before. What version of Windows is this? Is it 64 bit? Maybe the problem isn't the path. It could be a problem calling the 32bit executable, or some sort of issue with permissions.
Yep, the (x86) is the program files location for 32bit stuff. The All in One Installer refers to 64bit and that location on the page so I can only assume it has been tested and worked for others. This is my first time though running this setup on this system so I haven't a clue.

I have even tried to run that exe as well as MLCAD in compatibility mode just in case but that didn't work either. I did give all associated files full control in permissions thinking that was it was well, obviously no luck.

This issue is killing me, I need it to work.

I guess the big question is why am I getting this warning - 'C:\Users\J' is not recognized as an internal or external command, operable program or batch file. The system cannot find the path specified.

If I have the correct path and I am getting this warning...
What's the path to your home directory? Does it have a space in it after the J?
Pages: 1 2 3 4