LDCad Flex Hose problems


LDCad Flex Hose problems
#1
I'm trying to update some of my models for the OMR and I'm having problems with generating new parts for the Hose Flexible 8.5L without Tabs. This part should generate with a fixed 51 segments, 50 754.dat and 1 756.dat. This doesn't happen. Even if I force the length to be 170 ldu, the extra segments just generate with a null matrix. Any help on how to force LDCad to render the correct fixed length is appreciated.
Reply
RE: LDCad Flex Hose problems
#2
(2019-01-07, 12:42)Orion Pobursky Wrote: I'm trying to update some of my models for the OMR and I'm having problems with generating new parts for the Hose Flexible 8.5L without Tabs. This part should generate with a fixed 51 segments, 50 754.dat and 1 756.dat. This doesn't happen. Even if I force the length to be 170 ldu, the extra segments just generate with a null matrix. Any help on how to force LDCad to render the correct fixed length is appreciated.
My own experiments with setting a fixed length for flex parts was not very conclusive. I tested a bit with your hose, it mostly works fine, but generates a variable number of segments depending of constraints/control points. To get the right number, I simply adjusted the control point handles unti I got the right length. One problem is that in nested mode where I can adjust the handles I don't see that number, it only appears when I switch back to normal mode and hover on the part (it is displayed in status bar). The other problem is that length is displayed in mm while number of segments would be more convenient. This is easy to change: edit the flex part (or if you want to make the change definitive, edit the template itself). Session -> edit header -> Path tab -> change length display to "segs"
Reply
RE: LDCad Flex Hose problems
#3
(2019-01-07, 14:34)Philippe Hurbain Wrote: My own experiments with setting a fixed length for flex parts was not very conclusive. I tested a bit with your hose, it mostly works fine, but generates a variable number of segments depending of constraints/control points. To get the right number, I simply adjusted the control point handles unti I got the right length. One problem is that in nested mode where I can adjust the handles I don't see that number, it only appears when I switch back to normal mode and hover on the part (it is displayed in status bar). The other problem is that length is displayed in mm while number of segments would be more convenient. This is easy to change: edit the flex part (or if you want to make the change definitive, edit the template itself). Session -> edit header -> Path tab -> change length display to "segs"

You could also play with the segment size parameter of the two skin meta's. Those are set to 50% in the template to ensure the wide overlap of segments.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)