[LDPartEditor] 0.8.42 Beta Released (Bug fix / open *.dat with LDPartEditor.exe)


[LDPartEditor] 0.8.42 Beta Released (Bug fix / open *.dat with LDPartEditor.exe)
#1
Hi,

this release is mainly a critical bug fix, but it includes one handy feature: You can now open *.dat files from the Windows file explorer.

  1. Select a *.dat file
  2. Open the context menu
  3. Select "Open with"
  4. Select "Choose another app"
  5. Browse for LDPartEditor.exe

[Image: imgDuke2.png]
As always, you can download LDPE from this page:
http://nilsschmidt1337.github.io/ldparteditor/

Changelog:
(1 new feature and 3 bug fixes)

With this release you will be able to...
  • ...open *.dat files with LDPartEditor from the Windows file explorer ("Open with..." and select LDPartEditor.exe).

The following critical issues were fixed:
  1. Fixed a rare but critical undo/redo bug.
  2. Fixed a synchronization bug between the text and 3D editor.
  3. Fixed a bug which could freeze the text editor.

What will the next release 0.8.43 deliver? An improved version of Lines2Pattern, bug fixes.



The program was tested intensively with "real world" files.
However, it is still a beta version and something can go wrong in about 140.000 lines of code.

Make sure that you choose the right architecture for your OS and Java Virtual Machine (JVM) (64bit or 32bit).
A short guide how to check if a 64bit JVM is installed on your system is located at the bottom of this message.

  1. Download the zip-Archive
  2. Extract the archive content to the location of your choice
  3. On windows, double-click "LDPartEditor.exe" to start LDPE.
  4. On linux/mac, you have to excecute the shell script "run.sh" to start LDPE.
Alternatively, you can download a setup file to install LDPE on Windows.
When you install/extract LDPE on Windows you will find your LDPE configuration files under
{drive}\Users\{user}\AppData\Roaming\LDPartEditor
It is not recommended to use the "update.bat" script when you installed LDPE via the setup file.
Manually install the new version instead.

Please note that this software is in the beta stage. Although, this version was tested, there are already known issues  for this release. There is a potential risk of data loss.

You can search for updates if you do the following steps:

  1. On windows, double-click "update.bat" to search for updates.
  2. On linux/mac, you have to excecute the shell script "update.sh".

It is not recommended to use the "update.bat" script when you installed LDPE via the setup file.
Manually install the new version instead.

I listen carefully to your requests and possible complaints. Please leave me a message, with your thoughts and wishes to further improve the software.

LDPE is a 3D CAD application: The overall system requirements are higher. While I recommend to use a powerful 64-bit multicore system, it could be possible, to run LDPE on older machines as well.

System Requirements:


Minimum System Requirements:
  • 64-bit Java Runtime Environment (JRE) 1.8
  • OpenGL 2.1 compatible Graphics Card
  • Operating System (64-bit): Windows [7 or newer], Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • CPU: Multicore-Processor e.g. Intel Core 2 Duo or AMD Athlon II (>2.0Ghz)
  • RAM: 4GB
  • Video-Memory: 1 GB
  • Free Disk Space: 100 MB
Recommended Requirements:
  • Operating System (64bit): Windows 7,8,10, Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • OpenGL 3.3 compatible Graphics Card
  • CPU: Multicore-Processor with 4 cores (or more)
  • RAM: >4 GB
  • Video-Memory: >1 GB
  • Free Disk Space: 512 MB
  • For a faster start, LDPartEditor and the LDraw™ library should be installed on an SSD.
--------------------------------------------------------------------------------
How to check your JVM version (32- or 64-bit):
--------------------------------------------------------------------------------

You can try on the command line:

Code:
java -d64 version

If it's not a 64-bit version, you'll get a message that looks like:
This Java instance does not support a 64-bit JVM. Please install the desired version.
Reply
RE: [LDPartEditor] - Launch from explorer
#2
(2018-01-23, 20:36)Nils Schmidt Wrote: this release is mainly a critical bug fix, but it includes one handy feature: You can now open *.dat files from the Windows file explorer.
Highly appreciated, missed that. But there is a small setback: even if LDPE is already opened, it launches a new instance (with increased startup time) instead of just adding a new tab in running LDPE.
Reply
RE: [LDPartEditor] - Launch from explorer
#4
(2018-01-24, 8:10)Philippe Hurbain Wrote: it launches a new instance (with increased startup time) instead of just adding a new tab in running LDPE.

Strange.
On my machine it works fine.
It looks like a new instance is opened (it takes about 1 or 2 seconds, I get a brief glimpce of it) but then it "turns itself" into a new tab.

I have dat-files associated with LDDP. How do I tell windows to also associate it with LDPE?
Now, I have to right click on a file, choose "Open with/choose an other app", scroll the list, and select LDPE in the list.

When I want to open a file with DATHeader, it is already there, in the right click meny.
All I do is choose "Open with/DATHeader" in the menu.

I can't see LDPE in the Task Manager. All I see there is "Java Platform SE binary".
Reply
RE: [LDPartEditor] - Launch from explorer
#6
(2018-01-24, 16:38)Magnus Forsberg Wrote:
(2018-01-24, 8:10)Philippe Hurbain Wrote: it launches a new instance (with increased startup time) instead of just adding a new tab in running LDPE.

Strange.
On my machine it works fine.
It looks like a new instance is opened (it takes about 1 or 2 seconds, I get a brief glimpce of it) but then it "turns itself" into a new tab.

I have dat-files associated with LDDP. How do I tell windows to also associate it with LDPE?
Now, I have to right click on a file, choose "Open with/choose an other app", scroll the list, and select LDPE in the list.

When I want to open a file with DATHeader, it is already there, in the right click meny.
All I do is choose "Open with/DATHeader" in the menu.

I can't see LDPE in the Task Manager. All I see there is "Java Platform SE binary".

I will inlcude an option to associate *.dat files to LDPE in the next installer (Setup.exe) (#680).
Then you don't have to struggle with your Windows configuration.

Workaround: You can drag & drop *.dat files on a shortcut to LDPartEditor.exe and they will be opened.
Reply
RE: [LDPartEditor] - Launch from explorer
#7
(2018-01-24, 16:38)Magnus Forsberg Wrote:
(2018-01-24, 8:10)Philippe Hurbain Wrote: it launches a new instance (with increased startup time) instead of just adding a new tab in running LDPE.

Strange.
On my machine it works fine.
It looks like a new instance is opened (it takes about 1 or 2 seconds, I get a brief glimpce of it) but then it "turns itself" into a new tab.
Ah, yes, it mostly works: if I open a part file with LDPE from explorer then another part with the same method, I get only one LDPE instance. But (and that's how I tried) if I launch LDPE exe, load a file through LDPE open function, then open a part file from windows explorer, I get a second instance.


Quote:I have dat-files associated with LDDP. How do I tell windows to also associate it with LDPE?
Now, I have to right click on a file, choose "Open with/choose an other app", scroll the list, and select LDPE in the list.

When I want to open a file with DATHeader, it is already there, in the right click meny.
All I do is choose "Open with/DATHeader" in the menu.
I too have dat file associated with LDDP, but I only had to tell windows once about LDPE. Now if I double click on a dat file, LDDP opens as expected, and if I right click on dat file -> open with, LDPE is in the list...

Otherwise you could probably also use the send-to mechanism (that's how I use LETGUI or Datheader)
Reply
RE: [LDPartEditor] - Issues with launch from explorer
#8
(2018-01-24, 18:51)Philippe Hurbain Wrote:
(2018-01-24, 16:38)Magnus Forsberg Wrote: Strange.
On my machine it works fine.
It looks like a new instance is opened (it takes about 1 or 2 seconds, I get a brief glimpce of it) but then it "turns itself" into a new tab.
Ah, yes, it mostly works: if I open a part file with LDPE from explorer then another part with the same method, I get only one LDPE instance. But (and that's how I tried) if I launch LDPE exe, load a file through LDPE open function, then open a part file from windows explorer, I get a second instance.

I am aware that sometimes LDPE is launching a second instance to open a file. I will try to fix this with future releases.
It was not trivial to implement this "Open with..." feature in Java. The current implementation took about 500 lines of code.
I guess that I need about 750-1000 lines for a "stable" implementation. I have to use threads, queues, locks and a simple communication protocol just for opening a *.dat file in LDPE from the Windows explorer Wink
Reply
RE: [LDPartEditor] - Issues with launch from explorer
#9
I reported the problem, but I can live with present state which is already a great improvement Wink
Reply
RE: [LDPartEditor] Problem when switching from rotate to move
#3
Sometimes, when switching from move to rotate (or rotate to move) tool using keyboard shortcut, the next operation performed is done with previous tool instead. Eg. I rotate a subpart, hit the move shortcut key ("M" in my configuration), and when I mouse-drag an arrow to move the subpart, it gets rotated instead.
This problem is not new, but "sometimes" happened several times in a row so I felt urged to report Wink
Reply
RE: [LDPartEditor] Problem when switching from rotate to move
#5
(2018-01-24, 14:39)Philippe Hurbain Wrote: Sometimes, when switching from move to rotate (or rotate to move) tool using keyboard shortcut, the next operation performed is done with previous tool instead. Eg. I rotate a subpart, hit the move shortcut key ("M" in my configuration), and when I mouse-drag an arrow to move the subpart, it gets rotated instead.
This problem is not new, but "sometimes" happened several times in a row so I felt urged to report Wink

Thank you for this bug report! I created an issue (#679).
My assumption is, that the last transformation was not applied when you switched from move to rotate or vice versa.
Reply
RE: [LDPartEditor] 0.8.42 Beta Released (Bug fix / open *.dat with LDPartEditor.exe)
#10
Bug of the day:

* Selecting a color for the font in Txt2dat does not work. Letters are always rendered in black.

w.
LEGO ergo sum
Reply
RE: [LDPartEditor] Font colour + Txt2dat
#11
(2018-01-28, 15:30)Willy Tschager Wrote: Bug of the day:

* Selecting a color for the font in Txt2dat does not work. Letters are always rendered in black.

w.

Today, I fixed this issue (#681). It will be included in the upcoming release in February.
Reply
[LDPartEditor] 0.8.43 TEXMAP SPHERICAL is now "correct"
#12
While I was reading the texture mapping thread, I decided to finally fix LDPE's problems with poles on TEXMAP SPHERICAL (#243).

[Image: attachment.php?aid=3053]


Attached Files
.png   TEXMAP_Sphere.PNG (Size: 36.5 KB / Downloads: 16)
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)