[LDPartEditor] 0.8.36b Beta Released


[LDPartEditor] 0.8.36b Beta Released
#1
Hey,

here is a new release. It was intended to be released earlier, but now it has more value for you Smile

[Image: imgDuke2.png]
As always, you can download LDPE from this page:
http://nilsschmidt1337.github.io/ldparteditor/

Changelog:
(11 new features and 5 bug fixes)

With this release you will be able to...
  • ...select (and see in 3D view) elements producing an error or warning (when meaningful).
  • ...benefit from improved usability for the "hover over right click menu-icon" in the 3D view.
  • ...benefit from the fact that vertices which are close together are considered "as one" (when you add something; dist < threshold in LDU).
  • ...customise the 3D distance below which vertices are considered the same when you add new elements.
  • ...customise the 2D distance in pixels below which vertices are considered the same when you add new elements.
  • ...see a warning if the value of a DecimalSpinner differs from the displayed value.
  • ...drag&drop primitives on the text editor.
  • ..."Select Connected..." / "Touching..." "...with same type."
  • ...notice that closing a tab in the text editor close it also in the 3D editor, when the 3D and text editors share one window.
  • ...select objects, regardless of the selection filter (but there are some special exceptions).
  • ...benefit from more eye-catching buttons.
The following critical issues were fixed:

  1. Rectifier: There was no difference in the result on the fourth filter. "Convert if possible/Do not convert if adjacent cond-line."
  2. Text-Editor: The cursor jumped to the first line when the file was saved / the Save-button "stayed" in 'down'-position (actually, it was focused).
  3. The 3D editor placed the tab of a newly opened part on the left of an already opened part, while in the text editor it was placed as expected on the right.
  4. Selection issues with vertices which were close together on the screen.
  5. The coplanarity calculation was incomplete.

What will the next release 0.8.37 deliver? Bug fixes...



The program was tested intensively with "real world" files.
However, it is still a beta version and something can go wrong in about 100.000 lines of code.

Make sure that you choose the right architecture for your OS and Java Virtual Machine (JVM) (64bit or 32bit).
A short guide how to check if a 64bit JVM is installed on your system is located at the bottom of this message.

  1. Download the zip-Archive
  2. Extract the archive content to the location of your choice
  3. On windows, double-click "run.bat" to start LDPE.
  4. On linux/mac, you have to excecute the shell script "run.sh" to start LDPE.
Please note that this software is in the beta stage. Although, this version was tested, there are already known issues  for this release. There is a potential risk of data loss.

You can search for updates if you do the following steps:

  1. On windows, double-click "update.bat" to search for updates.
  2. On linux, you have to excecute the shell script "update.sh".
I listen carefully to your requests and possible complaints. Please leave me a message, with your thoughts and wishes to further improve the software.

LDPE is a 3D CAD application: The overall system requirements are higher. While I recommend to use a powerful 64-bit multicore system, it could be possible, to run LDPE on older machines as well.

System Requirements:


Minimum System Requirements:
  • 64-bit Java Runtime Environment (JRE) 1.8
  • OpenGL 2.1 compatible Graphics Card
  • Operating System (64-bit): Windows [7 or newer], Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • CPU: Multicore-Processor e.g. Intel Core 2 Duo or AMD Athlon II (>2.0Ghz)
  • RAM: 4GB
  • Video-Memory: 1 GB
  • Free Disk Space: 100 MB
Recommended Requirements:
  • Operating System (64bit): Windows 7,8,10, Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • OpenGL 3.3 compatible Graphics Card
  • CPU: Multicore-Processor with 4 cores (or more)
  • RAM: >4 GB
  • Video-Memory: >1 GB
  • Free Disk Space: 512 MB
  • For a faster start, LDPartEditor and the LDraw™ library should be installed on an SSD.
--------------------------------------------------------------------------------
How to check your JVM version (32- or 64-bit):
--------------------------------------------------------------------------------

You can try on the command line:

Code:
java -d64 version

If it's not a 64-bit version, you'll get a message that looks like:
This Java instance does not support a 64-bit JVM. Please install the desired version.
Reply
RE: [LDPartEditor] 0.8.36b Beta Released (...)
#2
Still not tested a lot, but
Quote:...benefit from more eye-catching buttons.
is highly appreciated.

Otherwise, it seems (maybe it's just here?) that primitive text search field is broken... Works again now, dunno exactly what happened (I even restarted LDPE to no avail). I'll keep my eyes peeled to see if it occurs again.
(edit) Looks also that the current grid icon (in snapping/converter pane) is no longer highlighted...
Reply
RE: [LDPartEditor] 0.8.36b Beta Released (...)
#3
(2017-08-18, 11:07)Philippe Hurbain Wrote:
Quote:...benefit from more eye-catching buttons.
is highly appreciated.

+1
w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.36b Beta Released (...)
#4
(2017-08-18, 11:07)Philippe Hurbain Wrote: Otherwise, it seems (maybe it's just here?) that primitive text search field is broken... Works again now, dunno exactly what happened (I even restarted LDPE to no avail). I'll keep my eyes peeled to see if it occurs again.
Same problem strikes again. Still don't know what triggers correct or wrong behaviour Sad
Reply
Primitive text search field issues (solved)
#5
edit: I was able to fix all these issues (inlcuding the broken visualisation) (#597)

(2017-08-19, 12:11)Philippe Hurbain Wrote:
(2017-08-18, 11:07)Philippe Hurbain Wrote: Otherwise, it seems (maybe it's just here?) that primitive text search field is broken... Works again now, dunno exactly what happened (I even restarted LDPE to no avail). I'll keep my eyes peeled to see if it occurs again.
Same problem strikes again. Still don't know what triggers correct or wrong behaviour Sad

Thank you for reporting this issue!
I was able to see this problem with my own eyes. There is a thread synchronisation issue, which is hard to reproduce.
Sometimes it works, sometimes it doesn't.

LDPE loads the primitives in parallel during program start and after the 3D editor is shown (this speeds ups the startup time alot).
You might see a delay until the primitives are visible.
There is even more black magic involved. Sometimes, a visualisation of the primitive seems broken. But in reality, LDPE constructs the primitive object at the moment when it is shown for the frist time (this speeds up startup time again).
Reply
RE: [LDPartEditor] Buttons not highlighted
#6
(2017-08-18, 11:07)Philippe Hurbain Wrote: Still not tested a lot, but
Quote:...benefit from more eye-catching buttons.
is highly appreciated.
(edit) Looks also that the current grid icon (in snapping/converter pane) is no longer highlighted...
Still having problems with multi-choice button not highlighted. Occurs in current grid icons, but also in ytruder operation mode (see screen capture)


Attached Files Thumbnail(s)
   
Reply
RE: [LDPartEditor] Buttons not highlighted (solved)
#7
(2017-11-27, 11:02)Philippe Hurbain Wrote:
(2017-08-18, 11:07)Philippe Hurbain Wrote: Still not tested a lot, but
is highly appreciated.
(edit) Looks also that the current grid icon (in snapping/converter pane) is no longer highlighted...
Still having problems with multi-choice button not highlighted. Occurs in current grid icons, but also in ytruder operation mode (see screen capture)

I created an issue (#635).

edit: I fixed it and will include it in the next 0.8.38 release. The fix will be included in the first 2018 release.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)