LDraw server problems 20 July 2014


LDraw server problems 20 July 2014
#1
Due to a server migration, the ldraw.org website is currently unavailable and the Parts Tracker is not functioning. I am in touch with Dan Boger who kindly provides us with this webspace on the peeron servers and we are working to resolve the problem.

Apologies for any inconvenience.
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - PT fixed
#2
I think I have the Parts Tracker working again, but please report anything that doesn't seem right.

The ldraw.org website is currently still unavailable, but we are working on that.
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - PT fixed
#3
Thanks Chris. Right now, when I try to submit a part, I get the "Sorry, parts tracker is down for maintenance right now." message. Is this expected?
Reply
Re: LDraw server problems 20 July 2014 - PT fixed
#4
Try now.
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - PT fixed
#5
I made two successful uploads, 2347 and 2347s01, but they don't seem to appear on the Activity log.
If I search those files I'll find them and they're downloadable, but don't have any generated images on PT or show any dependencies
Reply
Re: LDraw server problems 20 July 2014 - PT fixed
#6
Same thing here, eg. http://www.ldraw.org/cgi-bin/ptdetail.cg.../92256.dat
Reply
Re: LDraw server problems 20 July 2014 - PT fixed
#7
Same for me : http://www.ldraw.org/cgi-bin/ptdetail.cg...973p1u.dat

And the pic of the part is not showing also.
Reply
Re: LDraw server problems 20 July 2014 - PT fixed
#8
OK - not quite fixed then - I will look into it.
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - PT not fully fixed
#9
I have locked down the Parts Tracker whilst I investigate further.
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - PT working but no image generation
#10
I have got the Parts Tracker update process running again, and the queued submit actions for the parts mentioned above, do now show up on the Activity Log page.

However, there is still a problem with automated image generation - maybe the LDView executable we are using on the server is not compatible with the new hardware.

There may still be other things that are broken, so please report anything unexpected, here.

Thanks for you patience,
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - PT working but no image generation
#11
It's almost certainly a result of missing (32-bit) shared libraries, and nothing to do with the hardware change. As I said in email, I'll attempt to build it on the upgraded server.
Reply
Re: LDraw server problems 20 July 2014 - PT working
#13
Thanks to some speedy work by Travis, the image generation is working, so I hope that means that the Parts Tracker is now fully functional again.

I have generated the images for the recently submitted parts.
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - ldraw.org available but missing content
#12
The LDraw.org website CMS can see its database again, but things are still not right with the home page.
Chris (LDraw Parts Library Admin)
Reply
Re: LDraw server problems 20 July 2014 - ldraw.org available but missing content
#14
The home page should be back to normal.

w.
LEGO ergo sum
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)