Errors in LGEO?


Errors in LGEO?
#1
Hi all,

there was this post on the Studio forum about rendering errors in POV-Ray.  I’ve a déjà vu feeling with these errors.

Studio uses LDView’s code to export to POV-Ray and also uses LGEO for the exported 3D models.

I checked for 608p03: Studio’s .inc is the same I have from LGEO (which I believe is up-to-date, it’s been a while I have used it but, if I’m not mistaken, the last updates are “only” Darat’s high-def ones).

So I think it’s an error in LGEO… or it maybe something in the POV-Ray code/options but then I don’t see what it could be.

Does that ring a bell to anyone?
Reply
RE: Errors in LGEO?
#2
I have never used Studio, but just out of curiosity, is it possible for you to attach a problematic POV-Ray file here for study? Preferably one that includes only 1 part to render.
RenderMOC at Rebricable.com
Reply
RE: Errors in LGEO?
#3
(2021-02-28, 21:24)Leonardo Gonzalez Wrote: I have never used Studio, but just out of curiosity, is it possible for you to attach a problematic POV-Ray file here for study? Preferably one that includes only 1 part to render.

Thanks for your question: it made me test with a local POV-Ray before posting the .pov, not the bundled one (I hadn’t before because new computer…) and I found the problem: they are using an outdated lg_defs.inc (20080720) (which is weird because they have a more recent lg_color.inc (2013-05-27, modified by BL/Studio)).
The .pov is okay, the 608p03.inc is correct, but the lg_defs.inc makes all the difference.
Reply
RE: Errors in LGEO?
#4
Regarding the LGEO errors, I found these and was able to correct them:

lg_0608p03
       

lg_0608p04
       

lg_0609p01
       


Updated files From the LDraw AIOI:

.inc   lg_0608p03.inc (Size: 6.26 KB / Downloads: 2)

.inc   lg_0608p04.inc (Size: 6.21 KB / Downloads: 0)

.inc   lg_0609p01.inc (Size: 3.53 KB / Downloads: 0)
RenderMOC at Rebricable.com
Reply
RE: Errors in LGEO?
#5
(2021-03-01, 4:05)Leonardo Gonzalez Wrote: Regarding the LGEO errors, I found these and was able to correct them:

Which version of LGEO are you using?  The one in the AIOI?

I’m using Damien Roux’s and the one bundled in Studio is using Owen Burgoyne’s (same as AIOI?).

My remarks before were half wrong: I swaped the files (it’s what happens at 1AM Big Grin ), it’s the changelog in Damien’s version that stops on 20080720, the one in Studio’s version stops on 2014-02-10.  Still, Damien’s is more recent and the problems don’t appear when using it.
Reply
RE: Errors in LGEO?
#6
(2021-03-01, 19:54)Sylvain Sauvage Wrote: Which version of LGEO are you using?  The one in the AIOI?

I am using the LGEO from the AIOI, along with Damien's (Darats) taken from this post.

But now I am confused, the parts that I updated do not appear in the Darats library, they are in the AIOI only.

I assume that the Studio library you use had its own updates.
RenderMOC at Rebricable.com
Reply
RE: Errors in LGEO?
#7
(2021-03-01, 22:04)Leonardo Gonzalez Wrote: But now I am confused, the parts that I updated do not appear in the Darats library, they are in the AIOI only.

Yes, but it’s Darats’ lg_defs.inc that makes the difference:
  • AIOI or Studio’s lg_defs & original .inc = error
  • Darats’s lg_defs & original .inc = works
  • AIOI or Studio’s lg_defs & modified .inc = works
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 2 Guest(s)