LDPE 0.8.50 Beta Released (bugfix / usability)


0.8.50 Beta Released (bugfix / usability)
#1
Rainbow 
Hey,

this release took a little bit longer than expected, but it includes now 6 bug fixes. And three minor usability enhancements.
Some of the issues were indirectly reported by Gerald and Willy. They provided their log files and I was able to spot some critical entries.
Thank you both!

[Image: imgDuke2.png]
As always, you can download LDPE from this page:
http://nilsschmidt1337.github.io/ldparteditor/

Changelog:
(3 new features and 6 bug fixes)

With this release you will be able to...
  • ...use a button to re-open the 3D view (if no view is shown)
  • ...see a warning if you try to configure a shortcut key which can't be assigned.
  • ...start the program with a broken config file (it's not a bug, it's a feature...).

The following critical issues were fixed:

  1. The program could break if a subfile refered to a non-existent or read-protected nested subfile in very rare cases.
  2. There was a critical selection problem which occured if you have tried to select a single quad, but you deactivated the selection of quads before (selection filter).
  3. It was problematic if the program could not read from the official and unoffical LDraw library folder.
  4. It was impossible to save a file if its directory does not exist anymore.
  5. There was a breaking bug which could deactivate the duplication check on a single file (did not affect other files).
  6. Pressing the ESC key reset the (scale) snapping to an unexpected 2.00 value.



The program was tested intensively with "real world" files.
However, it is still a beta version and something can go wrong in about 140.000 lines of code.

Make sure that you choose the right architecture for your OS and Java Virtual Machine (JVM) (64bit or 32bit).
A short guide how to check if a 64bit JVM is installed on your system is located at the bottom of this message.

  1. Download the zip-Archive
  2. Extract the archive content to the location of your choice
  3. On windows, double-click "run.bat" to start LDPE.
  4. On linux/mac, you have to excecute the shell script "run.sh" to start LDPE.
Please note that this software is in the beta stage. Although, this version was tested, there are already known issues  for this release. There is a potential risk of data loss.

You can search for updates if you do the following steps:

  1. On windows, double-click "update.bat" to search for updates.
  2. On linux/mac, you have to excecute the shell script "update.sh".
I listen carefully to your requests and possible complaints. Please leave me a message, with your thoughts and wishes to further improve the software.

LDPE is a 3D CAD application: The overall system requirements are higher. While I recommend to use a powerful 64-bit multicore system, it could be possible, to run LDPE on older machines as well.

System Requirements:


Minimum System Requirements:
  • 64-bit Java Runtime Environment (JRE) 1.8
  • OpenGL 2.1 compatible Graphics Card
  • Operating System (64-bit): Windows [7 or newer], Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • CPU: Multicore-Processor e.g. Intel Core 2 Duo or AMD Athlon II (>2.0Ghz)
  • RAM: 4GB
  • Video-Memory: 1 GB
  • Free Disk Space: 100 MB
Recommended Requirements:
  • Operating System (64bit): Windows 7,8,10, Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • OpenGL 3.3 compatible Graphics Card
  • CPU: Multicore-Processor with 4 cores (or more)
  • RAM: >4 GB
  • Video-Memory: >1 GB
  • Free Disk Space: 512 MB
  • For a faster start, LDPartEditor and the LDraw™ library should be installed on an SSD.
--------------------------------------------------------------------------------
How to check your JVM version (32- or 64-bit):
--------------------------------------------------------------------------------

You can try on the command line:

Code:
java -d64 version

If it's not a 64-bit version, you'll get a message that looks like:
This Java instance does not support a 64-bit JVM. Please install the desired version.
Reply
RE: 0.8.50 Beta Released (bugfix / usability)
#2
I don't know how, but I've already got 0.8.50 for some reason!

I will, however, download this version and use it instead. Smile
Reply
RE: 0.8.50 Beta Released (bugfix / usability)
#3
(2020-06-01, 8:46)Nils Schmidt Wrote:
  1. The program could break if a subfile refered to a non-existent or read-protected nested subfile in very rare cases.
  2. There was a critical selection problem which occured if you have tried to select a single quad, but you deactivated the selection of quads before (selection filter).
  3. It was problematic if the program could not read from the official and unoffical LDraw library folder.
  4. It was impossible to save a file if its directory does not exist anymore.
  5. There was a breaking bug which could deactivate the duplication check on a single file (did not affect other files).
  6. Pressing the ESC key reset the (scale) snapping to an unexpected 2.00 value.

Thanks Nils,

which one is the one I reported? Just curious.

w.
LEGO ergo sum
Reply
What was reported?
#8
(2020-06-01, 17:17)Willy Tschager Wrote: Thanks Nils,

which one is the one I reported? Just curious.

w.

 I found indications of the first three cases in your logfile. They can probably cause the problems which you have observed.
It is very hard to reproduce the four issues you have reported via mail.

This includes (for documentation, maybe I will solve this in the near future):
  • An entry under "Last opened files" is not opened inside of the text editor, even when "Sync. 3D Editor Tabs with Text Editor Tabs" is active.
  • "Cut" or "Delete" does not work in the text editor sometimes, you have to save the file to continue.
  • "Sync. 3D Editor Tabs with Text Editor Tabs" does not sync the tabs sometimes.
  • An Edger2 run somehow "locks" the unmatched edges inside of the text editor. They can't be cut or deleted until you save the file to continue.
Reply
RE: 0.8.50 Beta Released (bugfix / usability)
#4
Quote:
  1. Pressing the ESC key reset the (scale) snapping to an unexpected 2.00 value.
Thanks for fixing this one!

...And any update on this?  Big Grin  https://forums.ldraw.org/thread-23708-po...l#pid34270
Reply
Shortcut customizations are not saved?
#5
(2020-06-02, 9:07)Philippe Hurbain Wrote: ...And any update on this?  Big Grin  https://forums.ldraw.org/thread-23708-po...l#pid34270 (a post about keyboard shortcut customizations which are not saved)

Hm... you should retry it Wink Maybe you willl see a warning. I implemented a feature especially for this purpose:

In the changelog I Wrote:...see a warning if you try to configure a shortcut key which can't be assigned.
Reply
RE: 0.8.50 Beta Released (bugfix / usability)
#6
(2020-06-02, 15:00)Nils Schmidt Wrote: Hm... you should retry it Wink Maybe you will see a warning. I implemented a feature especially for this purpose:
No it doesn't work - but in a very subtle way.
In my current configuration (coming from the older 0.49 version) I had R as shortcut for Rotation (working) AND manipulator reset (not working "of course").
Now I edit keyboard shortcuts to set '<' for rotation and Z for manipulator reset. Both work. (and I can close LDPE, shortcuts properly saved). But since after years of usage I got used to R shortcut for rotation, I change back < to R for rotation, and leave Z assigned to manipulator reset.  This works till I close LDPE... but when I restart it, R is automagically assigned back to reset manipulator (but remains also assigned to rotation, so reset manipulator is no longer accessible)
Reply
Created a bug-ticket regarding shortcuts
#7
(2020-06-02, 15:50)Philippe Hurbain Wrote: No it doesn't work - but in a very subtle way.
In my current configuration (coming from the older 0.49 version) I had R as shortcut for Rotation (working) AND manipulator reset (not working "of course").
Now I edit keyboard shortcuts to set '<' for rotation and Z for manipulator reset. Both work. (and I can close LDPE, shortcuts properly saved). But since after years of usage I got used to R shortcut for rotation, I change back < to R for rotation, and leave Z assigned to manipulator reset.  This works till I close LDPE... but when I restart it, R is automagically assigned back to reset manipulator (but remains also assigned to rotation, so reset manipulator is no longer accessible)

Thanks Philo! I was able to reproduce the problem from your description and created an issue (#753). I will just correct it with the next release.
Reply
RE: 0.8.50 Beta Released (bugfix / usability)
#9
I set SPACE as alternative middle mouse button in 0.49. Now this behaves really strange  - actually not usable while the middle mouse button suddenly works. Anyway I will switch back to 0.49. When I press the SPACE bar now it first rotates my part upside down. If I release and press again to somehow get to the view I want all gets suddenly zoomed in and also distorted.

Edit: All the above is true only for the Linux version.

   


w.
LEGO ergo sum
Reply
Strange 3D view issue under Linux
#10
(2020-06-02, 20:02)Willy Tschager Wrote: I set SPACE as alternative middle mouse button in 0.49. Now this behaves really strange  - actually not usable while the middle mouse button suddenly works. Anyway I will switch back to 0.49. When I press the SPACE bar now it first rotates my part upside down. If I release and press again to somehow get to the view I want all gets suddenly zoomed in and also distorted.

Edit: All the above is true only for the Linux version.


w.

Looks like your Linux system has issues with OpenGL 3.3 in the video driver. This is unfortunately normal for e.g. older Intel CPUs with build in graphic chips.
Try to deactivate it via unchecking "Tools..." -> "Use OpenGL 3.3" and then restart LDPE.

I spent some time to investigate on how to improve the compatibility check for this feature, but I have still no practical solution.
And it probably needs a better name. It is too technical. Even for a experienced LDraw user.
Reply
RE: Strange 3D view issue under Linux
#12
(2020-06-03, 18:02)Nils Schmidt Wrote: Looks like your Linux system has issues with OpenGL 3.3 in the video driver. This is unfortunately normal for e.g. older Intel CPUs with build in graphic chips.
Try to deactivate it via unchecking "Tools..." -> "Use OpenGL 3.3" and then restart LDPE.

I spent some time to investigate on how to improve the compatibility check for this feature, but I have still no practical solution.
And it probably needs a better name. It is too technical. Even for a experienced LDraw user.

It didn't solve my problem. I always used OpenGL2.0 also in the past. Funny thing is when I activate 3.3 the header still says OpenGL 2.0. The only difference is the tick in the options.

w.
LEGO ergo sum
Reply
RE: 0.8.50 Beta Released (bugfix / usability)
#11
I have an issue that was also present in my previous version (also 0.8.50); I don't know if it's related to anything I've reported previously. When expanding the text editor into view, some buttons are missing until I mouse over them. I'll let the image speak for itself (click to view animated GIF):
   

This issue persists when using OpenGL 3.3 as well.
Reply
Rounding problem
#13
"sometimes", rotation of an element result in excessive number of digits. When you try to apply rounding tool to that result, nothing happen.

Example of such line:
Code:
1 16 .00000000000000000000000000000212293491784143431108835 70.000000000000000000000000000001 -10.000000000000000000000000000032 -3.0614674589207171555441788133124 0 7.3910362600902944708123019945409 7.3910362600902944708123019945409 0 3.0614674589207171555441788133124 0 16 0 1-8edge.dat

Basically, this was obtained by rotating with a 22.5° angle step the following line after setting manipulator to primitive.
Code:
1 16 0 70 -10 0 0 -8 -8 0 0 0 16 0 1-8edge.dat
...but I said "sometimes" because when I try this again it does work (the rotated line has a normal number of digits and rounds properly...
Code:
1 16 -.00000000000000000000000000001 69.999999999999999999999999999996 -10 -3.0614674589207171555441788133124 0 7.391036260090294470812301994541 7.391036260090294470812301994541 0 3.0614674589207171555441788133124 0 16 0 1-8edge.dat


Edit: Problem is more subtle than it seemed at first: after the editions I made to document the bug here, I was able to round the first line properly Sad
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)