New website theme status


New website theme status
#1
The old thread is getting cluttered so I'll recap what's going on here:

What has been done:
- I think layout is principally complete. I've converted some of the articles (read non-homepage) to use the new theme.
- The article and menu hierarchy has been overhauled
- I slightly modified the parts update table tag


What needs to be done:
- I need a new "Parts Update" image. This image will be the default image displayed for a parts update unless or until an update specific image is made. This is the major thing holding up switching over to the new homepage design.
- There is a bug in the menu shown for computers. Third level articles are not displaying in the menu. The tablet/mobile menu is unaffected.
- Custom styling. Right now I'm using the default styling for the web framework in use. While I think the default styling is fine, I'd like to change that to be able to use a custom styling for components if we so choose. I have to figure out a way to do this while also maintaining the ability to edit the design from within the CMS.

As always, I want as many users as possible to be satisfied with the results. I'm open to suggestions, mild complaints that offer solutions, and requests.

P.S. We are not keeping the old design. It was a spaghetti mess of different blocks of code that has been following us since we switched to CMSMS almost 10 years ago. A house cleaning was sorely needed.
Reply
RE: New website theme status
#2
(2019-01-17, 15:53)Orion Pobursky Wrote: - I need a new "Parts Update" image. This image will be the default image displayed for a parts update unless or until an update specific image is made. This is the major thing holding up switching over to the new homepage design.

For what it's worth:


.png   Part Update1.png (Size: 95.69 KB / Downloads: 169)

https://www.dropbox.com/s/dlswdzajxlh84r...1.png?dl=0

w.
LEGO ergo sum
Reply
RE: New website theme status
#3
(2019-01-17, 17:16)Willy Tschager Wrote:
(2019-01-17, 15:53)Orion Pobursky Wrote: - I need a new "Parts Update" image. This image will be the default image displayed for a parts update unless or until an update specific image is made. This is the major thing holding up switching over to the new homepage design.

For what it's worth:



https://www.dropbox.com/s/dlswdzajxlh84r...1.png?dl=0

w.

Awesome. Time to flip the switch.
Reply
RE: New website theme status
#6
(2019-01-17, 17:19)Orion Pobursky Wrote:
(2019-01-17, 17:16)Willy Tschager Wrote: For what it's worth:



https://www.dropbox.com/s/dlswdzajxlh84r...1.png?dl=0

w.

Awesome. Time to flip the switch.

Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:

[Image: fVe1Gp5.png]

Other pages that use the new theme are just as broken.
Reply
RE: New website theme status
#7
(2019-01-17, 18:21)Travis Cobbs Wrote:
(2019-01-17, 17:19)Orion Pobursky Wrote: Awesome. Time to flip the switch.

Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:


Other pages that use the new theme are just as broken.

That's odd. I develop on a Mac at home and everything is good on iOS Safari. I'll look into it tonight. What version of Safari are you using?
Reply
RE: New website theme status
#9
(2019-01-17, 18:29)Orion Pobursky Wrote:
(2019-01-17, 18:21)Travis Cobbs Wrote: Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:


Other pages that use the new theme are just as broken.

That's odd. I develop on a Mac at home and everything is good on iOS Safari. I'll look into it tonight. What version of Safari are you using?

Same on my Windows 7 based Computer with Opera 57.0.3, Firefox 64.0.2, Chrome 71.0.
As well on my Android Phone with Opera 49.2 and on my iPhone the same result. ;-)
Reply
RE: New website theme status
#10
(2019-01-17, 18:29)Orion Pobursky Wrote:
(2019-01-17, 18:21)Travis Cobbs Wrote: Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:


Other pages that use the new theme are just as broken.

That's odd. I develop on a Mac at home and everything is good on iOS Safari. I'll look into it tonight. What version of Safari are you using?

You need to be on Safari 12 or 11.1. So MacOS 10.11 or higher.
Reply
RE: New website theme status
#8
(2019-01-17, 18:21)Travis Cobbs Wrote:
(2019-01-17, 17:19)Orion Pobursky Wrote: Awesome. Time to flip the switch.

Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:


Other pages that use the new theme are just as broken.

Same here on Firefox on Win10.

w.
LEGO ergo sum
Reply
RE: New website theme status
#11
(2019-01-17, 18:21)Travis Cobbs Wrote:
(2019-01-17, 17:19)Orion Pobursky Wrote: Awesome. Time to flip the switch.

Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:


Other pages that use the new theme are just as broken.

I messed up a site cache setting. Should work now.
Reply
RE: New website theme status
#13
(2019-01-17, 18:49)Orion Pobursky Wrote:
(2019-01-17, 18:21)Travis Cobbs Wrote: Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:


Other pages that use the new theme are just as broken.

I messed up a site cache setting. Should work now.

Yepp. :-)
Reply
RE: New website theme status
#16
(2019-01-17, 18:49)Orion Pobursky Wrote:
(2019-01-17, 18:21)Travis Cobbs Wrote: Almost everything is now broken for me (Chrome on Mac). Here's what the main page looks like for me:


Other pages that use the new theme are just as broken.

I messed up a site cache setting. Should work now.

Yes.
Reply
RE: New website theme status
#17
(2019-01-17, 17:19)Orion Pobursky Wrote: Awesome. Time to flip the switch.

Most (all?) of the sub-pages have a weird artifact in their background:

[Image: rZT3DVs.png]

I see this in Chrome 71 and Safari 12. I think that the gradient in the background was supposed to be removed entirely (it's not present on the front page).
Reply
RE: New website theme status
#18
(2019-01-18, 5:08)Travis Cobbs Wrote:
(2019-01-17, 17:19)Orion Pobursky Wrote: Awesome. Time to flip the switch.

Most (all?) of the sub-pages have a weird artifact in their background:


I see this in Chrome 71 and Safari 12. I think that the gradient in the background was supposed to be removed entirely (it's not present on the front page).

I’m still going through all the articles and that’s the old theme. It will be fixed when I switch that article to the new one. I intentionally made this a manual process to ensure I looked at every page.
Reply
RE: New website theme status
#29
If possible I would rotate "Parts Update" by 90 degrees counterclock-wise and delete the "available now" to be in sync with the other pics.

w.
LEGO ergo sum
Reply
RE: New website theme status
#15
(2019-01-17, 17:16)Willy Tschager Wrote:
(2019-01-17, 15:53)Orion Pobursky Wrote: - I need a new "Parts Update" image. This image will be the default image displayed for a parts update unless or until an update specific image is made. This is the major thing holding up switching over to the new homepage design.

For what it's worth:



https://www.dropbox.com/s/dlswdzajxlh84r...1.png?dl=0

w.

I have asked before without much success, but I'd really like someone who has the skills to do something like this for each update. It's definitely not my area of expertise. Maybe starting with the recent historical ones?
Chris (LDraw Parts Library Admin)
Reply
RE: New website theme status
#4
Known issue:
- The color table overlaps outside of existing formatting. See here: http://www.ldraw.org/article/547.html
Note that this table is now generated from data pulled from the current official ldconfig.ldr add will auto update if changed.
Reply
RE: New website theme status
#5
(2019-01-17, 18:10)Orion Pobursky Wrote: Known issue:
- The color table overlaps outside of existing formatting. See here: http://www.ldraw.org/article/547.html
Note that this table is now generated from data pulled from the current official ldconfig.ldr add will auto update if changed.

I expect to have this fixed when I adjust the large monitor breakpoint above 1200px.
Reply
RE: New website theme status
#27
(2019-01-17, 18:14)Orion Pobursky Wrote:
(2019-01-17, 18:10)Orion Pobursky Wrote: Known issue:
- The color table overlaps outside of existing formatting. See here: http://www.ldraw.org/article/547.html
Note that this table is now generated from data pulled from the current official ldconfig.ldr add will auto update if changed.

I expect to have this fixed when I adjust the large monitor breakpoint above 1200px.

Fixed
Reply
RE: New website theme status
#12
Known issue:
The table of contents, on the pages that have them, needs work. I'll be writing a new TOC auto generator to fix this.
Reply
RE: New website theme status
#14
I find it odd that clicking on the red brick logo on the wiki page, doesn't lead back to Ldraw.org, but instead lead to the main wiki page
Reply
RE: New website theme status
#19
I adjusted the max width breakpoint for large monitors by 150px. Is this too wide or fine?
Reply
RE: New website theme status
#20
(2019-01-18, 18:34)Orion Pobursky Wrote: I adjusted the max width breakpoint for large monitors by 150px. Is this too wide or fine?
Seems to work fine for me, on PC and on phone.
Reply
RE: New website theme status
#21
The tabs of the toolbar normally open automatically when mouse over.
But once you've clicked on a tab, mouse over does not work anymore.
If nothing goes right, go left.
Reply
RE: New website theme status
#22
(2019-01-18, 20:10)Johann Eisner Wrote: The tabs of the toolbar normally open automatically when mouse over.
But once you've clicked on a tab, mouse over does not work anymore.

Should be fixed.
Reply
RE: New website theme status
#23
(2019-01-18, 20:13)Orion Pobursky Wrote:
(2019-01-18, 20:10)Johann Eisner Wrote: The tabs of the toolbar normally open automatically when mouse over.
But once you've clicked on a tab, mouse over does not work anymore.

Should be fixed.

Perfect!
Thanks.
If nothing goes right, go left.
Reply
RE: New website theme status
#24
The link "LDraw Specifications" on all the Part Tracker homepages, leads to a page without format

http://www.ldraw.org/article/292
Reply
RE: New website theme status
#25
(2019-01-22, 18:41)Magnus Forsberg Wrote: The link "LDraw Specifications" on all the Part Tracker homepages, leads to a page without format

http://www.ldraw.org/article/292

Thanks for the report. I changed that page to a section header since everything is listed in the menu. I’ll remove the link or maybe I’ll make an auto generated page that lists all the children pages.
Reply
RE: New website theme status
#26
(2019-01-22, 18:44)Orion Pobursky Wrote:
(2019-01-22, 18:41)Magnus Forsberg Wrote: The link "LDraw Specifications" on all the Part Tracker homepages, leads to a page without format

http://www.ldraw.org/article/292

Thanks for the report. I changed that page to a section header since everything is listed in the menu. I’ll remove the link or maybe I’ll make an auto generated page that lists all the children pages.

Fixed.
Reply
RE: New website theme status
#28
(2019-01-17, 15:53)Orion Pobursky Wrote: - There is a bug in the menu shown for computers. Third level articles are not displaying in the menu. The tablet/mobile menu is unaffected.

Fixed.
Reply
RE: New website theme status
#30
Didn't we use to have a possibility to search the LDraw.org site?
Reply
RE: New website theme status
#31
(2019-01-27, 17:14)Magnus Forsberg Wrote: Didn't we use to have a possibility to search the LDraw.org site?

Yes. I’m adding that back in soon.
Reply
RE: New website theme status
#32
(2019-01-27, 18:48)Orion Pobursky Wrote:
(2019-01-27, 17:14)Magnus Forsberg Wrote: Didn't we use to have a possibility to search the LDraw.org site?

Yes. I’m adding that back in soon.

Hi Orion
This link on the unofficial part site doesn't work.

Johann


Attached Files Thumbnail(s)
   
If nothing goes right, go left.
Reply
RE: New website theme status
#33
(2019-01-30, 19:54)Johann Eisner Wrote:
(2019-01-27, 18:48)Orion Pobursky Wrote: Yes. I’m adding that back in soon.

Hi Orion
This link on the unofficial part site doesn't work.

Johann

It works but the anchor is just further down an already short page. For most computer screens, the page doesn't even need to scroll down.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)