Call for LDCad 1.6 bug reports


Call for LDCad 1.6 bug reports
#1
Hello all,

I decided to do a 1.6c version of LDCad as I've gathered a couple of small issues making it worth while.

But I would like to address as much as possible as this might be the final 1.x version.

These are the known issues:
- Copy goes wrong when multiple instances are involved of which not all are really selected (e.g. some are hidden trough buffer exchange).
- ctrl + 'plus' or 'min' hotkeys don't work.
- Animation mode does not apply buffer exchange visibility.

And some minor tweaks/additions
- Hotkeys for zooming and panning
- Allow higher and unlimited max script execution time
- (very)Basic export (probably CSV) for part bin contents. Mostly for use with the "All parts used in the current model" bin.


Please feel free to report any additional issues and or minor tweaks.
Reply
RE: Call for LDCad 1.6 bug reports
#2
(2018-07-20, 17:33)Roland Melkert Wrote: Please feel free to report any additional issues and or minor tweaks.
Dunno if it qualifies as minor... show help section of a part when displaying its properties?
Reply
RE: Call for LDCad 1.6 bug reports
#3
(2018-07-20, 17:33)Roland Melkert Wrote: Hello all,

<snip/>


Please feel free to report any additional issues and or minor tweaks.

I don't know whether this is a LDCAD bug or a(n unofficial) part issue. I just tried adding the newly created train motor (unofficial) part to a model and in LDCAD it seems to have some "challenges";

[Image: 800x706.jpg]

The same parts renders properly using LPub3D, so I'm slightly puzzled as to what has happened here. Any suggestions?

David
Reply
RE: Call for LDCad 1.6 bug reports
#4
It looks like you don't have, or have misplaced the subfiles to the top and bottom parts of the motor assembly.

89832s01.dat and 54756s01 should be placed in the ../unofficial/parts/s -folder
Reply
RE: Call for LDCad 1.6 bug reports
#5
(2018-08-13, 21:28)Magnus Forsberg Wrote: It looks like you don't have, or have misplaced the subfiles to the top and bottom parts of the motor assembly.

89832s01.dat and 54756s01 should be placed in the ../unofficial/parts/s -folder

Those subfiles were there already. However, now when I open the model in LDCAD ...
[Image: 800x706.jpg]

.. the motor is displayed as expected. Any attempt to explain why it wasn't displaying correctly before but now is would be pure guess work from me, so I won't go there.

David
Reply
RE: Call for LDCad 1.6 bug reports
#6
(2018-08-13, 23:24)David Manley Wrote: Any attempt to explain why it wasn't displaying correctly before but now is would be pure guess work from me, so I won't go there.

Did you restart the program after placing the dependency files? LDCad only updates the library at program start when changes are detected.
Reply
RE: Call for LDCad 1.6 bug reports
#7
A plausible scenario for this: you intalled the main part without installing the subparts (or placed them in a wrong folder). When you look at the part with LDCad, it misses all those subparts as shown in your screen capture. If then you look at your file with LDView (or try to make BIs with LPub3D that uses LDView), LDView automatically fetches the missing subparts from LDraw server. Its display is correct, and the missing subparts are now correctly placed in the right folder, thus "repairing" LDCad display.

Maybe future versions of LDCad could also try to fetch missing files from LDraw server?
Reply
RE: Call for LDCad 1.6 bug reports
#8
(2018-08-14, 18:43)Roland Melkert Wrote:
(2018-08-13, 23:24)David Manley Wrote: Any attempt to explain why it wasn't displaying correctly before but now is would be pure guess work from me, so I won't go there.

Did you restart the program after placing the dependency files? LDCad only updates the library at program start when changes are detected.

I had restarted LDCad after placing the dependency files, so I don't think it was that but ...

(2018-08-15, 9:36)Philippe Hurbain Wrote: A plausible scenario for this: you intalled the main part without installing the subparts (or placed them in a wrong folder). When you look at the part with LDCad, it misses all those subparts as shown in your screen capture. If then you look at your file with LDView (or try to make BIs with LPub3D that uses LDView), LDView automatically fetches the missing subparts from LDraw server. Its display is correct, and the missing subparts are now correctly placed in the right folder, thus "repairing" LDCad display.

Maybe future versions of LDCad could also try to fetch missing files from LDraw server?

... Philippe's plausible scenario seems to be a reasonable explanation.

I had installed the dat files listed for the file detail in the appropriate unofficial sub-directory but nothing else. I have LPub3D configured to use LDView as my renderer. I ran LPub3D a couple of minutes after using LDCad. Looking at the timestamps of the files in the "s" sub-directory, they have a timestamp corresponding to when I ran LPub3D, hence when I next ran LDCad, the sub-parts were available.

Thank you Philippe for the plausible scenario explanation.

Regards,

David
Reply
RE: Call for LDCad 1.6 bug reports
#9
A minor annoyance: I check "sync description with filenames" when I create submodels, and this option is neatly used for all submodels... except those automatically created through templates.
Reply
RE: Call for LDCad 1.6 bug reports
#10
I'm not sure if this is a bug or a feature request but is there a way to select and change a color for all colors in a model including sub models? Love your wonderful program Roland!
Reply
RE: Call for LDCad 1.6 bug reports
#11
(2018-09-14, 4:34)Cam\s Bricks Wrote: I'm not sure if this is a bug or a feature request but is there a way to select and change a color for all colors in a model including sub models? Love your wonderful program Roland!
One way to do that: go to nested mode. Select one part with the color you want to change, then select -> Same color, than apply the color you want. One drawback: if you have groups that contain a part with the color you want to change, whole groups get selected and you end up changing colors of all parts in these groups. In that case, after the first general selection, destroy the groups (secection -> groups -> ungroup selection), then re-select again. I have no solution if you need to keep the groups...
Reply
RE: Call for LDCad 1.6 bug reports
#12
(2018-09-14, 7:08)Philippe Hurbain Wrote: One drawback: if you have groups that contain a part with the color you want to change, whole groups get selected and you end up changing colors of all parts in these groups. In that case, after the first general selection, destroy the groups (secection -> groups -> ungroup selection), then re-select again. I have no solution if you need to keep the groups...
You can also change the grouping layer to "none", all groups will be ignored that way.
Reply
RE: Call for LDCad 1.6 bug reports
#13
(2018-09-14, 17:18)Roland Melkert Wrote:
(2018-09-14, 7:08)Philippe Hurbain Wrote: One drawback: if you have groups that contain a part with the color you want to change, whole groups get selected and you end up changing colors of all parts in these groups. In that case, after the first general selection, destroy the groups (secection -> groups -> ungroup selection), then re-select again. I have no solution if you need to keep the groups...
You can also change the grouping layer to "none", all groups will be ignored that way.

Does it retain the group info if I go back to a non "none" layer?
Reply
RE: Call for LDCad 1.6 bug reports
#14
(2018-09-14, 19:59)Cam\s Bricks Wrote:
(2018-09-14, 17:18)Roland Melkert Wrote: You can also change the grouping layer to "none", all groups will be ignored that way.

Does it retain the group info if I go back to a non "none" layer?

Yes, the group layers are meant to allow for multiple configurations. E.g. to help animate things while building instructions use different groups in the same model.
Reply
RE: Call for LDCad 1.6 bug reports
#15
In 1.6b it is possible to close windows (source, parts bin, color) even if we are in locked windows mode. I don't think it's a good thing...
Reply
RE: Call for LDCad 1.6 bug reports
#16
(2018-09-18, 9:37)Philippe Hurbain Wrote: In 1.6b it is possible to close windows (source, parts bin, color) even if we are in locked windows mode. I don't think it's a good thing...

The option only locks docking, it still allows closing for sake of the floating windows.

I guess I could disallow closing docked windows to make it more consistent though.

Thanks for pointing this out.
Reply
RE: Call for LDCad 1.6 bug reports
#17
(2018-09-18, 18:02)Roland Melkert Wrote: I guess I could disallow closing docked windows to make it more consistent though.
Yes, that's what I meant, as accidentally closing docked window kills your carefully crafted screen layout Wink
Reply
RE: Call for LDCad 1.6 bug reports
#18
Probably more a 2.0 feature, but...
Sometimes, it would be interesting to be able to see highlight of selected parts even if they are hidden by other parts (x-ray mode). This would be helpful to locate hidden parts (selected in source window) or insert part that go deep inside a model. Of course this must remain an option, as x-ray mode is a nuisance in the general case.
Reply
RE: Call for LDCad 1.6 bug reports
#19
Ok it's been awhile and work on LDCad 1.6c has been extremely slow but I managed to finally finish the programming related items on my main todo list.

I'm going to concentrate on snapping info and maybe a simple animation for now, hoping to release 1.6c in may.

But in the meantime I would like to remember people to keep reporting issues before I close the book on 1.6c.

These are the changes thus far:
Code:
Fixed:
- [Config] The menu hottracking state is no longer missing in main.cfg
- [LDraw] Textures no longer fail to load when they have spaces in their filename.
- [Hotkeys] ctrl+"plus sign" and ctrl+"minus sign" no longer fail to register.
- [Menus] Fixed minor text and layout issues of the menu bar configuration dialog.
- [Menus] Menus no longer cause redraw events when menu hottracking is disabled.
- [Editing] Copy no longer always includes all instances of submodels, it now only includes the ones actually selected.
- [Editing] Added missing hotkey for the properties item in the select menu.
- [Editing] The "Session/detach this subfile" will no longer cause missing parts in dependencies when the newly detached file is closed.
- [Editing] Closing files will now correctly restore the last used submodel instead of always returning to the main model of the last used submodel's file.
- [Editing] The selection embed feature no longer deletes all non positional items during nested mode.
- [Animation] Hidden and buffer exchange related content is now (also) rendered correctly during animation mode.
- [Scripting] session::get/setStepNr and subfile::getStepCount will no longer crash the program when used unlinked.
- [Scripting] aniTools gearDepAction no longer applies the given gears ration correctly (it used to swap them around).
- [Path] Overlapping circle guidance points can no longer cause a potentially fatal division by zero error.
- [Templates] Templates no longer ignore the default sync name option.
- [Shadow] Fixed / tweaked multiple parts with minor snapping and or mirroring issues.


Improved/Changed:
- [LDraw] Library locations are now filtered by extension (configurable in main.cfg) to prevent texture files to show up in the part bin as empty parts.
- [LDraw] Libraries zipped using a mac computer will no longer fail to populate the part bin. (The __MACOSX folder is now ignored)
- [LDraw] A warning will now be issued when trying to save a file using a non standard LDraw file extension.
- [Hotkeys] Replaced the "sample" label with a button in the hotkey config dialog. This because the label didn't work in all Linux variants making changing hotkeys impossible.
- [Hotkeys] Tweaked descriptions of dynamic features (e.g. the grid stepping items).
- [GUI] docked windows can no longer be closed when the lock docked windows option is enabled.
- [Editing] Copy now always uses the selection item order. This was needed to fix the above mentioned copy bug.
- [Editing] Added "Properties" to the edit menu.
- [Editing] Selection information now uses the current selection center as it's first point.
- [Scripting] The maximum execution time (maxExecTime in main.cfg) for scripts is no longer limited to 5..2000ms. Setting it to <=0 will result in no limitation at all, WARNING: this will hang the program if you (accidentally) create an infinite loop in your scripts.
- [Examples] Did a redirect ("~Moved" etc) clean up.


Added:
- [LDraw] Textures are now also supported from within zipped libraries.
- [Hotkeys] You can now assign hotkeys for the editor's zoom and panning control.
- [Editing] Added "Exclude dynamic parts" to the nesting exclusions menu. This will exclude all path and spring parts from the nesting mode in one go.
- [PartBin] Added a basic export option. It will write the current content (name/descr/colID/colName/count) into a tab separated file.
- [Scripting] added session::getMainSubfile and session::getInsSubfile.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)