LPub3D, LDGlite and LDView changes layout


LPub3D, LDGlite and LDView changes layout
#1
Hi, in LPub3D, when I switch between LDGlite and LDView, various elements on the page change size and position. Is there something I can do to keep layout and size more consistent? Thanks.
Reply
RE: LPub3D, LDGlite and LDView changes layout
#2
Or, does anyone know how I can speed up LDView rendering? In many cases the main assembly simply disappears in LDGlite, and LDView takes significantly longer to render every page regardless of if anything has changed. Thanks.
Reply
RE: LPub3D, LDGlite and LDView changes layout
#4
(2016-05-13, 2:26)Brian Wrote: Or, does anyone know how I can speed up LDView rendering? In many cases the main assembly simply disappears in LDGlite, and LDView takes significantly longer to render every page regardless of if anything has changed. Thanks.

I provided a suggestion that could hopefully be used to make LPub3D's usage of LDView faster, so it's possible that a future LPub3D release will do that. However, LDView's design means that it is never going to be as fast as ldglite at rendering images from the command line. LDView spends more time during model loading to optimize things for interactive display performance, and this means that loading the model takes longer. When all you are going to do is take a single snapshot of the model, this is far from ideal, but it's not something that's going to change.
Reply
RE: LPub3D, LDGlite and LDView changes layout
#3
I spent a considerable amount of time Investigating that and came to the conclusion that it'd be quite difficult to make it perfect, as long as lpub is making different layout decisions based on a single pixel difference in image size.  However there also appears to be some cruft in lpub3d image scaling code from the old lpub codebase that puts it off by more than a pixel with the images produced by ldview.

I could take a look at the disappearing main assemblies if you can provide an example where it happens. I have suspicions it's the znear setting, but it's challenging to reproduce the problem with limited resources.
Reply
RE: LPub3D, LDGlite and LDView changes layout
#5
Thanks. The missing assembly reappears if I increase the paper size. The size difference was off by more than a few pixels in my case ... I may have not refreshed the cache. I'll see if I can repro on an official model.
Reply
RE: LPub3D, LDGlite and LDView changes layout
#6
If you can reproduce it with an official then it'll be much easier to track down and fix the problem.  Otherwise it's a guessing game.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)