LDView 4.2 > Display Problem for Prim. Subst. for 48\Cones larger than 9?


LDView 4.2 > Display Problem for Prim. Subst. for 48\Cones larger than 9?
#1
When doing the 30398 I stumbled over a strange behavior in LDView.

To conclude:
If a file uses a cone larger than 9 from the Hi-Res primitives, i.e. starting from 48\4-4con10, AND LDView is set to use Primitive Substitution, the curve is not smoothed.
However if the file uses the standard primitive, 4-4con10, the smoothing works.

Anybody noticed this as well?

This code
Code:
1 14 0 5 0 1 0 0 0 2 0 0 0 1 48\4-4con5.dat
1 14 0 0 0 1 0 0 0 2 0 0 0 1 48\4-4con9.dat
1 14 0 -5 0 1 0 0 0 2 0 0 0 1 48\4-4con10.dat
1 14 0 -10 0 1 0 0 0 2 0 0 0 1 48\4-4con12.dat
1 16 0 -15 0 1 0 0 0 2 0 0 0 1 48\4-4con20.dat
results in this:
giving no smoothing for the bottom three (10, 12 and 20)
   


and this code
Code:
1 14 0 5 0 1 0 0 0 2 0 0 0 1 4-4con5.dat
1 14 0 0 0 1 0 0 0 2 0 0 0 1 4-4con9.dat
1 14 0 -5 0 1 0 0 0 2 0 0 0 1 4-4con10.dat
1 14 0 -10 0 1 0 0 0 2 0 0 0 1 4-4con12.dat
1 16 0 -15 0 1 0 0 0 2 0 0 0 1 4-4con20.dat

results in proper smoothing:
   
Reply
Re: LDView 4.2 > Display Problem for Prim. Subst. for 48\Cones larger than 9?
#2
It appears that LDView isn't detecting those as being cones. I don't know why, but it certainly seems to be a bug. Note that most people won't notice, because if curve smoothing is turned on, and you use these in an actual part file, the'll get smoothed.
Reply
Re: LDView 4.2 > Display Problem for Prim. Subst. for 48\Cones larger than 9?
#3
Thanks Travis

It happens also for parts, take a look at 4742, you can notice it also with "smoothing curves" on

The interesting thing is that it works if you use the standard primitives as a base in the file and not the hi-res ones.
Reply
Re: LDView 4.2 > Display Problem for Prim. Subst. for 48\Cones larger than 9?
#5
4742 looks fine to me as long as "Smooth Curves" is enabled. It looks bad when that is disabled. I'm pretty sure I'm running 4.2 Beta 1, but there is a small possibility that I'm running a developer build. I'm on a Mac, but I wouldn't expect that to matter.
Reply
Re: LDView 4.2 > Display Problem for Prim. Subst. for 48\Cones larger than 9?
#8
Yes, smoothing curves gives it a better look, only a small gap is visible:

   


Attached Files Thumbnail(s)
   
Reply
Re: LDView 4.2 > Difference in display of Metallic Colors in Prims and Triangles/Quads
#4
Travis,

one more thing I noticed:

Part 3815p8i.dat includes a belt buckle made from prims/quads/triagles. It is supposed to be metallic silver. however when viewed there is a difference in the colors of the prims and the quads/triangles. This affects all metallic colors, not the plain ones.
First time I noticed this. Is this known?
Reply
Re: LDView 4.2 > Difference in display of Metallic Colors in Prims and Triangles/Quads
#6
Can you post a screenshot? (You can use imgur.com if you don't know where to put the image.) I don't see the problem here.
Reply
Re: LDView 4.2 > Difference in display of Metallic Colors in Prims and Triangles/Quads
#7
When starting LDView to get the screenshot, I was puzzled as I could not see it...

After trying some settings that I used yesterday, I could only reproduce the issue if I set "Conditional Lines" to "Show All".

   

So in general this looks fine if the settings are in, how to say, "normal mode". Sorry for that!

Gerald
Reply
Re: LDView 4.2 > Difference in display of Metallic Colors in Prims and Triangles/Quads
#9
There must be something else going on here. I don't get that result, with the same settings.
Reply
Re: LDView 4.2 > Difference in display of Metallic Colors in Prims and Triangles/Quads
#10
I found out that "Specular Highlight" under "Lighting" needs to be checked as well
Reply
Re: LDView 4.2 > Difference in display of Metallic Colors in Prims and Triangles/Quads
#11
Thanks. It seems there is some kind of weird thing going on when "Show all" is checked for conditional lines, but only with the specular for metal colors. Given that "Show all" conditional lines is designed purely for parts author debugging, and given my lack of work on LDView, I really doubt this is ever going to get fixed (unless someone else tracks down the problem in the source code).
Reply
Re: LDView 4.2 > Difference in display of Metallic Colors in Prims and Triangles/Quads
#12
That issue is not really a problem as it shows under very special circumstances as we have found out now.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)