LDraw.org Discussion Forums

Full Version: LDView 4.2 > Display Problem for Prim. Subst. for 48\Cones larger than 9?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
When doing the 30398 I stumbled over a strange behavior in LDView.

To conclude:
If a file uses a cone larger than 9 from the Hi-Res primitives, i.e. starting from 48\4-4con10, AND LDView is set to use Primitive Substitution, the curve is not smoothed.
However if the file uses the standard primitive, 4-4con10, the smoothing works.

Anybody noticed this as well?

This code
Code:
1 14 0 5 0 1 0 0 0 2 0 0 0 1 48\4-4con5.dat
1 14 0 0 0 1 0 0 0 2 0 0 0 1 48\4-4con9.dat
1 14 0 -5 0 1 0 0 0 2 0 0 0 1 48\4-4con10.dat
1 14 0 -10 0 1 0 0 0 2 0 0 0 1 48\4-4con12.dat
1 16 0 -15 0 1 0 0 0 2 0 0 0 1 48\4-4con20.dat
results in this:
giving no smoothing for the bottom three (10, 12 and 20)
[attachment=1907]


and this code
Code:
1 14 0 5 0 1 0 0 0 2 0 0 0 1 4-4con5.dat
1 14 0 0 0 1 0 0 0 2 0 0 0 1 4-4con9.dat
1 14 0 -5 0 1 0 0 0 2 0 0 0 1 4-4con10.dat
1 14 0 -10 0 1 0 0 0 2 0 0 0 1 4-4con12.dat
1 16 0 -15 0 1 0 0 0 2 0 0 0 1 4-4con20.dat

results in proper smoothing:
[attachment=1908]
It appears that LDView isn't detecting those as being cones. I don't know why, but it certainly seems to be a bug. Note that most people won't notice, because if curve smoothing is turned on, and you use these in an actual part file, the'll get smoothed.
Thanks Travis

It happens also for parts, take a look at 4742, you can notice it also with "smoothing curves" on

The interesting thing is that it works if you use the standard primitives as a base in the file and not the hi-res ones.
Travis,

one more thing I noticed:

Part 3815p8i.dat includes a belt buckle made from prims/quads/triagles. It is supposed to be metallic silver. however when viewed there is a difference in the colors of the prims and the quads/triangles. This affects all metallic colors, not the plain ones.
First time I noticed this. Is this known?
4742 looks fine to me as long as "Smooth Curves" is enabled. It looks bad when that is disabled. I'm pretty sure I'm running 4.2 Beta 1, but there is a small possibility that I'm running a developer build. I'm on a Mac, but I wouldn't expect that to matter.
Can you post a screenshot? (You can use imgur.com if you don't know where to put the image.) I don't see the problem here.
When starting LDView to get the screenshot, I was puzzled as I could not see it...

After trying some settings that I used yesterday, I could only reproduce the issue if I set "Conditional Lines" to "Show All".

[attachment=1920]

So in general this looks fine if the settings are in, how to say, "normal mode". Sorry for that!

Gerald
Yes, smoothing curves gives it a better look, only a small gap is visible:

[attachment=1923]
There must be something else going on here. I don't get that result, with the same settings.
I found out that "Specular Highlight" under "Lighting" needs to be checked as well
Pages: 1 2