Problems with loading LDR file from LDD


Problems with loading LDR file from LDD
#1
Hi,

This is a rookie question :-)

I have created a simple model in LDD 4.3.8. The model base on EV3 set (31313). Because I don't like the format of building instructions from LDD, I wanted to try LDView and LPub. So I have done an export from LDD to LDR file.

I have installed LDraw_AIOI_2013-01_setup_32bit_v1.exe , plus the latest complete.zip and ldrawunf.zip . I run LDMakeList.exe as well.

When I try to open exported LDR (attached to this thread) in LdView, I get below errors:
Quote:Error loading submodel x933c01.dat.
File: C:\Lego\Tata\Smietnik\auto01.ldr
Line #74
Line: 1 47 79.982009887695312 -170.532470703125 -10.602602958679199 0 0 1 0 -1 0 1 0 0 x933c01.dat
Error loading submodel 59158.dat.
File: C:\Lego\Tata\Smietnik\auto01.ldr
Line #3
Line: 1 4 80 -30.000028610229492 -39.999992370605469 -1 0 0 0 -1 0 0 0 1 59158.dat

Is there a way how can I fix it quickly and easily? :-)

Best regards


Attached Files
.ldr   auto01.ldr (Size: 9.52 KB / Downloads: 0)
Reply
Re: Problems with loading LDR file from LDD
#2
both files seems to be not official, at least with that numbers.
Reply
Re: Problems with loading LDR file from LDD
#3
Well, the LDR file was done by LDD (File / Export Model). So you bet on LDD bug?

I'm attaching LXF (just drop .txt extension) file, to this post.

Regards


Attached Files
.txt   auto01.lxf.txt (Size: 16.21 KB / Downloads: 0)
Reply
Re: Problems with loading LDR file from LDD
#4
Do you have the latest version of ldraw.xml?

Download from here:
http://gallaghersart.com/page/new_ldd_pa..._ldraw.xml

I dont know if Mike Gallagher have added the new EV3 parts to the translation list yet.

x933c01.dat is renumbered to just 933c01.dat. Mindstorm NXT RJ12 Plug with cable end
59158.dat is a new alias number. A search for it in LDD gives a small EV3 engine. We call it 99455.dat
Reply
Re: Problems with loading LDR file from LDD
#5
Thank you, I didn't know about the ldraw.xml. However with this file there are no errors while loading exported LDR (after closing LDD, replacing ldraw.xml, opening LDD and exporting) , but EV3 bricks (engines, cpu) are not displayed.

Regards
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)