LPUB3D problems

RE: LPUB3D problems
(2017-01-11, 0:19)Walt White Wrote: Thanks for investigating this puzzle.

My Path to the LDraw Root Directory was:
C:\Program Files (x86)\LDraw

I tried changing it to:
so it matches exactly my LDRAWDIR environment variable:
but it still failed.

I already had the "Options | Script I/O Restrictions" set to "No Restrictions" but went ahead and added the folder containing the .LDR file to the [Permitted Output Paths] in pvengine.ini as suggested, but it still fails.

I haven't considered file permissions as a problem because LPub3D successfully generates six files in the "tmp" sub-folder:

For me, the clue is that both of the .POV files contain sixty eight lines of:
// Empty model
so LPub3D never generates anything in the "parts" sub-folder, which explains why POV-Ray fails with the message that it can't find what it is looking for in that "parts" sub-folder.

And the LPub3D log file clearly states why it can't generate the required file:
@ln 1014 "Item [3736.dat] not in the LPub3D archives. C:/Users/Walt/AppData/Local/LPub3D Software/LPub3D/libraries/lpub3dldrawunf.zip C:/Users/Walt/AppData/Local/LPub3D Software/LPub3D/libraries/complete.zip"

The puzzle for me is why LPub3D can't find that 3736.dat file in complete.zip when my Windows 10 machine clearly shows that .DAT file in that .ZIP file. I've tried running LPub3D as an administrator and it still fails.



I think that the error you encountered may be due to a space somewhere in your directory path. Refer to https://forums.ldraw.org/thread-22020.html for a possible explanation.

Are you able to try renaming you directory path, replacing any space in the directory name with an underscore? Please post the outcome of attempting this i.e. whether or not it resolved the issue you encountered.


« Next Oldest | Next Newest »

Messages In This Thread
LPUB3D problems - by Knud Ahrnell Albrechtsen - 2015-10-05, 10:53
Re: LPUB3D problems - by Trevor Sandy - 2015-10-05, 11:35
Re: LPUB3D problems - by Trevor Sandy - 2015-10-06, 11:01
RE: LPUB3D problems - by Walt White - 2017-01-08, 21:54
RE: LPUB3D problems - by Walt White - 2017-01-08, 21:56
RE: LPUB3D problems - by David Manley - 2017-01-09, 23:59
RE: LPUB3D problems - by Walt White - 2017-01-11, 0:19
RE: LPUB3D problems - by David Manley - 2017-02-03, 6:18
RE: LPUB3D problems - by Walt White - 2017-02-03, 16:59

Forum Jump:

Users browsing this thread: 1 Guest(s)