LDraw.org Discussion Forums
LPUB3D problems - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: LDraw Editors and Viewers (https://forums.ldraw.org/forum-11.html)
+--- Thread: LPUB3D problems (/thread-17461.html)

Pages: 1 2 3


LPUB3D problems - Knud Ahrnell Albrechtsen - 2015-10-05

Hi

I have just installed LPUB3D and i have run into a couple problem with it.
The first is that when I change from standard document size to LEGAL and the orientation of the document is Landscape, the partlist stays in the middle of the page and I can't get it to move automatically to the upper left corner of the document.
How can I fix this, without having to move them all by hand ?

The other problem is when choosing POV-Ray as default editor.
POV-RAY complains about parsing commandline.
Any idea what to do about this - other than choosing another default renderer Smile
I have attached a screendump of the error.
I should be running the latest version of POV-Ray.

/Knud


Re: LPUB3D problems - Trevor Sandy - 2015-10-05

Hi Knud,

Send sceenshots of the the following:

1. Configuration => Preferences - General and Rendering Tabs
2. Configuration => Page Setup - Page Tab
3. Configuration => Parts List Setup - Background/Border Tab

Send copies of the following:

4. Generated POV-Ray (.pov) file
5. Model (.mpd/.ldr) file

Cheers,
Trevor


Re: LPUB3D problems - Knud Ahrnell Albrechtsen - 2015-10-06

Hi Trevor

I have attached the screenshots you need.
I could not find any POV file in the project folder.
And what would you be looking for in my ldr file?

Kind Regards
Knud


Re: LPUB3D problems - Trevor Sandy - 2015-10-06

Thanks for the information Knud,

I requested the information to better reproduce your issue.

For the model (.mpd/.ldr) file, you don't have to send a full model file. For example, you could create a test file as long as it's producing the issue you are reporting. One scenario where the .ldr file could help is if you are referencing a part that may be causing POV-Ray to abnormal end.

In summary, when the LPub3D renderer is set to POV-Ray, it sends a command arguments to L3P which generate .pov files.

Here is an example of LPub3D's L3P command used to generage a step's csi .pov file:

"C:\Program Files\LPub3D\3rdParty\l3p1.4WinB\L3P.EXE" -ca0.01 -cg0.0,0.0,3116890 -ld -lgeo -lgdC:\Users\Trevor\LDraw\lgeo -car0.772727 -o -lddC:\Users\Trevor\LDraw "-q4 -sw2" C:\Users\Trevor\Desktop\LPub\6964-01\LPub\tmp\csi.ldr C:\Users\Trevor\Desktop\LPub\6964-01\LPub\tmp\CSILDR~1.POV

You can find the current model page csi and pli .pov files under <model folder>/LPub/tmp

LPub3D then sends a command argument to POV-Ray with the appropriate parameters including the path to the .pov file.

If you do not have .pov files in the location above, then LPub3D is not generating then in your environment. The .pov file is very important to troubleshooting any POV-Ray abnormal responses.

Here is an example of LPub3D's POV-Ray command used to render a step's csi:

Rendering using command line '+IC:\Users\Trevor\Desktop\LPub\6964-01\LPub\tmp\CSILDR~1.POV
+OC:\Users\Trevor\Desktop\LPub\6964-01\LPub\assem\6964-mainmodel_1_0_0_0_1_0_0_0_1_6_1275_150_DPCM_1.png +W1275 +H1650 +UA
+LC:\Users\Trevor\LDraw\lgeo\lg +LC:\Users\Trevor\LDraw\lgeo\ar +A'.

Cheers,
Trevor


LPUB3D problems (preventive recommendations) - Trevor Sandy - 2015-10-06

Knud, I just looked at the screenshots you sent.

You should avoid to put the LDraw content library (including lgeo) under the Program Files directory. The LDraw content library does not have any application or program files and should not be placed under Program Files which is designated for application files and their dependencies.

In addition, most programs that must write content (like LPub3D must write fade files) and will not be able to do so under the Program Files directory because of UAC.

Also, for the 3D Viewer (LeoCAD) Library Archive location, I would recommend, in addition to a location not under Program Files, using LDraw's complete.zip along with having the ldrawunf.zip file in the same location. This way you will not have issues to generate fade files which uses the ldrawunf.zip archive.


Re: LPUB3D problems (preventive recommendations) - Knud Ahrnell Albrechtsen - 2015-10-29

Hi
Sorry for the long time before my response.
I have been waiting for the download section here at the forum to be available again.
I have now done the following:
I have completely uninstalled the all-in-one installer, ldview, pov-ray, etc.
I have then downloaded and installed the newest all-in-one installer from the forum. I set it to install everything.
Otherwise I used all standard settings in the installer. I have used the preferred setting under the public user for the ldraw lib files.
I have given the local user modify rights for the install folder: C:\Program Files (x86)\LDraw (just in case).
I have then installed and configured ldview x64, POV-Ray 3.7 and LPUB 3D.

I created a folder here: C:\temp\test and gave the local user full access.
I created a test.ldr file containing 2 bricks and saved it to the above folder.
I opened the test.ldr with LPUB3D and changed the page setup to 35.5600 x 21.5900.
Then the following happenes when I change the preferred renderer:
LDView/LGLite: It still does not put the partlist to the edge of the document.
POV-RAY: It comes with the following error:
IO Restrictions prohibit write access to 'C:\temp\Test\LPub\parts\3001_0_2100_150_DPCM_1_23_-45.png'
Failed to start render: Cannot open file.

Regarding the complete.zip and ldrawunf.zip. I have downloaded and put them both here C:\Program Files (x86)\LDraw\
And as i mentioned earlier there is modify access to the folder for the local user.
I cant find anywhere where i can set the path to the above .zip files?

I have attached pictures of the setup in LPUB3D.
Perhaps I should mention that I am only logged on as a normal user, NOT Admin or power user.

Kind Regards
Knud


Re: LPUB3D problems - Knud Ahrnell Albrechtsen - 2016-02-09

Hi again Trevor

I have been looking into my problems with LPub3D, and found a solution to one of them.
The first problem I described in my original post, was that the partlist was not placed in the edge of the document when orienting the page as landscape. I fixed this by going to the first partlist and rightclicking on the page number next to it and selecting "move step number". Then i changed the "relavite to" setting from "page Header" to "page".
That did the trick Smile

Regarding the render problem with using POV-ray, I still have the same problem.
I have been looking a bit more into what you describe above.
I have created a new empty ldr file with only two parts: a 3005 1x1 brick.
I placed the file in C:\temp and the folder has write access for all users.
I the started LPub 3D (newest version) and loaded the file. Then changed the rendere til POV-Ray.
POV-RAY: It comes with the following error:
IO Restrictions prohibit write access to 'C:\temp\Test\LPub\parts\3001_0_2100_150_DPCM_1_23_-45.png'
Failed to start render: Cannot open file.

I the left the POV-Ray window open and looked for the .pov file you describe under C:\temp\LPub3D\tmp.
There is none. there are 3 ldr files, but no .pov file.
and the C:\temp\Test\LPub\parts\3001_0_2100_150_DPCM_1_23_-45.png does not exist either.

I hope you can help me find out what is wrong


Re: LPUB3D problems (preventive recommendations) - Trevor Sandy - 2016-02-12

Hello Knud,

Do not put any updatable content (i.e. ldraw archive or unofficial archive) under your program files directory. I believe the AIOI puts the these items elsewhere. See the AIOI online documentation.

For you parts list issue: If you are on a single-step page, you should be able to move the parts list to to the location you want. On a multi-step page use the context menu (right-click) to access Move Part List and follow the dialog.

You should read the POV-Ray documentation on adding Library-Path[s] to the povray.ini and check your Script I/O Restrictions under Options (in the application)

Cheers,


Re: LPUB3D problems (preventive recommendations) - Knud Ahrnell Albrechtsen - 2016-02-15

Hi Trevor

I have moved all that you mention to another location.
I still have problems with using POV-Ray as a renderer. If you read my post from 9. February for details.
Besides the problem with using POV-Ray, I have found out that LPub3D for some reason will not show the 15068.dat int the part list.
I have attached the file and a screenshot.
I am using version 1.3.5 Revision 615 build 2 of LPub3D


Re: LPUB3D problems (preventive recommendations) - Philippe Hurbain - 2016-02-15

You must have something wrong in your LDraw library, your "Empty.ldr" file renders fine here with all variants of 15068.dat.

Nonetheless, I noticed something weird: I had a copy of 15068p04.dat in the temporary folder where I put the model file. And though the copy had a regular part header (albeit unofficial) and despite the part beeing also in my LDraw library, it was treated as a submodel instead of a part. Is there a good reason for this behaviour?