Could we also have an updrade of LETGUI?

Philo have added Selector and improved Rectifier.

I can't run windz through LETGUI, for some reason.
It works fine when I run it separatly.

The "output" text entry box is often blocked by the "settings box".
Firstly - thank you very much for your feedback !!

Update of LETGUI is on my TODO list the next item.

For windz please let me have a console line that works.
I never got windz here to work! I implemented a guess!
It's not a command line issue: I have one machine which allows me to run Windz through LETGUI (WinXP), another where I must use command line (Seven 64 (*))...
(*) Note that neither Letgui nor Windz are in a protected folder such as Program files.
That might explain why I'm not able to run it.
I have a Windows 7 Home Premium, 64, too.
For Windz I only archieved a working result in generating a bat file that I call after that. So the current cmd (32 or 64 bit) will do the job. If your XP is 32bit it seems to me that this is the main problem!

Please have a look in your temp folder. There you should find a file called ~letgui.bat.
I think you can get away without a .bat by executing
%WINDIR%\System32\cmd.exe /c cd /d somefolder && windz input.dat > output.dat
Maybe you need to add some quotes...
WINDZ 0.1.0
I can run my instance of windz.exe on Win7 64bit sucessfully from cmd.exe.

Note that Win7 64bit offers 2 variants of cmd.exe:

The default 64bit instance, located at C:\Windows\System32 (or wherever you installed windows).
And yes, it is located in the "System32" folder for backwards compatibility, although IMHO it better should
live in "System64". You can determine that it's this 64bit instance you're running by issuing the "set" command
and look at the PROCESSOR_ARCHITECTURE environment variable. It will display some 64ish setting within
the 64bit version of cmd.exe.

And there's the 32bit instance, located in C:\Windows\SysWOW64. This strange folder name means
"Windows on Windows 64", meaning that it contains all 32bit executables, for "emulating" a 32bit Windows
on a 64bit Windows. A strange folder name choice again: you'll find 32bit stuff in here, and the folder name
ends with "...64". Sigh. However, when you fire up the cmd.exe there and look at the PROCESSOR_ARCHITECTURE
environment variable via "set", you'll find it it to be set to "x86".

I am running WINDZ 0.1.0, and for it, I had archived the release notes, here they are:
Windz Release 0.1.0


  windz [ options ] filename


    Debug mode.
    Windz will expand the dat file. It will only contain triangles
    and quads with three colors:
      Green: The polygon was not modified;
      Red:   The polygon was modified;
      Blue:  Windz couldn't figure out what is the correct winding for this polygon.

  -n Initials
    When correcting parts, windz includes one line of the type:
      0 2002-08-31 ZAN Modified with WINDZ for BFC compliance
    Use this option to make windz put your initials in this line.
    For instance, if your name is Ole Kirk Christiansen, you can put the
    option -nOKC and windz will generate a line like this:
      0 1932-08-16 OKC Modified with WINDZ for BFC compliance

    Prints help.

  All Windz output will be sent to the standard output, so,
  if you want to see what windz is doing, use the '>' to redirect the
  standard output to a file.
  Ex:  windz 3001.dat > z3001.dat

  Windz is a free program. The only requirement is that you
  submit the part with the information line that it generates:
    0 2002-08-31 ZAN Modified with WINDZ for BFC compliance
  You can change the initials in the line using the -n option.

  0001 Improve performace: Some kind of bounding-box algorithm needs to be implemented.
  0002 Output to file: Create a new option that enables windz to send
       the output directly to a file without using '>'.

  0001 Incorrect output when handling files that contain bad vertex sequence or concave quads.

Windz Copyright (C) 2002 by Ildefonso Junior Zanette <i.z@uol.com.br>

The commandline that works for me is:
windz.exe input.dat > output.dat
I've attached my instance of windz.exe to this post.

Attached Files
.txt   windz.exe.txt (Size: 280 KB / Downloads: 4)
Re: WINDZ 0.1.0
Did you use the 32bit cmd or the 64bit cmd for your working commandline? This question is not really answered by your post.

I just tried here with 64bit commandline and it does not work!
Re: WINDZ 0.1.0
I have tested windz.exe with and inlined box.dat, where I'd changed two quads from CCW to CW
I tried with cmd.exe of sysWOW64 and with cmd.exe of system32 both had given me a completely CW "box"
It was also possible to get the help page with windz.exe -h in both cmd.

Oh, I had forgotten to write that I use Win 7 Professional 64-bit.

Re: WINDZ 0.1.0
Hmm you are right. If I call winz.exe with parameter -h the help page ist shown. If I call it without any parameter it gives an error message: winz.exe does not work anymore (winz.exe funktioniert nicht mehr).
I do not know why that message will be shown.
Re: WINDZ 0.1.0
Yes, same her. Program crashes without parameter -h or without input and output statement.
Re: WINDZ 0.1.0
Ok, thanks for feedback.

Now I think I have the key problem.
I am using in NET "system.diagnostics.Process"
For all tools I set the Filename property to the tools name with path information
And the Arguments property I fill with the command string.

The unique problem now with windz is, that it only writes to the standard output and not to any file. This needs to be done by the cmd with redirecting the output to a file. So it is completely different from the other tools.

I got it now to work, hopefully also on your machines.

Update will be ready in five minutes. Smile

By the way, LETGUI delivers version of Windz.
The "output" text entry box is often blocked by the "settings box".
Can you tell me which enviroment you use? I use it on windows with NET framework an have no problems!
I'm sorry, missed this.
I have a seven64 and use NET framework 4.
I don't think there is something wrong in letgui, since I also see the same bad behaivor when I open "Replace color" in LDDP.
Or do they share something?

It is as if the "windows" are too small, they don't adapt to the required size.

[Image: image_3.png] See some examples here.
That is strange. I did not see something similar before. I use it on win8 64 bit and it seems that NET 4.0 and 4.5 are installed by default (I only have visual express 2010 installed afterwards).
Also my laptop with seven64 bit has no problems.

I do not have any problem here with the size of the windows.

I think I have to ask Google for that problem.

By the way? How is DATHeader working for you? I am asking that because DATHeader should start all the way with the same size. I do not calculate anything there myself. All is done by the framework. I think I have calculated something at LETGUI, so that might be a reason.
DatHeader is working fine. I've never noticed any bad GUI in DatHeader.
No problem here (Seven64)... Maybe a non-standard Windows font size?
No, I don't think so. I just have had a look into the code. I calculate the height of the windows on start, but not the width!
I also tried here to make the window smaller and exits the prog. Restarted, but the window started again with the defined width.

But I am sure that something like this has happened to your machine.

I have searched my path currentuser\AppData\Local\Michael Heidemann\LETGUI\\
In that path no file is stored
In currentuser\AppData\Local\Michael Heidemann\LETGUI\
there should be the file LETGUIINI.xml

No other entries are used today. If you have any other entries please delete them in that folders, as they are not intended to be there. Also no entries in the registry are made. So you should also have a look into that by using regedit.exe. (I have some entries there, but that are only entries that I started that application.

I have also seen some entries in the path "\Local\Michael_Heidemann\LETGUI" or "\Local\mikeheide\LETGUI" or "\Roaming\Michael_Heidemann\LETGUI.exe......\(version)\user.config". They are all unnecessary, but I am not sure how to remove them or how to avoid the creation of that files. Try just deleting that files.

In my opinion LETGUI gets from some place the information to not show the full windows. But to be honest, I do not know from where and why. My last solution would be -
1) save your current LETGUIINI.xml
2) remove LETGUI by using the uninstall function from windows.
3) Search for any entries in the registry for letgui - delete them.
4) Restart your computer.
5) Install fresh LETGUI latest version.
6) run letgui and just inform about the ldraw base folder.
7) Exit letgui (the LETGUIINI.xml is written in the path mentioned above)
8) Copy the saved LETGUIINI.xml to the current place (overwriting the just created).
9) I assume that your system shows the same windows than my system.

Please let me know if you could
1) solve your problem
2) did you find maybe any other files that are related to letgui (maybe an older version).

Hopefully we can solve your problem and other user know what to do if they got the same experience.
Did you test with different settings for the system font size (i.e. 125%)? That appears to be the source of the problem, just looking at the screenshots.
Thank you guys, for trying to help me.

I think Travis is on to something.
When I reduced the system font size to 115% (it was set at standad, 125%) the problems went away.
But only in LETGUI. It didn't affect LDDP at all. May I ask what setting you use/have?
I have an ASUS 17" laptop with 1920x1080 resolution, nvidia geForce gtx 560M. Does that affect anything?

Now I just have to adapt my self to this new setting.
I have two monitor 1280 x 1024 and 1680 x 1050
I do not have the same options than you (win8) but a similar "size of elements" and that is set to 100% (standard). I also tried yesterday changing that, but it had no effect on the appearance of LETGUI!

As I am using at one point in the calculation where to place the groupbox a defined value I think that this might be the reason. I'll have a look at the code. Maybe I can calculate that value based on the settings of the system.
I have found at several placed really bad code in this case. I placed the controls by fixed values Sad
I send a quick hack by email to Magnus for checking that the problems have gone. If I got his ok, I will release that as a bugfix version.
I'm happy again!

Michael's file solved my gui-problems.

Thank you!!
Thank you very much for your feedback. I am glad that I found the problem and solved it.
I will shortly make this fix available for all other users.
we encounter this kind of trouble frequently at my job.
check the "AutoSize" and "AutoSizeMode" properties of the form.
if they're set to "scale font only", then the font can grow, but the space for it might be too small.
this is a terrible annoyance of the .NET forms.
we found no real good solution for this yet. what we currently do is make the form layout large enough
to be able to hold even the largest scaled font, but achieving this requires tedious testing
with different Windows fontsize scaling settings in virtual machines.
and you need to look at each and every dialog and check if it is okay.
did I say that this is an annoyance......? :-|
« Next Oldest | Next Newest »

Forum Jump:

Users browsing this thread: 1 Guest(s)