LDPE 1.8.54 Beta Released (bugfixes / no Java / new installers)


1.8.54 Beta Released (bugfixes / no Java / new installers)
#1
Hey,


this version comes with new installers and does not need a Java installation anymore.
It also improves the compatibility with Mac OS X and Linux.


Please uninstall the previous LDPartEditor version, before installing version 1.8.54.
LDPE uses now a very modern technology stack (self-contained Java 17).



[Image: imgDuke2.png]



As always, you can download LDPE from this page:

http://nilsschmidt1337.github.io/ldparteditor/


Changelog:
(2 new features and 2 bug fixes)


With this release you will be able to...
  • ...use installers of LDPartEditor for Windows, Linux and Mac OS X (without the need to install Java)
  • ...see more digits (at least 4 decimal places) on the protractor and the distance meter.

The following critical issues were fixed:

  1. "Set X/Y/Z (for Selection)" loaded always the vertex from the clipboard if there was one vertex stored in it.
  2. Outdated UI libraries for Mac OS X were updated.




The program was tested intensively with "real world" files.
However, it is still a beta version and something can go wrong in about 140.000 lines of code.

Installation on Windows:

  1. Download and extract LDPartEditor_win32_x64.zip
  2. Run LDPartEditor-1.8.54.msi
  3. Start LDPartEditor from the start menu

Installation on Linux:

  1. Download and extract LDPartEditor_linux_x64.zip
  2. Install ldparteditor_1.8.54-1_amd64.deb
  3. Start LDPartEditor from the menu or via launcher

Installation on Mac OS X:

  1. Download and extract LDPartEditor_mac_x64.zip
  2. Mount LDPartEditor-1.8.54.dmg
  3. Drag LDPartEditor.app to the Applications folder
  4. Copy ldparteditor.sh to your home folder
        4a. Open a Terminal.app and run ./ldparteditor.sh
        4b. Or open a Terminal.app and run /Applications/LDPartEditor.app/Contents/MacOS/LDPartEditor

Please note that this software is in the beta stage. Although, this version was tested, there are already known issues  for this release. There is a potential risk of data loss.

I listen carefully to your requests and possible complaints. Please leave me a message, with your thoughts and wishes to further improve the software.

LDPE is a 3D CAD application: The overall system requirements are higher. While I recommend to use a powerful 64-bit multicore system, it could be possible, to run LDPE on older machines as well.

System Requirements:

Minimum System Requirements:
  • OpenGL 2.1 compatible Graphics Card
  • Operating System (64-bit): Windows [7 or newer], Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • CPU: Multicore-Processor e.g. Intel Core 2 Duo or AMD Athlon II (>2.0Ghz)
  • RAM: 4GB
  • Video-Memory: 1 GB
  • Free Disk Space: 100 MB

Recommended Requirements:
  • Operating System (64bit): Windows 7,8,10, Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • OpenGL 3.3 compatible Graphics Card
  • CPU: Multicore-Processor with 4 cores (or more)
  • RAM: >4 GB
  • Video-Memory: >1 GB
  • Free Disk Space: 512 MB
  • For a faster start, LDPartEditor and the LDraw™ library should be installed on an SSD.
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#2
Installed. Works. What more to say? Wink
Thanks, Nils!
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#3
Installed and opened successfully on Mac 10.14.6. My only issue so far is that the program doesn't quit fully—it hangs and I have to force quit.

Also, I'm curious why the .app bundle can't be opened directly? I'm sure there's a reason, maybe having to do with the self-contained Java. Could this also be related to not quitting properly?

On the good news side, the app has so far opened correctly every time—no more of the missing buttons or view panels I used to get! Big Grin
Reply
Mac OS X Feedback
#5
(2022-02-23, 15:30)N. W. Perry Wrote: Installed and opened successfully on Mac 10.14.6. My only issue so far is that the program doesn't quit fully—it hangs and I have to force quit.

Also, I'm curious why the .app bundle can't be opened directly? I'm sure there's a reason, maybe having to do with the self-contained Java. Could this also be related to not quitting properly?

On the good news side, the app has so far opened correctly every time—no more of the missing buttons or view panels I used to get! Big Grin

Thanks, I had this problem too (program doesn't quit fully), it disappeared with a newer version of OS X (I am currently on Montery 12.2.1)

The issue with the .app bundle is actually a good security feature from Mac OS.
I am not an offical Apple Developer and not part of the Apple Developer Program.
When I publish the application on Mac OS X, I have to sign it. Then it would possible to open the .app bundle directly.
I can't sign the application, because I do not want to pay for an Apple Developer License .
Therefore you have to do this workaround with the Terminal.

Mac OS X restricts the start of unsigned applications, because that protects you from malware, too.
LDPE is not malware, but it is still unsigned and not verified by Apple.
Reply
RE: Mac OS X Feedback
#6
(2022-02-23, 16:48)Nils Schmidt Wrote: The issue with the .app bundle is actually a good security feature from Mac OS.
I am not an offical Apple Developer and not part of the Apple Developer Program.
When I publish the application on Mac OS X, I have to sign it. Then it would possible to open the .app bundle directly.
I can't sign the application, because I do not want to pay for an Apple Developer License .
Therefore you have to do this workaround with the Terminal.

The same thing applies to LDView, but you don't have to use a Terminal workaround. (If you like doing that, then that's fine).

After running the app normally and being told that it cannot run, go to System Preferences, then Security & Privacy. Unlock the page. You should then have the option of whitelisting the app so it runs normally.

I believe you can also right click on the app in Finder and select Open from the popup menu. If you do it this way, you should hopefully be given the opportunity to manually whitelist the app, instead of going through System Preferences.
Reply
RE: Mac OS X Feedback
#7
(2022-02-23, 18:15)Travis Cobbs Wrote: The same thing applies to LDView, but you don't have to use a Terminal workaround. (If you like doing that, then that's fine).

After running the app normally and being told that it cannot run, go to System Preferences, then Security & Privacy. Unlock the page. You should then have the option of whitelisting the app so it runs normally.

I believe you can also right click on the app in Finder and select Open from the popup menu. If you do it this way, you should hopefully be given the opportunity to manually whitelist the app, instead of going through System Preferences.

That is supposed to work (and usually does), but in this case when I follow those steps, that does not occur.

It might be relevant that the error message I get isn't the usual "unidentified developer" complaint that is usually solved by whitelisting, but the more serious "app is damaged and should be moved to the trash" message. Frustratingly, the help page for this issue still gives me the specific advice of whitelisting the app, but the required option never presents itself.

So, I have a little scripter app that will launch the program (already had one for the old .jar file anyway), which takes no longer than opening the app bundle itself. I could also just make an alias of the executable file inside the bundle, I suppose, and open that. So it's no great burden.

As for the quitting issue, I notice that closing the app window, Microsoft-style, seems to quit correctly rather than actually quitting. And if this is solved in later versions of MacOS, I guess I wouldn't worry about it!
Reply
RE: Mac OS X Feedback
#35
(2022-02-23, 16:48)Nils Schmidt Wrote: Thanks, I had this problem too (program doesn't quit fully), it disappeared with a newer version of OS X (I am currently on Montery 12.2.1)

I'm now on Monterey 12.6.1, and the problem hasn't disappeared for me. However, the workaround (quit by closing the window rather than the menu command) does still work.
Reply
Program does not start on Linux :(
#4
Bug 
It currently does not start on Linux Mint. I will try to solve this issue on the next weekend.
I did some tests before a few weeks ago, I was sure it was working. But I must have changed something in the last minute.
Reply
Now it runs on Linux too :)
#9
I moved some library files and re-uploaded the binary file for Linux (LDPartEditor_linux_x64.zip).
It works now :)
  • I was able to install it easily on Linux Mint.
  • On Ubuntu, I had to install a missing dependency
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#8
Installed and works fine. Win10 (64)
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#10
Feature request:

As a user I'd like that opening a file via the "Last opened file" button the file gets opened also in the text editor an not only in the 3D editor.

w.
LEGO ergo sum
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#11
(2022-03-03, 17:25)Willy Tschager Wrote: Feature request:
As a user I'd like that opening a file via the "Last opened file" button the file gets opened also in the text editor an not only in the 3D editor.
+1 !
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#12
(2022-03-03, 17:25)Willy Tschager Wrote: Feature request:

As a user I'd like that opening a file via the "Last opened file" button the file gets opened also in the text editor an not only in the 3D editor.

w.

Honestly I think there could be better sync between the text and 3D editors. Sometime it feels like I'm using two different programs. 
Examples:
- The opening problem you mention
- If I select a surface or sub part, I want to see the corresponding line in the other editor automatically (yes I know there's a button). If it's a vertex, the first line that uses that vertex.
- If I switch a tab on one side, the tab on the other should switch.
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#13
(2022-03-03, 18:19)Orion Pobursky Wrote: - If I select a surface or sub part, I want to see the corresponding line in the other editor automatically (yes I know there's a button). If it's a vertex, the first line that uses that vertex.
- If I switch a tab on one side, the tab on the other should switch.
+1
LEGO ergo sum
Reply
Sychronisation on selections and part content
#15
(2022-03-03, 18:19)Orion Pobursky Wrote: Honestly I think there could be better sync between the text and 3D editors. Sometime it feels like I'm using two different programs.
- If I select a surface or sub part, I want to see the corresponding line in the other editor automatically (yes I know there's a button). If it's a vertex, the first line that uses that vertex.

Thanks Orion, I created issue #884.

The decoupling is intended, because you can do different tasks with each editor (change the textual representation / change the visual representation).
Also, it is very hard to synchronise the selection info, from a technical point of view.

What I can do easily: When you select something in the text editor, it should be selected in the 3D editor, too.
Is that what you want? I would enable it if "Sync. 3D Editor Tabs with Text Editor" is active.

It is not so clear what should happen...
  • ...if you select multiple items in the 3D editor which are seperated all over the textual representation from the part.
  • ...when you select a fraction of a sub part in the 3D editor?
  • ...when you add an object in the 3D editor (e.g. a triangle, which needs a selection)


It is also difficult if a user wants to look at another places of the text file and gets confused/distracted by the automatic sync between both editors.

Side note: It is currently impossible to visually identify if something belongs to a sub part if everything is coloured with the same colour (usually colour 16).
I know that this is something to improve, but I am not sure what should be the visual difference between part and sub part content.
Reply
RE: Sychronisation on selections and part content
#18
Multi select is hard. I know all to well with LDDP. Not asking for that. Single select, on the other hand, would be useful.
Reply
RE: Sychronisation on selections and part content
#20
(2022-03-04, 21:18)Orion Pobursky Wrote: Multi select is hard. I know all to well with LDDP. Not asking for that. Single select, on the other hand, would be useful.

Should I transfer the single selection from the text editor to the 3D editor?

e.g.

Quote:WHEN you work on a triangle (in the text editor)
THEN this triangle should be selected in the 3D editor

Quote:WHEN you select multiple lines of text (in the text editor)
THEN this content should be selected in the 3D editor, too.
Reply
Tab synchronisation / open in 3D and text editor
#14
(2022-03-03, 17:25)Willy Tschager Wrote: As a user I'd like that opening a file via the "Last opened file" button the file gets opened also in the text editor an not only in the 3D editor.
Orion Pobursky Wrote:If I switch a tab on one side, the tab on the other should switch.


You can enable the synchronisation for tab switching between 3D and text editor with this button ("Sync. 3D Editor Tabs with Text Editor"):
For "last opened files" this will open the file in both editors.

[Image: attachment.php?aid=7628]


Attached Files
.png   tabSynchronization.png (Size: 1.65 KB / Downloads: 114)
Reply
RE: Tab synchronisation / open in 3D and text editor
#16
(2022-03-04, 17:45)Nils Schmidt Wrote: You can enable the synchronisation for tab switching between 3D and text editor with this button ("Sync. 3D Editor Tabs with Text Editor"):
For "last opened files" this will open the file in both editors.

[Image: attachment.php?aid=7628]

I'm aware of the button. You've shown it to me in Billund. Problem is that the button has "hiccups". Most of the time it works, sometimes not. There is no guarantee that it is pressed when you fire up the prog, though you closed it pressed. Could be that "Stand by" is the cause. I could never track down why it doesn't work sometimes. Sometimes the tabs do not synchronize and you have to press it again though it was pressed all the time.

w.
LEGO ergo sum
Reply
RE: Tab synchronisation / open in 3D and text editor
#17
Seen that too... Never reported because like you i was never able to reproduce reliably.
Reply
"Sync. 3D Editor Tabs with Text Editor" hiccups
#19
(2022-03-04, 18:56)Willy Tschager Wrote: I'm aware of the button. You've shown it to me in Billund. Problem is that the button has "hiccups". Most of the time it works, sometimes not. There is no guarantee that it is pressed when you fire up the prog, though you closed it pressed. Could be that "Stand by" is the cause. I could never track down why it doesn't work sometimes. Sometimes the tabs do not synchronize and you have to press it again though it was pressed all the time.
(2022-03-04, 20:51)Philippe Hurbain Wrote: Seen that too... Never reported because like you i was never able to reproduce reliably.

Thanks, Philo and Willy. I was able to reproduce the problem and created issue #886.

Steps to reproduce:

  1. Activate "Sync. 3D Editor Tabs with Text Editor"
  2. On the 3D Editor click on "Open Part File"
  3. Just close the dialog window without selecting any file.
  4. Restart LDPE
Reply
RE: "Sync. 3D Editor Tabs with Text Editor" hiccups
#23
Somewhat related:
- when I create a new file ("new part file" button in 3D window or "create subpart from selection" button), a new text window is opened, instead of using a new tab in already opened text window (I use separate text and 3D windows).
- If I use "save as", a new file is created, but no text window or tab is created, although my sync tabs button is active.
Reply
RE: "Sync. 3D Editor Tabs with Text Editor" hiccups
#26
(2022-03-07, 17:10)Philippe Hurbain Wrote: Somewhat related:
- when I create a new file ("new part file" button in 3D window or "create subpart from selection" button), a new text window is opened, instead of using a new tab in already opened text window (I use separate text and 3D windows).
- If I use "save as", a new file is created, but no text window or tab is created, although my sync tabs button is active.

Thanks, Philo. I was able to identify the issue and created two bug tickets.
issue #888 ("new part file")
issue #887 ("save as")
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#21
Could you please look into also the following issue?

* When I run Edger I have to save the file before I can do anything with the result. Selecting a line in the text editor won't show you the counterpart in the 3D editor if you haven't saved the file first.

w.
LEGO ergo sum
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#22
(2022-03-07, 13:32)Willy Tschager Wrote: Could you please look into also the following issue?

* When I run Edger I have to save the file before I can do anything with the result. Selecting a line in the text editor won't show you the counterpart in the 3D editor if you haven't saved the file first.

w.

Maybe this is not related to this release? I think I had the same on the previous version too.
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#24
(2022-03-07, 15:46)Magnus Forsberg Wrote: Maybe this is not related to this release? I think I had the same on the previous version too.

I agree, this has been there.
Reply
Steps to reproduce the Edger sync issue?
#25
(2022-03-07, 13:32)Willy Tschager Wrote: Could you please look into also the following issue?

* When I run Edger I have to save the file before I can do anything with the result. Selecting a line in the text editor won't show you the counterpart in the 3D editor if you haven't saved the file first.

w.

What are the steps to reproduce the problem? When you run Edger, you usually have to wait about two seconds until both editors are synchronised.
Reply
RE: Steps to reproduce the Edger sync issue?
#27
(2022-03-08, 20:39)Nils Schmidt Wrote: What are the steps to reproduce the problem? When you run Edger, you usually have to wait about two seconds until both editors are synchronised.

* Open a file
* Make sure the sync button in the 3D editor is pressed
* Go to bottom of the text editor and add a few empty lines as you want your conds and unmatched edges get generated there
* Select Edger in the 3D editor and generate your conds and unmatched edges
* Go back to the text editor and select the conds and unmatched edges you wanna see highlighted in the 3D editor
* Press the "Show selection in 3D editor"

Sometimes nothing happens and you the text editor seams blocked. You have to save the result first before you can go on with your work.

w.
LEGO ergo sum
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#28
Today I got the following error when LDPE froze at start.


.png   Screenshot 2022-03-10 15.59.31.png (Size: 8.27 KB / Downloads: 77)

w.
LEGO ergo sum
Reply
LDPE froze at start
#29
(2022-03-10, 15:12)Willy Tschager Wrote: Today I got the following error when LDPE froze at start.



w.

Maybe there is a hint inside one of the logfiles located at
C:\Users\username\AppData\Roaming\LDPartEditor
Reply
RE: LDPE froze at start
#30
Here we go:

[ERROR 0.8.53] @org.nschmidt.ldparteditor.data.DatFile
java.io.FileNotFoundException: \\(no file selected) (Der angegebene Pfadname ist ungültig)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at org.nschmidt.ldparteditor.text.UTF8BufferedReader.<init>(UTF8BufferedReader.java:45)
at org.nschmidt.ldparteditor.data.DatFile.parseForData(DatFile.java:1149)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.openFileIn3DEditor(Editor3DWindow.java:3802)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.lambda$run$56(Editor3DWindow.java:1964)
at org.nschmidt.ldparteditor.helper.WUtil$5.widgetSelected(WUtil.java:81)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4175)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1081)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1066)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:780)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:3193)
at org.eclipse.swt.custom.CTabFolder.destroyItem(CTabFolder.java:808)
at org.eclipse.swt.custom.CTabItem.dispose(CTabItem.java:130)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow$7.close(Editor3DWindow.java:1941)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1956)
at org.eclipse.swt.custom.CTabFolder.lambda$init$0(CTabFolder.java:335)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4175)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3988)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3587)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:823)
at org.eclipse.jface.window.Window.open(Window.java:799)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.run(Editor3DWindow.java:2027)
at org.nschmidt.ldparteditor.splash.SplashScreen.run(SplashScreen.java:412)
at org.nschmidt.ldparteditor.main.LDPartEditor.main(LDPartEditor.java:48)

[LDPartEditor RELEASE ] Started on Fri Mar 04 19:52:55 CET 2022
[LDPartEditor RELEASE 0.8.53 @ SWT v4930 OpenGL 2.0 PLATFORM win32]
[LDPartEditor RELEASE ] Started on Sat Mar 05 17:01:18 CET 2022
[LWJGL] [MemoryAccessor] Unsupported JVM detected, this will likely result in low performance. Please inform LWJGL developers.
[LDPartEditor RELEASE 1.8.54 @ SWT v4948 OpenGL 2.0 PLATFORM win32]
[ERROR 1.8.54] @org.nschmidt.ldparteditor.data.DatFile
java.io.FileNotFoundException: \\(no file selected) (Der angegebene Pfadname ist ungültig)
at java.base/java.io.FileInputStream.open0(Native Method)
at java.base/java.io.FileInputStream.open(Unknown Source)
at java.base/java.io.FileInputStream.<init>(Unknown Source)
at java.base/java.io.FileInputStream.<init>(Unknown Source)
at org.nschmidt.ldparteditor.text.UTF8BufferedReader.<init>(UTF8BufferedReader.java:45)
at org.nschmidt.ldparteditor.data.DatFile.parseForData(DatFile.java:1149)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.openFileIn3DEditor(Editor3DWindow.java:3799)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.lambda$run$56(Editor3DWindow.java:1969)
at org.nschmidt.ldparteditor.helper.WUtil$5.widgetSelected(WUtil.java:82)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4243)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1060)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1084)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1069)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:773)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:3248)
at org.eclipse.swt.custom.CTabFolder.destroyItem(CTabFolder.java:812)
at org.eclipse.swt.custom.CTabItem.dispose(CTabItem.java:132)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow$7.close(Editor3DWindow.java:1946)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1961)
at org.eclipse.swt.custom.CTabFolder.lambda$init$0(CTabFolder.java:336)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4243)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1060)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4060)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3632)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:823)
at org.eclipse.jface.window.Window.open(Window.java:799)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.run(Editor3DWindow.java:2032)
at org.nschmidt.ldparteditor.splash.SplashScreen.run(SplashScreen.java:414)
at org.nschmidt.ldparteditor.main.LDPartEditor.main(LDPartEditor.java:48)

[ERROR 1.8.54] @org.nschmidt.ldparteditor.data.DatFile
java.io.FileNotFoundException: \\(no file selected) (Der angegebene Pfadname ist ungültig)
at java.base/java.io.FileInputStream.open0(Native Method)
at java.base/java.io.FileInputStream.open(Unknown Source)
at java.base/java.io.FileInputStream.<init>(Unknown Source)
at java.base/java.io.FileInputStream.<init>(Unknown Source)
at org.nschmidt.ldparteditor.text.UTF8BufferedReader.<init>(UTF8BufferedReader.java:45)
at org.nschmidt.ldparteditor.data.DatFile.parseForData(DatFile.java:1149)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.openFileIn3DEditor(Editor3DWindow.java:3799)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.lambda$run$56(Editor3DWindow.java:1969)
at org.nschmidt.ldparteditor.helper.WUtil$5.widgetSelected(WUtil.java:82)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4243)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1060)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1084)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1069)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:773)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:3248)
at org.eclipse.swt.custom.CTabFolder.destroyItem(CTabFolder.java:812)
at org.eclipse.swt.custom.CTabItem.dispose(CTabItem.java:132)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow$7.close(Editor3DWindow.java:1946)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1961)
at org.eclipse.swt.custom.CTabFolder.lambda$init$0(CTabFolder.java:336)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4243)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1060)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4060)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3632)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:823)
at org.eclipse.jface.window.Window.open(Window.java:799)
at org.nschmidt.ldparteditor.shell.editor3d.Editor3DWindow.run(Editor3DWindow.java:2032)
at org.nschmidt.ldparteditor.splash.SplashScreen.run(SplashScreen.java:414)
at org.nschmidt.ldparteditor.main.LDPartEditor.main(LDPartEditor.java:48)
LEGO ergo sum
Reply
Thanks for the log file entry!
#31
Hi Willy,

thanks. This is very helpful. I saw that the problem is also present in older versions of LDPE (e.g. 0.8.53).
I created issue #890 and will solve this with the next release (1.8.55).

Cheers,
Nils
Reply
RE: 1.8.54 Beta Released (bugfixes / no Java / new installers)
#32
When I'm rotating part in LDPE, it seem to not rotate correctly 1-16 chrd's, rotating them in unpredictable way
   
Reply
Difficult selection / rotation of 1-16chrd.
#33
(2022-03-26, 13:18)Max Murtazin Wrote: When I'm rotating part in LDPE, it seem to not rotate correctly 1-16 chrd's, rotating them in unpredictable way

Thanks, Max. I created issue #891.
Will try to solve the problem with the next release.
Reply
RE: Difficult selection / rotation of 1-16chrd.
#34
(2022-03-28, 20:16)Nils Schmidt Wrote: Will try to solve the problem with the next release.
That will be really helpful Wink
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)