LDCad Stringstuds


Stringstuds
#1
New LDCad user here,


While building I must have hit some short-keys. It appears I permanently part grouped a good portion of my model. I attempted to un-group (ctrl-shift-g) but it had no effect. when i hover over the grouped parts it reads stringStudsLQ-1.ldr. When I go into nested editing I can manipulate the grouped parts. When I switch back to normal editing they are still grouped. I've spent 2 days looking for a solution. I need help. Huh Thanks in advance.


-Wes


https://imgur.com/48ysAhU


Attached Files Thumbnail(s)
   
Reply
RE: Stringstuds
#2
Hi Wes,
Welcome here!
I think (according to status bar) that you tried to create a string (this creates a submodel) then added parts to that submodel.
You can learn more about submodels here: http://www.melkert.net/LDCad/docs/advEdit
...but your case looks a bit special/complex. Can you share your mpd file, I'll have a look to get back a normal behaviour from it.
Reply
RE: Stringstuds
#6
(2020-12-19, 9:41)Philippe Hurbain Wrote: Hi Wes,
Welcome here!
I think (according to status bar) that you tried to create a string (this creates a submodel) then added parts to that submodel.
You can learn more about submodels here: http://www.melkert.net/LDCad/docs/advEdit
...but your case looks a bit special/complex. Can you share your mpd file, I'll have a look to get back a normal behaviour from it.

Hi Philippe,

Here is the file. I'll check out the link. Thanks for the welcome and thank you for any help.

-Wes


Attached Files
.ldr   StringStuds.ldr (Size: 23.38 KB / Downloads: 1)
Reply
RE: Stringstuds
#3
(2020-12-19, 8:05)Wes Wrote: New LDCad user here,


While building I must have hit some short-keys. It appears I permanently part grouped a good portion of my model. I attempted to un-group (ctrl-shift-g) but it had no effect. when i hover over the grouped parts it reads stringStudsLQ-1.ldr. When I go into nested editing I can manipulate the grouped parts. When I switch back to normal editing they are still grouped. I've spent 2 days looking for a solution. I need help. Huh Thanks in advance.


-Wes


https://imgur.com/48ysAhU

Yeah, it looks like you added these parts inside a flexible part subfile, rather than in the main model. They probably aren't actually grouped, since nested editing lets you manipulate the parts separately, which is why un-grouping has no effect.

Try double-clicking the whole thing (while not in nested editing) and see if it takes you inside the string subfile. If it does, you should be able to cut/copy all the parts you want, then return to the main model and paste them there. (In the upper right corner—which it looks like you've redacted?—click and choose the item with {M} next to it to return to the main model.)
Reply
RE: Stringstuds
#4
(2020-12-19, 17:35)N. W. Perry Wrote: If it does, you should be able to cut/copy all the parts you want, then return to the main model and paste them there.
I'm afraid auto groups in flex parts comes into play and makes things more complex...
Reply
RE: Stringstuds
#9
(2020-12-19, 18:21)Philippe Hurbain Wrote: I'm afraid auto groups in flex parts comes into play and makes things more complex...

That was my first thought, but if he can manipulate the parts individually by going into nested mode…usually the auto groups will stay grouped in nested mode. (I think…actually it's a little unpredictable sometimes…)

…and of course, looking at the file now, the parts did get auto-grouped into the path start group, but I can still move them independently. (Perhaps because there are no path points?)
Reply
RE: Stringstuds
#7
Exclamation 
(2020-12-19, 17:35)N. W. Perry Wrote: Yeah, it looks like you added these parts inside a flexible part subfile, rather than in the main model. They probably aren't actually grouped, since nested editing lets you manipulate the parts separately, which is why un-grouping has no effect.

Try double-clicking the whole thing (while not in nested editing) and see if it takes you inside the string subfile. If it does, you should be able to cut/copy all the parts you want, then return to the main model and paste them there. (In the upper right corner—which it looks like you've redacted?—click and choose the item with {M} next to it to return to the main model.)

Hi,

Ya, I'm not sure how i created a subfile/session. I attempted to double-click into the subfile/session and copy/paste. No effect. I also attempted to copy/paste the parts while in the subfile/session, delete the session (bad idea), and paste the parts into main. Couldn't recover the work i did. Luckily I didn't save. I suppose my next question is there another way to copy the work you do in a subfile/session and move it into main? 

Thanks for your time,

-Wes


Attached Files Thumbnail(s)
           
Reply
RE: Stringstuds
#10
(2020-12-20, 0:42)Wes Wrote: Hi,

Ya, I'm not sure how i created a subfile/session. I attempted to double-click into the subfile/session and copy/paste. No effect. I also attempted to copy/paste the parts while in the subfile/session, delete the session (bad idea), and paste the parts into main. Couldn't recover the work i did. Luckily I didn't save. I suppose my next question is there another way to copy the work you do in a subfile/session and move it into main? 

Thanks for your time,

-Wes

Yeah, I could cut or copy the parts, but not paste them into the main subfile, as Roland explains below. Normally you'd be able to move parts from a subfile to the main file, the issue here is just that the subfile is a flexible part, so you're copy/pasting two different types of code.

Hand-editing the .mpd file is probably the quickest way to fix it. It may seem intimidating at first, but actually it can be very helpful because you can see right away what you're changing and how it relates to what LDCad does. Just make a duplicate copy to practice editing, and if something goes wrong you can always revert to your original and re-build the model in LDCad instead.
Reply
RE: Stringstuds
#11
(2020-12-20, 3:13)N. W. Perry Wrote: Yeah, I could cut or copy the parts, but not paste them into the main subfile, as Roland explains below. Normally you'd be able to move parts from a subfile to the main file, the issue here is just that the subfile is a flexible part, so you're copy/pasting two different types of code.

Hand-editing the .mpd file is probably the quickest way to fix it. It may seem intimidating at first, but actually it can be very helpful because you can see right away what you're changing and how it relates to what LDCad does. Just make a duplicate copy to practice editing, and if something goes wrong you can always revert to your original and re-build the model in LDCad instead.

I remember adding a flexible part (OMG string studs was the part! lol . .just realized). I did notice the part was only partially there after looking closely though. I deviated hard and didn't realize i was building into a separate file.  I'll give the hand editing a shot just for the exposure. Would most likely be beneficial to know. Apologies for the derp. So if I add a flexible part how should I add it into main? I know there are like 2 options right?

Thank you
Reply
RE: Stringstuds
#5
(2020-12-19, 8:05)Wes Wrote: It appears I permanently part grouped a good portion of my model.

I think Philo is right, you added the bricks to the string submodel.

Problem is parts in such models are handled differently so you can't copy paste them to the main model.

If you don't want to redo the model you could edit the ldraw file

Look for lines like:
0 !LDCAD PATH_CAP [group=start] [color=0] [posOri=60 -24 -40 1 0 0 0 1 0 0 0 1] [part=3005.dat] [extraLen=0mm] [inlineRef=false]

and change them into lines like these
1 0 60 -24 -40 1 0 0 0 1 0 0 0 1 3005.dat

So you take a '1', followed by the number after color=, and the part after posOri= upto the ] and close the line with the  .dat name.

Do this for all the lines except the ones with [part=572a.dat] and [part=ldcRopeEnd.dat] in them.

As a last step move all the changed lines to the bottom of the first subfile (above the second 0 FILE .... line)
Reply
RE: Stringstuds
#8
(2020-12-19, 20:40)Roland Melkert Wrote: I think Philo is right, you added the bricks to the string submodel.

Problem is parts in such models are handled differently so you can't copy paste them to the main model.

If you don't want to redo the model you could edit the ldraw file

Look for lines like:
0 !LDCAD PATH_CAP [group=start] [color=0] [posOri=60 -24 -40 1 0 0 0 1 0 0 0 1] [part=3005.dat] [extraLen=0mm] [inlineRef=false]

and change them into lines like these
1 0 60 -24 -40 1 0 0 0 1 0 0 0 1 3005.dat

So you take a '1', followed by the number after color=, and the part after posOri= upto the ] and close the line with the  .dat name.

Do this for all the lines except the ones with [part=572a.dat] and [part=ldcRopeEnd.dat] in them.

As a last step move all the changed lines to the bottom of the first subfile  (above the second 0 FILE .... line)

Hello Roland,

Thanks for your reply! I suppose I could just go back to main and reference the subfile/session and just add those parts back to main manually. I'm not confident enough to edit files (I tripped into subfiles/sessions and didn't realize, lol). I'm afraid of worsening my situation.  Confused  Should only take me a few hours . . or 8.  Sad

Again thanks for your time and help. 

-Wes
Reply
RE: Stringstuds
#12
(2020-12-20, 1:13)Wes Wrote: Thanks for your reply! I suppose I could just go back to main and reference the subfile/session and just add those parts back to main manually. I'm not confident enough to edit files (I tripped into subfiles/sessions and didn't realize, lol). I'm afraid of worsening my situation.  Confused  Should only take me a few hours . . or 8.  Sad

I realized there is another option, should be much easier.

- open your saved model in e.g. notepad.
- search for 0 !LDCAD GENERATED
- copy all lines starting with 1 up to the 0 FILE line
- open a second empty notpad
- paste the copied content
- remove any line containing 572a.dat
- remove any line containing 4-4cyli.dat
- remove any line ending in .ldr
- copy the remaining lines.
- Open LDCad and start a new model.
- paste the copied lines (ctrl+v)
- Optionally copy paste all 'normal' parts from the old model inside LDCad itself by opening the old model too.
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 2 Guest(s)