LPUB3D model only rendered in small area


LPUB3D model only rendered in small area
#1
Hi,

I have the following problem:     

On the page is enough space for the model but it's only rendered in this small area. I have no idea how to fix this and I'm absolute beginner. I use LDGLite as a render and LPUB3D on Mac OS 

I think my code looks rather normal (not everything just until the step where it looks wrong):

Code:
0 voyager
0 Name: voyager.ldr
0 ROTSTEP 10.000 10.000 -150.000 REL
1 71 576.035522 -208 52.500443 0 0 1 0 1 0 -1 0 0 3029.dat
1 71 576.035461 -200 142.500458 1 0 0 0 1 0 0 0 1 3710.dat
1 71 576.035461 -200 92.500458 0 0 1 0 1 0 -1 0 0 3020.dat
1 71 616.035461 -200 92.500443 -1 0 0 0 1 0 0 0 -1 63330.dat
1 71 536.035461 -200 92.500435 -1 0 0 0 1 0 0 0 -1 63333.dat
1 71 576.0354 -200 32.500423 1 0 0 0 1 0 0 0 1 18980.dat
0 STEP
0 ROTSTEP 10.290 10.165 29.949 REL
1 71 576.0354 -216 162.500427 1 0 0 0 1 0 0 0 1 3710.dat
1 71 636.035461 -208 112.500458 -1 0 0 0 1 0 0 0 -1 63330.dat
1 71 516.035461 -208 112.500427 -1 0 0 0 1 0 0 0 -1 63333.dat
1 71 576.035461 -216 72.500488 0 0 1 0 1 0 -1 0 0 3036.dat
1 71 636.035461 -208 32.500443 0 0 1 0 1 0 -1 0 0 3020.dat
1 71 516.035522 -208 32.500431 0 0 1 0 1 0 -1 0 0 3020.dat
0 STEP
1 71 646.0354 -216 -7.499573 0 0 -1 0 1 0 1 0 0 2436a.dat
1 71 506.035431 -216 -7.499577 0 0 1 0 1 0 -1 0 0 2436a.dat
1 71 646.035461 -216 52.500446 0 0 -1 0 1 0 1 0 0 99781.dat
1 71 506.035461 -216 52.500458 0 0 1 0 1 0 -1 0 0 99781.dat
1 71 646.035461 -208 -27.499556 0 0 1 0 1 0 -1 0 0 3023.dat
1 71 506.035461 -208 -27.499548 0 0 -1 0 1 0 1 0 0 3023.dat
1 71 576.035461 -216 -17.499538 -1 0 0 0 1 0 0 0 -1 3666.dat
0 STEP
1 71 567.035461 0 591.500366 0 0 1 0 1 0 -1 0 0 sub1.ldr
0 STEP
1 71 545.964417 -240 -17.499554 1 0 -0 0 1 0 0 0 1 3024.dat
1 71 545.964355 -232 -37.499546 -0 0 -1 0 1 0 1 0 -0 3623.dat
1 71 545.964355 -256 -37.499546 1 0 -0 0 1 0 0 0 1 50950.dat
1 71 545.964417 -224 -17.499554 0 0 1 0 1 0 -1 0 0 2420.dat

Thanks for any help
Reply
RE: LPUB3D model only rendered in small area
#2
(2018-10-24, 20:14)cusaro Wrote: Hi,

I have the following problem: 

On the page is enough space for the model but it's only rendered in this small area. I have no idea how to fix this and I'm absolute beginner. I use LDGLite as a render and LPUB3D on Mac OS 

I think my code looks rather normal (not everything just until the step where it looks wrong):

Code:
0 voyager
0 Name: voyager.ldr
0 ROTSTEP 10.000 10.000 -150.000 REL
1 71 576.035522 -208 52.500443 0 0 1 0 1 0 -1 0 0 3029.dat
1 71 576.035461 -200 142.500458 1 0 0 0 1 0 0 0 1 3710.dat
1 71 576.035461 -200 92.500458 0 0 1 0 1 0 -1 0 0 3020.dat
1 71 616.035461 -200 92.500443 -1 0 0 0 1 0 0 0 -1 63330.dat
1 71 536.035461 -200 92.500435 -1 0 0 0 1 0 0 0 -1 63333.dat
1 71 576.0354 -200 32.500423 1 0 0 0 1 0 0 0 1 18980.dat
0 STEP
0 ROTSTEP 10.290 10.165 29.949 REL
1 71 576.0354 -216 162.500427 1 0 0 0 1 0 0 0 1 3710.dat
1 71 636.035461 -208 112.500458 -1 0 0 0 1 0 0 0 -1 63330.dat
1 71 516.035461 -208 112.500427 -1 0 0 0 1 0 0 0 -1 63333.dat
1 71 576.035461 -216 72.500488 0 0 1 0 1 0 -1 0 0 3036.dat
1 71 636.035461 -208 32.500443 0 0 1 0 1 0 -1 0 0 3020.dat
1 71 516.035522 -208 32.500431 0 0 1 0 1 0 -1 0 0 3020.dat
0 STEP
1 71 646.0354 -216 -7.499573 0 0 -1 0 1 0 1 0 0 2436a.dat
1 71 506.035431 -216 -7.499577 0 0 1 0 1 0 -1 0 0 2436a.dat
1 71 646.035461 -216 52.500446 0 0 -1 0 1 0 1 0 0 99781.dat
1 71 506.035461 -216 52.500458 0 0 1 0 1 0 -1 0 0 99781.dat
1 71 646.035461 -208 -27.499556 0 0 1 0 1 0 -1 0 0 3023.dat
1 71 506.035461 -208 -27.499548 0 0 -1 0 1 0 1 0 0 3023.dat
1 71 576.035461 -216 -17.499538 -1 0 0 0 1 0 0 0 -1 3666.dat
0 STEP
1 71 567.035461 0 591.500366 0 0 1 0 1 0 -1 0 0 sub1.ldr
0 STEP
1 71 545.964417 -240 -17.499554 1 0 -0 0 1 0 0 0 1 3024.dat
1 71 545.964355 -232 -37.499546 -0 0 -1 0 1 0 1 0 -0 3623.dat
1 71 545.964355 -256 -37.499546 1 0 -0 0 1 0 0 0 1 50950.dat
1 71 545.964417 -224 -17.499554 0 0 1 0 1 0 -1 0 0 2420.dat

Thanks for any help


Upload the file if possible so we can analyze it. this happen to me some time i was not able to fix it either, what i did was make smaler that step as a work arround. i hope we can get the correct solution
Reply
RE: LPUB3D model only rendered in small area
#3
Hi,

here is the file
.ldr   voyager_short.ldr (Size: 19.49 KB / Downloads: 3) . I delete everything that follows. It's broken in the step after after the subsection.

Thanks for the help.
Reply
RE: LPUB3D model only rendered in small area
#4
(2018-10-25, 11:27)cusaro Wrote: Hi,

here is the file . I delete everything that follows. It's broken in the step after after the subsection.

Thanks for the help.
Weird (as it often happens with LPub)... The size of assembly images on my machine (Windows/LPub3d 2.2.1/LDView renderer) was correct, but many pages didn't show part list box! I tried to refresh the LPub3D zipped library to no avail, then noticed that coordinates of parts showed an unusual number of decimals. I rounded them using LDDP, and now could get correct part list at every step.
This was the good news... I then switched to LDGlite, and there I get same cropped assembly image as you Sad

Edit: out of curiosity, I tried Studio instruction generator on your file. Worked fine...
Reply
RE: LPUB3D model only rendered in small area
#5
(2018-10-25, 13:41)Philippe Hurbain Wrote:
(2018-10-25, 11:27)cusaro Wrote: Hi,

here is the file . I delete everything that follows. It's broken in the step after after the subsection.

Thanks for the help.
Weird (as it often happens with LPub)... The size of assembly images on my machine (Windows/LPub3d 2.2.1/LDView renderer) was correct, but many pages didn't show part list box! I tried to refresh the LPub3D zipped library to no avail, then noticed that coordinates of parts showed an unusual number of decimals. I rounded them using LDDP, and now could get correct part list at every step.
This was the good news... I then switched to LDGlite, and there I get same cropped assembly image as you Sad

Edit: out of curiosity, I tried Studio instruction generator on your file. Worked fine...

other thing i have realized is that if you change the page size or if you put it in landscape you the render is done in the correct way.

its a lpub bug

[Image: xk2Nxxq.png]


this is done with weblic

[Image: 3006323d-aa8a-44de-bbde-13c701b6c0ce.png]

this is done with [Image: zJ4gX4B.png]

all other software renderds the page manual as its expected its defenitly a  ldpub bug.
Reply
RE: LPUB3D model only rendered in small area
#6
Which version of LPub3D are you using? And does it also happen with LDView as renderer?
Reply
RE: LPUB3D model only rendered in small area
#7
(2018-10-26, 11:15)Merlijn Wissink Wrote: Which version of LPub3D are you using? And does it also happen with LDView as renderer?

I'm using 2.3.2 of Lpub 3d.

In ldview does render ok
Reply
RE: LPUB3D model only rendered in small area
#8
(2018-10-26, 16:58)tatubias Wrote:
(2018-10-26, 11:15)Merlijn Wissink Wrote: Which version of LPub3D are you using? And does it also happen with LDView as renderer?

I'm using 2.3.2 of Lpub 3d.

In ldview does render ok

I think, Merlijn means if you use LDView as Preferred renderer in LPub3D.


Attached Files Thumbnail(s)
   
If nothing goes right, go left.
Reply
RE: LPUB3D model only rendered in small area
#9
(2018-10-26, 20:00)Johann Eisner Wrote:
(2018-10-26, 16:58)tatubias Wrote: I'm using 2.3.2 of Lpub 3d.

In ldview does render ok

I think, Merlijn means if you use LDView as Preferred renderer in LPub3D.

That fixed my issue too. i was using LDGview lite. LDView is slower render but now with this update on the configuration is working :Smile wiiiiiiii

Probably I will be using ldgview lite while editing the building instructions and before publishing the pdf I will switch to ldview renderer
Reply
RE: LPUB3D model only rendered in small area
#10
(2018-10-26, 20:26)tatubias Wrote: That fixed my issue too. i was using LDGview lite. LDView is slower render but now with this update on the configuration is working :Smile wiiiiiiii

Probably I will be using ldgview lite while editing the building instructions and before publishing the pdf I will switch to ldview renderer

Cool! Yeah LDView is slower, but it's not nearly as slow as it used to be in the past.  Wink
Also, a new version 2.3.3 has just been released. I'd recommend you try that one to see if the LDGLite problems still persist or if they have been solved (there are numerous bugfixes in 2.3.3). If the problem still persists with the new version, I recommend you post a new issue/bug report here and Trevor (the developer) will gladly help you  Smile
Reply
RE: LPUB3D model only rendered in small area
#11
(2018-10-27, 7:45)Merlijn Wissink Wrote:
(2018-10-26, 20:26)tatubias Wrote: That fixed my issue too. i was using LDGview lite. LDView is slower render but now with this update on the configuration is working :Smile wiiiiiiii

Probably I will be using ldgview lite while editing the building instructions and before publishing the pdf I will switch to ldview renderer

Cool! Yeah LDView is slower, but it's not nearly as slow as it used to be in the past.  Wink
Also, a new version 2.3.3 has just been released. I'd recommend you try that one to see if the LDGLite problems still persist or if they have been solved (there are numerous bugfixes in 2.3.3). If the problem still persists with the new version, I recommend you post a new issue/bug report here and Trevor (the developer) will gladly help you  Smile

Excellent news 2.3.2 version had lots of issues that the app closes when rendering complex models and making changes. Like if you want to add rotstep from th3 3dviewer it hangs and closes. I have not tested the 2.3.3 version yet.

I attaching the download link from source forge.
Lpub3D download link:
Reply
RE: LPUB3D model only rendered in small area
#12
Thanks for the massiv help. 2.3.3 sadly don't solve my issue. I try to use LDView but I get the following error:

Code:
Incompatible library version: LDView requires version 9.0.0 or later, but libOSMesa.8.dylib provides version 8.0.0

The file is indeed rendered correct in the other programs mentioned above. I try to get LDView running on my Mac with High Sierra
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)