UTF 8 font (emojis)


UTF 8 font (emojis)
#1
Rainbow 
In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this forum additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)
Reply
RE: UTF 8 font (emojis)
#2
(2018-03-13, 19:17)Steffen Wrote: In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this form additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)

This is indeed a font issue. Not sure if this is a quick fix
Reply
RE: UTF 8 font (emojis)
#3
(2018-03-13, 20:09)Orionย Pobursky Wrote:
(2018-03-13, 19:17)Steffen Wrote: In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this form additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)

This is indeed a font issue. Not sure if this is a quick fix

I may be wrong. This may be a database issue which is much harder to change
Reply
RE: UTF 8 font (emojis)
#4
(2018-03-13, 19:17)Steffen Wrote: In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this form additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)

This turned out to be super-easy. Emoji are now supported although anything entered before now will still show as question marks due to the old database encoding.
Reply
RE: UTF 8 font (emojis)
#5
(2018-03-14, 3:30)Orionย Pobursky Wrote: This turned out to be super-easy.

cool, I thought so!
many thanks!

๐Ÿถ ๐Ÿฑ ๐Ÿญ ๐Ÿน ๐Ÿฐ ๐ŸฆŠ ๐Ÿป ๐Ÿผ ๐Ÿจ ๐Ÿฏ ๐Ÿฆ ๐Ÿฎ ๐Ÿท ๐Ÿฝ ๐Ÿธ ๐Ÿต ๐Ÿ™Š ๐Ÿ™‰ ๐Ÿ™Š ๐Ÿ’ ๐Ÿ” ๐Ÿง ๐Ÿฆ ๐Ÿค ๐Ÿฃ ๐Ÿฅ ๐Ÿฆ† ๐Ÿฆ… ๐Ÿฆ‰ ๐Ÿฆ‡ ๐Ÿบ ๐Ÿ— ๐Ÿด ๐Ÿฆ„ ๐Ÿ ๐Ÿ› ๐Ÿฆ‹ ๐ŸŒ ๐Ÿš ๐Ÿž ๐Ÿœ ๐Ÿ•ท ๐Ÿ•ธ ๐Ÿข ๐Ÿ ๐ŸฆŽ ๐Ÿฆ‚ ๐Ÿฆ€ ๐Ÿฆ‘ ๐Ÿ™ ๐Ÿฆ ๐Ÿ  ๐ŸŸ ๐Ÿก ๐Ÿฌ ๐Ÿฆˆ ๐Ÿณ ๐Ÿ‹ ๐ŸŠ ๐Ÿ† ๐Ÿ… ๐Ÿƒ ๐Ÿ‚ ๐Ÿ„ ๐ŸฆŒ ๐Ÿช ๐Ÿซ ๐Ÿ˜ ๐Ÿฆ ๐Ÿฆ ๐ŸŽ ๐Ÿ– ๐Ÿ ๐Ÿ ๐Ÿ‘ ๐Ÿ• ๐Ÿฉ ๐Ÿˆ ๐Ÿ“ ๐Ÿฆƒ ๐Ÿ•Š ๐Ÿ‡ ๐Ÿ ๐Ÿ€ ๐Ÿฟ ๐Ÿพ ๐Ÿ‰ ๐Ÿฒ ๐ŸŒต ๐ŸŽ„ ๐ŸŒฒ ๐ŸŒณ ๐ŸŒด ๐ŸŒฑ ๐ŸŒฟ โ˜˜๏ธ ๐Ÿ€ ๐ŸŽ ๐ŸŽ‹ ๐Ÿƒ ๐Ÿ‚ ๐Ÿ ๐Ÿ„ ๐ŸŒพ ๐Ÿ’ ๐ŸŒท ๐ŸŒน ๐Ÿฅ€ ๐ŸŒป ๐ŸŒผ ๐ŸŒธ ๐ŸŒบ ๐ŸŒŽ ๐ŸŒ ๐ŸŒ ๐ŸŒ• ๐ŸŒ– ๐ŸŒ— ๐ŸŒ˜ ๐ŸŒ‘ ๐ŸŒ’ ๐ŸŒ“ ๐ŸŒ” ๐ŸŒš ๐ŸŒ ๐ŸŒž ๐ŸŒ› ๐ŸŒœ ๐ŸŒ™ ๐Ÿ’ซ โญ๏ธ ๐ŸŒŸ โœจ โšก๏ธ ๐Ÿ”ฅ ๐Ÿ’ฅ โ˜„๏ธ โ˜€๏ธ ๐ŸŒค โ›…๏ธ ๐ŸŒฅ ๐ŸŒฆ ๐ŸŒˆ โ˜๏ธ ๐ŸŒง โ›ˆ ๐ŸŒฉ ๐ŸŒจ โ˜ƒ๏ธ โ›„๏ธ โ„๏ธ ๐ŸŒฌ ๐Ÿ’จ ๐ŸŒช ๐ŸŒซ ๐ŸŒŠ ๐Ÿ’ง ๐Ÿ’ฆ โ˜”๏ธ
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)