UTF 8 font (emojis)


UTF 8 font (emojis)
#1
Rainbow 
In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this forum additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)
Reply
RE: UTF 8 font (emojis)
#2
(2018-03-13, 19:17)Steffen Wrote: In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this form additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)

This is indeed a font issue. Not sure if this is a quick fix
Reply
RE: UTF 8 font (emojis)
#3
(2018-03-13, 20:09)Orion Pobursky Wrote:
(2018-03-13, 19:17)Steffen Wrote: In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this form additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)

This is indeed a font issue. Not sure if this is a quick fix

I may be wrong. This may be a database issue which is much harder to change
Reply
RE: UTF 8 font (emojis)
#4
(2018-03-13, 19:17)Steffen Wrote: In post
https://forums.ldraw.org/thread-15660-po...l#pid28166
, I used normal UTF8 emojis, i.e., the heart-eyes one:
https://emojipedia.org/smiling-face-with...aped-eyes/

The forum SW seemingly converted those to "?" characters.
Is there a chance to fix that?
I think a simple switch to a different forum font for posts rendering which has emojis should cure the problem.
(I know that this form additionally features its own emoji syntax, but that always should be just additional to UTF8 IMHO.)

(This of course has low prio.)

This turned out to be super-easy. Emoji are now supported although anything entered before now will still show as question marks due to the old database encoding.
Reply
RE: UTF 8 font (emojis)
#5
(2018-03-14, 3:30)Orion Pobursky Wrote: This turned out to be super-easy.

cool, I thought so!
many thanks!

? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ☘️ ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ⭐️ ? ✨ ⚡️ ? ? ☄️ ☀️ ? ⛅️ ? ? ? ☁️ ? ⛈ ? ? ☃️ ⛄️ ❄️ ? ? ? ? ? ? ? ☔️
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)