[LDPartEditor] 0.8.15 Beta Released


[LDPartEditor] 0.8.15 Beta Released
#1
Hey :)

good news: I found and fixed more bugs, but 0.8.15 has new features, too.

[Image: imgDuke2.png]
As always, you can download LDPE from this page:
http://nilsschmidt1337.github.io/ldparteditor/

Changelog:
(3 new features and 6 bug fixes)

With this release you will be able to...
  • ...randomise the colours for a selection.
  • ...benefit from a little bit better 3D render performance.
  • ...see the version number in the window title from the 3D editor.
The following critical issues were fixed:

  1. It was not possible to change the colour of CSG objects (3D editor)
  2. After closing a file in the 3D editor with "Close" in the parts tree window and actually vanishing from the 3D and Text editor it cannot be deleted in the explorer telling that the file is open in the SE java platform.
  3. Fixed a NullPointerException which occurred during the transformation of CSG bodies (3D editor only)
  4. Fixed a NullPointerException which occurred during the colour change for CSG bodies (3D editor only)
  5. The QuickFix for the part description transformed the first line into a comment.
  6. Line-type 1 syntax highlighting / warning (text editor): Wrong yellow underline for files which were found on the hard-disk.
What will the next release 0.8.16 deliver? Usability improvements, maybe some new fancy features...



The program was tested intensively with "real world" files.
However, it is still a beta version and something can go wrong in about 100.000 lines of code.

Make sure that you choose the right architecture for your OS and Java Virtual Machine (JVM) (64bit or 32bit).
A short guide how to check if a 64bit JVM is installed on your system is located at the bottom of this message.

  1. Download the zip-Archive
  2. Extract the archive content to the location of your choice
  3. On windows, double-click "run.bat" to start LDPE.
  4. On linux/mac, you have to excecute the shell script "run.sh" to start LDPE.
Please note that this software is in the beta stage. Although, LDPE 0.8.15 was tested, there are already known issues  for this release. There is a potential risk of data loss.

You can search for updates if you do the following steps:

  1. On windows, double-click "update.bat" to search for updates.
  2. On linux/mac, you have to excecute the shell script "update.sh".
I listen carefully to your requests and possible complaints. Please leave me a message, with your thoughts and wishes to further improve the software.

LDPE is a 3D CAD application: The overall system requirements are higher. While I recommend to use a powerful 64-bit multicore system, it could be possible, to run LDPE on older machines as well.

System Requirements:

Minimum System Requirements:
  • Java Runtime Environment (JRE) 1.8
  • OpenGL 2.1 compatible Graphics Card
  • Operating System (32/64bit): Windows [XP; Vista; 7 or newer], Mac OS X [>=10.6], Linux [e.g. Ubuntu Linux >=10.4]
  • CPU: Multicore-Processor e.g. Intel Core 2 Duo or AMD Athlon II (>2.0Ghz)
  • RAM: 4GB
  • Video-Memory: 512 MB
  • Free Disk Space: 100 MB
Recommended Requirements:
  • Operating System (64bit): Windows 7, Mac OS X [>=10.6], Linux [e.g. Ubuntu Linux >=10.4]
  • CPU: Multicore-Processor with 4 cores (or more)
  • RAM: >4 GB
  • Video-Memory: >=1 GB
  • Free Disk Space: 512 MB
--------------------------------------------------------------------------------
How to check your JVM version (32- or 64-bit):
--------------------------------------------------------------------------------

You can try on the command line:

Code:
java -d64 version

If it's not a 64-bit version, you'll get a message that looks like:

Code:
This Java instance does not support a 64-bit JVM. Please install the desired version.

In general, I recommend to install the 64-bit version of the JVM for Java 8.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#2
I'm unable to start this version. I get an error message like this:
---------------------------
Java Virtual Machine Launcher
---------------------------
Error: Unable to access jarfile LDPartEditor.jar
---------------------------
OK   
---------------------------

PS.
I should also mention that I have upgraded my pc to use Win10 now, and I'm not sure I understand all the differencies yet.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#3
I downloaded and extracted the files to a place utside the Program(x86)-folder, but I still can't make it start. This time I got a error-log.


Attached Files
.txt   error_log.txt (Size: 1.79 KB / Downloads: 2)
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#4
(2016-05-18, 16:29)Magnus Forsberg Wrote: I downloaded and extracted the files to a place utside the Program(x86)-folder, but I still can't make it start. This time I got a error-log.

Are you sure you downloaded the right version? Log file seems to imply that your LDPE is 32 bit but your Java is 64 bit. For the record, it works here (64bit / Win7)
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#5
(2016-05-18, 18:18)Philippe Hurbain Wrote: Are you sure you downloaded the right version?

Stupid mistake. Your right, I downloaded the wrong version. Now it works, but only if I place it outside the Program(x86)-folder.
I think maybe I should relocate all of my files. Win10 opposes nearly everything I try to move there.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#6
(2016-05-18, 20:26)Magnus Forsberg Wrote: Stupid mistake. Your right, I downloaded the wrong version. Now it works, but only if I place it outside the Program(x86)-folder.
I think maybe I should relocate all of my files. Win10 opposes nearly everything I try to move there.

Normally I wouldn't defend Microsoft, but Program Files and Program Files (x86) have been secured since Vista, and the reason they were secured was extremely legitimate. In 2016, programs that don't work there are at fault, not Windows. I think I should point out that programs running in Linux have the same restriction: don't write files to the program folder. Of course, that's been the case since before Linux was created (with other *nix OSes), and writing to the program folder was originally the recommended behavior on Windows. But Vista was released in 2006, and writing to the program folder has been a no-no ever since then.

Having said that, if there is a program you want to run, and it requires you to install it somewhere else, then the pragmatic thing to do is to install it somewhere else.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#8
(2016-05-19, 1:40)Travis Cobbs Wrote: Having said that, if there is a program you want to run, and it requires you to install it somewhere else, then the pragmatic thing to do is to install it somewhere else.

I've never had a Vista machine and Win 7 never objected to anything I did, given the fact that I'm the sole user on my machine and have admin rights on it. After upgrading to Win 10 I'm no longer trusted to handle my own machine and I object to that behaviour.
I've been taught to install every program in the Program-folder since Win 3.0 and maybe thats the reason for me doing it like I've allways done it.
I guess I have to adapt to the "new" way of installing my programs.

The AIOI chooses C:/Program files(x86) as a default place to install, but the tutorial also says:
Quote:Keep the default location or provide an alternative location to install the LDraw System Of Tools. Change the location only if you know exactly what you're doing. On a 64-Bit OS resist installing to the C:\Program files folder. The installer won't complain but you might run into compatibility issues later.

Where do you have your ldraw programs installed? To me, it feels very wrong to place them in My Documents.
Where do I move my files to "do it the right way"? C:/user/username/ldraw ?
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#9
Always put all my LDraw stuff in C:\LDraw, the old way...
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#7
Question and wish of the day...
- When I'm done with it, how do I get rid of a protractor/distance meter other that removing line in text editor? I just noticed that selection of measurement is done in line mode, and protractor in surface mode.
- When I am using the move or rotate tool (while "pulling" the arrow), I'd like to see the diatance traveled/angle rotated, preferably near manipulator. The value should disappear (and be reset) as soon as I release the mouse button.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#10
Bug: when you mirror a selection, winding of triangle/quads is correctly inverted. But primitives in selection should not be BFC inverted!
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#12
(2016-05-23, 18:45)Philippe Hurbain Wrote: Bug: when you mirror a selection

How is this done?

w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#14
(2016-05-27, 6:22)Willy Tschager Wrote:
(2016-05-23, 18:45)Philippe Hurbain Wrote: Bug: when you mirror a selection

How is this done?

w.

Merge/split -> scale selection -> -1 coefficient.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#18
(2016-05-27, 6:54)Philippe Hurbain Wrote:
(2016-05-27, 6:22)Willy Tschager Wrote:
(2016-05-23, 18:45)Philippe Hurbain Wrote: Bug: when you mirror a selection

How is this done?

w.

Merge/split -> scale selection -> -1 coefficient.

THX,

w.

PS. Would prefer LDPC's icon instead ;-)
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#11
Vertex merge with ctrl-W / ctrl-E is an awesome tool to reduce a mesh in a controlled way. So...
Wish of the day: when selecting several vertices with a marquee, it would be nice if the last vertex enclosed in the marquee became last vertex in selection so that ctrl+E merges all vertices onto this last vertex. That would be a great time saver!

Otherwise, never used so far the merge to nearest edge/face functions. Now I did, and I can say it's an awesome tool to coerce a random mesh to fit a primitive (eg. LDD wig mesh onto a LDraw head)
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#13
Feature request of the day:

Since it is now possible to select in the line numbers I'd like that a double click shows the selection also in the 3D editor.

Bug:

Selecting in the line numbers and hitting "Selection in 3D view" most often in the 3D also the neighbour triangle/quad is selected.

w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#15
Quote:Since it is now possible to select in the line numbers I'd like that a double click shows the selection also in the 3D editor.
It would be great if line selection was more consistent with other Windows selections. Currently shift + line number click simply select that line number only, and ctrl+click on two separated lines selects all the lines in-between. It would be better if ctrl+click on different lines selected all of those lines only (even if separated) and shift+click allowed for a range of lines selection.

Quote:Selecting in the line numbers and hitting "Selection in 3D view" most often in the 3D also the neighbour triangle/quad is selected.
Seems to be related to the fact that clicking on line number also selects line separator.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#16
Question of the day: is it really necessary to open a blank "new.dat" file at LDPC startup? 99.99% of the time the first thing I do is to close it and I have to tell that no, I don't want to save it! At least, it shouldn't be tagged as modified unless really modified...
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#21
(2016-05-27, 7:12)Philippe Hurbain Wrote: Question of the day: is it really necessary to open a blank "new.dat" file at LDPC startup? 99.99% of the time the first thing I do is to close it and I have to tell that no, I don't want to save it! At least, it shouldn't be tagged as modified unless really modified...

+1
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#17
Bug report: Quick fixing of scaled 48\primitives messes up the primitive name. 48\prim.dat is converted to 48prim.dat
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#19
Bug:

the black 3s and 4s were Selected with ...Connected... and ...with Same Color:

   

performing a Cut also some lines with color 16 got cut out:

   

and in addition the cut could not be undone.

w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#20
Feature request of the day:

* I would love if the real and user name could be copied from the options to the header dialog
* I find the dialog far from ideal: first I do not understand why it appends to the file focused in the 3D editor though a header is clearly a text thing, second it gets appended to the bottom even though I have place the cursor at the top - and here comes into play that it focuses on the 3D
* Once again I also would love if the file gets closed in both, text and 3D editor when I close them in one or the other editor

w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#22
For the record, the disappearing surfaces/lines problem I mentionned here http://forums.ldraw.org/thread-21509-pos...l#pid21828 is also present in this version. Fortunately I found a turn around: when I check my part with LDView and notice missing elements, I go back to LDPC (I have learned not to close file before checking), press undo / redo, save again and everything is OK.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#23
In the last days I have fixed a couple of hold voted parts. In the past this would have been a painful process, but with LDPE it could be done in the wink of an eye! It is simple a GOD-DAMN good prog! Thank you Nils for your efforts.

w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#24
(2016-06-05, 22:02)Willy Tschager Wrote: Thank you Nils for your efforts.
+1!
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#25
Feature request of the day:

* I'd like to have the coordinates cross in the bottom right-hand corner of the 3D view flagged with x, y, z.
* When copying/cutting a primitive that has a BFC INVERTNEXT attached the prog should automatically select and copy/cut/past the BFC as well (Text as well as 3D).
* The behavior of automatically selecting as well the neighboring line when clicking in the line numbers bar is really annoying. Please fix it as fast as possible!
* I'd like to have an extra pane that shows which line/triangles/quads/... are hidden via ghost or that they get commented out in the text editor say with a special !HIDDEN meta.
* I'd like to have LDPC's small vertex window in the bottom right corner showing you the x, y, z values of the selected vertex.
w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#26
Bug:

* T_Junctionfinder eliminates lines at random (used Normal mode)

Get a try with this part:

http://www.ldraw.org/cgi-bin/ptdetail.cg.../6644a.dat

and check these lines:

2 4 -5 5 -28 -4 5 -19
2 4 -2 5 -30.5 -2 5 -28
2 4 2 5 -30.5 2 5 -28

w.
LEGO ergo sum
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#27
I noticed something similar (disappearing edge lines) when using the vertex merge to nearest edge function.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#28
Wish of the day: selecting a modification tool (select/move/rotate etc...) should automatically deselect a construction tool (create quad/line/triangle...). Toooo many times I wonder why I can't select or move something because actually I am building a quad!

And the question of the day: when I create new elements from scratch (say lines) how do I manage to put them in the plane I want?
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#29
Bug of the day: BFC INVERTNEXT doesn't work as intended. Scope of the statement should extend only to the next source line. A BFC INVERTNEXT before anything else than a type 1 line should be flagged as an error and be ignored. A BFC INVERTNEXT placed before a flat primitive should trigger a warning with quick fix (mirroring of the flat primitive in flat direction and suppression of BFC INVERTNEXT)
Related: deep inlining of primitives sometimes result in a BFC INVERTNEXT followed by triangle/quads/lines with INVERTNEXT visually acting on all of them. This shouldn't work this way: if inlined primitive needs to be inverted, no BFC INVERTNEXT should be added and all triangle/quads should have their winding swapped.
(Edit) Also related: if you hide an inverted primitive, its BFC INVERTNEXT statement should be ignored instead of beeing carried over next elements.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#30
Nuisance of the day: while you can select a surface by clicking on it even if only a small portion is visible, you can only select lines/condlines if BOTH end vertices are visible.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#31
Flipping two triangles is only possible if I first give them another, different colour, and after I flip them the surrounding cond-lines are gone.
Reply
RE: [LDPartEditor] 0.8.15 Beta Released (randomise colours / bug fix)
#32
A nice thing that LDPE works in illimited precision but... why are the position/scale/rotate/translate entry fields limited to a mere 4 digits after dp?
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)