LPub3D - POV-Ray rendering not working

LPub3D - POV-Ray rendering not working
I've just installed POV-ray and I'm trying to find out what I can do with it from LPub3D

I have gone to Configuration > Preferences > Rendering, ticked the POV-Ray is installed box and found the path for POV-Ray: (C:\Program Files\POV-Ray\v3.7\bin\pvengine64.exe) and L3P (C:\Program Files (x86)\LDraw\LPub3D\3rdParty\l3p1.4WinB\L3P.EXE).
I have also ticked the LGEO is available box as I installed that too (with the AIOI), but I am confused about what to put in that field. There is no executable, so my best guess is C:\Program Files (x86)\LDraw\LGEO

With this in place I have set Preferred Renderer to POV-Ray and tried to render the first page of a set of instructions I am working on. However, POV-Ray throws error message after error message saying something is wrong. I have tried to figure out how to copy the information in the message pane (POV-Ray itself sends me to the Edit menu, but I can't seem to find what I need there) so I can post it here and ask what I may be doing wrong.
Re: LPub3D - POV-Ray rendering not working
Hi, here's a list of what I did recently to troubleshoot a similar issue:

# Install LDraw, LGEO, and POV in paths with no spaces:

# Enable logging in "povray.ini" file:

# Double check "povray.ini" library paths:

# Check L3P location in Environment Path:

# Remove spaces in file name and internal names:

# You might need these old files in "C:\LDraw\LGEO"

# Set IO Restrictions=0 in "pvengine.ini"
IO Restrictions=0

Check this thread for more info:
Re: LPub3D - POV-Ray rendering not working
Thanks. I'm on holiday right now, which, oddly enough, means I have little to no time to check this Sad
I would have expected whatever path the AIOI used to sort of work out of the box, but I get the impression my first mistake may be . I see I get pretty much the same kind of error you describe in your other post

Could not find file ...\LPub\parts\40490_0_1650_150_DPCM_0.75_23_-45.png.ini
Cannot open INI file ...\LPub\parts\40490_0_1650_150_DPCM_0.75_23_-45.png

so I'll try retracing your steps there...
« Next Oldest | Next Newest »

Forum Jump:

Users browsing this thread: 1 Guest(s)