LGEO Parts Update


LGEO Parts Update
#1
Hello all.

After some correspondence with Willy, I thought I'd post a link to an LGEO update I've been working on, the progress of which I have been posting over at Eurobricks.

Lutz Uhlmann seems to have stopped working on LGEO since about 2008, where a large number of his original parts were updated or fixed. However, there are still a number of parts missing from the LGEO library, as well as a few parts that still need fixing.

I have put together an update that contains some more fixes, a few cosmetic updates, as well as some new parts that I have managed to create by either adapting existing parts or (and this took a little while to get my head around) creating parts from scratch.

Although some of my new parts are not perfect, they look good enough when not rendered close up, so I'm happy with them for the time being.

The zip file contains all the relevant files required, and a PDF document of instructions on how to install them.

The current total for the parts pack, as of 2012-08-30, is:

- New parts: 37
- Updated parts: 2
- Fixed parts: 12

Download: LGEO-Update.zip

Incidentally, I've started work on a POV-Ray rendering guide on the LDraw.org wiki, and will publish that properly when it's finished. It'll be based on the Eurobricks guide, but with some tweaks.
Reply
Re: LGEO Parts Update
#2
Excellent. I look forward to trying this out Smile

Tim
Reply
Re: LGEO Parts Update
#3
Thanks for sharing Owen. I'm really looking forward to the tweaks of your already excellent tutorial.

w.
LEGO ergo sum
Reply
Re: LGEO Parts Update
#4
Hello Owen,

I downloaded your lgeo update and wanted to test it. However when I tried to render the file POV-Ray exited with a warning, saying that the texture 'lg_rubber_light_gray' has not been defined.
I might be wrong, but I only found a reference to this texture in the 'lgeo.xml' file; it has not been defined in any POV-Ray file.

thanks, Koos Jan
Reply
Re: LGEO Parts Update
#5
Hi Koos Jan,

I've had a look at the current zip file that I've had online since the first post I made, and can see the "lg_rubber_light_gray" colour defined in both the "LGEO.xml" and "lg_color.inc" files.

Running a test render using this colour seemed to work, so not quite sure why that's not working properly. You've not overwritten your "lg_color.inc" file at all, perhaps?
Reply
Re: LGEO Parts Update
#7
Hello Owen,

thank you for your reply. Everything now works fine. I indeed forgot to overwrite the old file.

Koos Jan
Reply
Re: LGEO Parts Update
#6
I would be interested to see your POV-Ray rendering guide.

Here are some links to recent Lego images that I've rendered in POV-Ray:

Urak-hai (Lurtz)

Superman Minifigure

Superman Minifigure (flying pose)

Reuben

=====================================
Download 3D Lego models and other resources from:
http://www.pearse.co.uk/lego
=====================================
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)