LDCad 1.7 Alpha 1 (win+linux)

RE: LDCad 1.7 Alpha 1 (win+linux)
!DATA testing

In short: I'm lost Smile This is what I've tried and how LDCAD 1.7 Alpha works on my Linux machine (Debian Jessie, x86_64) - sorry for such a long story,I try to describe how to reproduce the strange behavior I got, step by step:

0. Note: where the !DATA support is hidden in GUI: Session->Create new...->Data. This is what I used.

1. Huge black square with a white cross is displayed in the main window, "Edit data header" popup over it and, on top, another popup "LDCAD Error": This is not a png file. With two such messages in Details section, same timestamp. And yes, after clicking "OK" button, second popup with the same error appears. "OK" again and I'm in the Header popup window.

2. I was confused by "Load" and "Save" labels on buttons, at first, so I tried to type the image full path  manually. Accept clicked. I got the same error again: "This is not a png file". Probably because LDCAD replaced all slash chars to backslash chars in the image path.??

3. Load button. Opens a choose file dialog, I selected one of my png files, hit OK. I see "Data File size:....." which looks OK, although the end of the text is hidden behind Load and Save buttons. But the Filename field is not updated with the selected png file and that huge black square with white cross is still here. Even after "Accept" button hitting. So did LDCAD load that png file or not?

4. In the Part bin, I switched to the tab "MPD File content". I see main.ldr and black square submodels there. But after switching to main.ldr and back to "png" subfile, the thumbnail in the part bin got updated! I see the correct png there. In the main window the big black square is still there. But it looks like a moment of hope!

5. I switched back to main.ldr and drag png submodel from part bin to the main window. I got an error "Part usage not allowed in this kind of subfile.".

6. Hypothesis: although I understood Travis' description in the opposite way, it might be that LDCAD allows png subfiles in .dat files only. So I closed LDCAD, started from scratch but, in the end,I got the same error message.

7. The huge black square smiles at me, still. Smile

Did I do anything wrong? What's the intended usage? And how/where I can set the image dimensions in LDus?

Thanks, Roland.

Edit: I saw (in the text editor) the !DATA section was created correctly. So I tried to type the subfile with !TEXMAP lines manually and reopen the file in LDCAD again. Then it works, I can use the new subfile as a sticker. So what's missing is GUI for TEXMAP creation - both for sticker creation and for printed pattern creation.

Attached Files Thumbnail(s)
« Next Oldest | Next Newest »

Messages In This Thread
RE: LDCad 1.7 Alpha 1 (win+linux) - by Milan Vančura - 2021-08-06, 11:16

Forum Jump:

Users browsing this thread: 1 Guest(s)