MacOS LDCad on Wine (for Mac)-revisited

RE: LDCad on Wine (for Mac)-revisited
(2021-04-15, 19:15)Manfred Kern Wrote: I can confirm, that you must first select LDCad in order that mouse over , ... is working. When you select the app it will work.
But in my opinion, this is natural to MacOS, since LDCad is not an app bundle. If you e.g. develop a program with wxWidgets (a cross platform C++ Gui framework) you have the same result. After compiling and launching the program it will not have the focus. As soon as you create an app bundle, it will behave as a "normal" MacOS app. Also Cmd-Q does not work for closing the app. You need to close the window.

Interesting; so you'd say the way it worked under 4.0.3 was actually the "bug", and now it behaves "correctly"? (In which case I'll take the bug, but that's another matter!)

What happens if you open some other windows in the same space as LDCad? Say another app, or a Finder window? In 4.0.3, whichever window is at the front when I switch spaces will be at the front when I switch back. I'm curious whether the LDCad window is actually being moved to the back, or just acting like it?

Incidentally, the LDCad window is actually a program window in "wine64-preloader", which is an executable but not an app bundle (app bundles always have an executable file somewhere inside them). So, I also wonder if any program running in a preloader window would have the same behavior? On my system, they do behave the same way, except for LDDP, which is always sent to the back for some reason. But I really don't know enough about window management to understand why.
« Next Oldest | Next Newest »

Messages In This Thread
RE: LDCad on Wine (for Mac)-revisited - by N. W. Perry - 2021-04-15, 20:05

Forum Jump:

Users browsing this thread: 1 Guest(s)