[LDPE] 1.8.67 Released (scientific num. / bugfix: manipulator pos/ library.ldraw.org)

[LDPE] 1.8.67 Released (scientific num. / bugfix: manipulator pos/ library.ldraw.org)

this release adds hints when using the scientific number format.
It corrects a 3D manipulator bug and five other issues.
The download of data from library.ldraw.org works now!

[Image: imgDuke2.png]

As always, you can download LDPE from this page:



(1 new feature and 6 bug fixes)

With this release you will be able to...
  • ...see a hint on numbers with scientific notation (you can also "quick fix" these numbers).

The following critical issues were fixed:

  1. The 3D manipulator orientation got polluted.
  2. LDPE was not able to download from library.ldraw.org
  3. The tabs in the 3D editor couldn't be moved around. The text editor was not affected.
  4. SymSplitter cutted with data from subfiles too, in addition to the cutting plane (see images on https://github.com/nilsschmidt1337/ldpar...issues/959 )
  5. Intersector calculated sometimes wrong results with some triangles missing.
  6. It was not possible to do a "copy + transform" action on MacOS X with the cursor keys (see https://github.com/nilsschmidt1337/ldpar...issues/958 ).

The program was tested intensively with "real world" files.
However, something can go wrong in about 140.000 lines of code.

Installation on Windows:

  1. Download and extract LDPartEditor_win32_x64.zip
  2. Run LDPartEditor-1.8.67.msi
  3. Start LDPartEditor from the start menu
Installation on Linux:

  1. Download and extract LDPartEditor_linux_x64.zip
  2. Install ldparteditor_1.8.67-1_amd64.deb
  3. Start LDPartEditor from the menu or via launcher
Installation on Mac OS X:

  1. Download and extract LDPartEditor_mac_x64.zip
  2. Mount LDPartEditor-1.8.67.dmg
  3. Drag LDPartEditor.app to the Applications folder
  4. Copy ldparteditor.sh to your home folder
        4a. Open a Terminal.app and run ./ldparteditor.sh
        4b. Or open a Terminal.app and run /Applications/LDPartEditor.app/Contents/MacOS/LDPartEditor

I listen carefully to your requests and possible complaints. Please leave me a message, with your thoughts and wishes to further improve the software.

LDPE is a 3D CAD application: The overall system requirements are higher. While I recommend to use a powerful 64-bit multicore system, it could be possible, to run LDPE on older machines as well.

System Requirements:

Minimum System Requirements:
  • OpenGL 2.1 compatible Graphics Card
  • Operating System (64-bit): Windows [7 or newer], Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • CPU: Multicore-Processor e.g. Intel Core 2 Duo or AMD Athlon II (>2.0Ghz)
  • RAM: 4GB
  • Video-Memory: 1 GB
  • Free Disk Space: 100 MB
Recommended Requirements:
  • Operating System (64bit): Windows 7,8,10, Linux [e.g. Ubuntu Linux >=14.4], Mac OS X [>=10.6]
  • OpenGL 3.3 compatible Graphics Card
  • CPU: Multicore-Processor with 4 cores (or more)
  • RAM: >4 GB
  • Video-Memory: >1 GB
  • Free Disk Space: 512 MB
  • For a faster start, LDPartEditor and the LDraw™ library should be installed on an SSD.
RE: [LDPE] 1.8.67 Released (scientific num. / bugfix: manipulator pos/ library.ldraw.org)
Part review from the menu works again! Thansk!
RE: [LDPE] 1.8.67 Released (scientific num. / bugfix: manipulator pos/ library.ldraw.org)
This code, from https://library.ldraw.org/tracker/31251,  gives a rather confusing error message.


The "error" here is that I don't (yet) have r04i1000.dat in the right folder
RE: [LDPE] 1.8.67 Released (scientific num. / bugfix: manipulator pos/ library.ldraw.org)
I sometimes still get this error. Think it was fixed earlier.

« Next Oldest | Next Newest »

Forum Jump:

Users browsing this thread: 2 Guest(s)