Scrolling within ML CAD parts in Windows 7

Re: Scrolling within ML CAD parts in Windows 7
Michael Heidemann Wrote:It has nothing to do with Win7! I just checked here with WinXP and I could not get the same scrolling as you showed in the video!
I have checked MLCad version 3.2 and 3.3 and 3.4 all the same result.

So you need to have a very special mouse on your XP system.

I hate to disagree, but it does work with XP, and has on many different XP systems I have used over the years.

There are known problems with Windows 7 support for mouse-wheel scrolling. Whether anything can be done for MLCad depends how the scrolling is being handled -- actively by the application or simply "by default". With Windows Vista (and therefore also Windows 7) Microsoft introduced a new high-resolution support for scrolling. Unfortunately they didn't consider all the existing software that knows nothing about it. What happens is that the mouse is suddenly sending much smaller scroll intervals to the application, and many applications simply don't see it any more. This document by Microsoft describes what they did (but not how to fix it!)

There are several suggestions around the Internet that may help. One is disabling the new high-resolution support in the Registry:

Add the following 2 entries to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID\Vid_xxxx&Pid_yyyy\<instance_ID>\Device Parameters:

VScrollHighResolutionDisable = 1
HScrollHighResolutionDisable = 1

Other suggestions are: trying a new or a different mouse driver, or rewriting the offending application. (Sorry!)

Martin James
« Next Oldest | Next Newest »

Messages In This Thread
Re: Scrolling within ML CAD parts in Windows 7 - by Martin James - 2012-12-26, 11:48

Forum Jump:

Users browsing this thread: 1 Guest(s)