LDView 4.2 Beta 1 Released


Re: LDView 4.2 Beta 1 Released
#31
Hi Travis,

I have just spotted a little but annoying glitch while doing some more testing:

The preference set "Thumbnails" is not visible in the LDView application
until the first time a thumbnail generator was run.

This leads to an ugly behaviour a user (using LDView the first time and wanting to see thumbnails) has to do:

1. He first needs to let the thumbnail generator run on some folder,
creating images he does not want (as he wants to change the default configuration).

2. Then he needs to fire up LDView and change the preference set. While doing that, he needs to be aware which one to pick: is he using a 32bit Windows explorer, then he needs to run LDView.exe, is he using a 64bit Windows explorer, then he needs to run LDView64.exe

3. Inside the application, he needs to change the "Thumbnails" preference set.

4. Then he can go back to the folder where he wants to see the thumbnail renderings. He there needs to touch all files which from step 1. got an ugly image. This will trigger its thumbnail re-generation.

I suggest to heal this annoyance as follows:

(A) Make the "Thumbnails" preference set present by default always.

(B) Add a checkbox to it whether LDView shall render thumbnails in Windows explorer or not.
Currently, this can only be toggled at install time. I suggest copying the necessary DLLs always,
and letting this checkbox turn their usage on and off (i.e., setting/unsetting the necessary registry key(s)).

© Share the preference sets, especially "Thumbnails" between the 64bit and 32bit instances LDView.exe and LDView64.exe.
TODO: I don't know if this is already the case. I suspect that my Win32-Explorer spawns a Win32-LDView.exe, and that one sees its own copy, whereas I when using the tool interactively, fire up LDView64.exe. These two should share their preference sets.

(D) Change the default settings of the "Thumbnails" preference set.
It currently creates a black background, which looks terrible and frightening in the otherwise "bright" Windows 7 explorer.
I have to always change that manually to "white".
Second: the default field of view setting is terrible, the thumbnails all have a fisheye effect.
My suggestions for (IMHO) better defaults of the "Thumbnails" preference set are:
- background color RGB 245/245/245
- default color RGB 225/225/225
- field of view = 10
Reply
« Next Oldest | Next Newest »



Messages In This Thread
LDView 4.2 Beta 1 Released - by Travis Cobbs - 2012-04-08, 20:59
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-10, 18:48
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-10, 22:07
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 12:23
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 14:24
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 17:05
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 20:40
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 22:10
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-15, 1:59
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-15, 10:08
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-25, 12:22
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 22:14
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 21:03
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-14, 22:34
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-15, 1:59
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-21, 12:28
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-21, 22:25
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-23, 15:38
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-23, 21:58
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-29, 23:09
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-05-01, 11:53
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-30, 17:18
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-23, 22:30
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-23, 23:12
errors in 8464.mpd - by Steffen - 2012-04-25, 7:44
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-25, 12:53
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-25, 12:57
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-25, 13:49
Re: LDView 4.2 Beta 1 Released - by Steffen - 2012-04-26, 21:48
Re: LDView 4.2 Beta 1 Released - by MoonMan - 2012-05-07, 13:42
Re: LDView 4.2 Beta 1 Released - by MoonMan - 2012-05-08, 2:32
Re: LDView 4.2 Beta 1 Released - by MoonMan - 2012-05-11, 0:31
Re: LDView 4.2 Beta 1 Released - by Steffen - 2013-12-30, 12:59
Part loading problem - by Christoph Mierowski - 2013-12-29, 22:55
Re: Part loading problem - by Travis Cobbs - 2013-12-30, 5:40
Re: Part loading problem - by Magnus Forsberg - 2013-12-30, 21:59
Re: Part loading problem - by Steffen - 2013-12-31, 5:24
Re: Part loading problem - by Tim Gould - 2014-01-03, 7:27

Forum Jump:


Users browsing this thread: 1 Guest(s)