LDView for Linux (4.2 beta) doesn't accept -ca and -cg


LDView for Linux (4.2 beta) doesn't accept -ca and -cg
#1
Hi,

I compiled LPub4 in Linux which runs fine. I render with LDView.
I used three version of LDView: a 4.2 under wine, a Linux-native 4.2 installed from the debs on sourceforge and a self-compiled Linux-native 4.2

Problems:
- with Wine-Version and Linux-natives I get different results by using the same args
- the problem seems to be the -ca and -ca arguments. Without it, both LDViews gave the same view on screen
- other arguments probably are not affected (but I didn't tested it a lot)
- the Linux-version-problem does happen both in the installed Ubuntu-deb and in a self-compiled binary

Question: are the -ca and -ca arguments in the Linux-versions inactive or is the syntax somehow different?

(there is a problem with the alpha-channel in the Wine-Version as well which prevents me from using the wine-LDView as renderer for LDPub, but this is another topic Smile

Im running it under Linux Mint Maya (pretty much a Ubuntu 12.04)

thanks for a reply and best regards, Ingolf
Reply
Re: LDView for Linux (4.2 beta) doesn't accept -ca and -cg
#2
Thanks for the bug report. I wasn't aware of that problem, but looking at the code, I see it. The Windows and Mac versions use cross-platform code to process the command line and generate snapshots when directed to do so. Unfortunately, the Qt (Linux) version has its own platform-specific code for doing this. I don't know right now if this is due to it not yet being updated to use the cross-platform code, or if it is because the cross-platform code doesn't work on the Linux version. (Note that someone else maintains the Linux version with my help, so I'm not an expert on it.)

I'll talk to the Linux LDView maintainer to see if he can update it to use the cross-platform command line snapshot code. If not, I'll give him the info needed to implement support for -ca and -cg. (Note: I believe that -SaveSnapshots=1 command line option also doesn't work in the Qt version.)

In the short term, I believe that you should be able to use the OSMesa command-line-only version of LDView. Either grab a built version of that, or build it yourself. Note that this version's executable is "ldview" (all lower case). It uses the cross-platform command line snapshot code, so it should properly support -ca and -cg, and it should have a working alpha channel. It should work with LPub.
Reply
Re: LDView for Linux (4.2 beta) doesn't accept -ca and -cg
#3
Wow, that was very quick, thanks for the answer.

I will give it a try to install the Fedora-OSMesa, but it will take some days time since I don't have any experience with installing rpms and I don't have the time to do it immediatly. But I promise you to give you a reply.
But of course I would prefer having a patch-file for the source Wink

btw and a little bit OT: There is another issue (urgency: low). When opening the very same .ldr or .mpd-files there was a little different behaviour in the deb-LDView and the self compiled: a message "Failed to load translation" popped up in the deb-Version but not in the compiled version.

If you need any additional information (command line args, the model-files, whatever), please ask for it.

thanks a lot (for the reply and for this fine piece of software) and have a good weekend, Ingolf
Reply
Re: LDView for Linux (4.2 beta) doesn't accept -ca and -cg
#4
Hi again,

so I gave it a try, but Sad

Alien is building a fine deb from the osmesa-rpm which installs good, but it is not running. So unfortuneatly I couldn't test it. So I wait for your solution.

bye, Ingolf
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)