LDraw All-In-One-Installer 2013-02 now available


LDraw All-In-One-Installer 2013-02 now available
#1
The LDraw All-In-One-Installer 2013-01, in short AIOI, has been released.

The AIOI supports Windows XP (Home and Pro), Windows Vista (all versions) and Windows 7 (all versions). On 64-Bit Operating Systems it will install in the "Program files (x86)" folder. The Installer will NOT run on Windows 95, 98, ME, NT Ver 4, 2000, or XP below SP2.

Changes:
  • Removed Alias Parts Library
  • Updated LDFind
  • Updated LeoCAD
  • Kept Pov-Ray 3.6 though 3.7 has been officially released. There is currently an issue with the license of the Editor.dll, which therefore is not part of the redistribution package. Will switch to 3.7 as soon as this has been solved.

There are currently some issues with the registration of a file needed by Sticker Generator when installing on Windows 8.

You can download the AIOI from:

Home > Help > Get Started > LDraw All-In-One-Installer

Many thanks to all the programers who contributed to this release.

Willy Tschager
(LDraw.org Content Manager)
LEGO ergo sum
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#2
I thought it was time I checked out the latest AIOI to see if anything has radically changed. (I support a load of users who do weird and wonderful things with LDraw. When new users come on board I like to think I'm giving them valid advice and assistance.) I've hit a problem with the LGEO component.

Would I be right in thinking that the version of LGEO included in the AIOI is the one Owen Burgoyne has been updating and publishing at Eurobricks? The thing is, I can't get it to work with POV-Ray 3.6 (the version still officially recommended). It throws syntax errors in lg_color.inc. However it does work fine with POV-Ray 3.7. I think it's objecting to syntax like:

srgb <33,33,33>/255

rather than

srgb <33/255, 33/255, 33/255>

Adding to the confusion, the LGEO link on the AIOI download page takes you to Lutz Uhlmann's 2008 version, which does work with POV-Ray 3.6.

...or have I simply managed to do something silly?

--
Martin James
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#3
Where do you see that 3.6 is "officially" recommended? I can't find any such recommendation on the POV-Ray site now that 3.7 has been released after something like 8 years of beta.
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#4
I think he means the AIOI still uses 3.6, as described in this thread's top message.

A side note

Maybe the AIOI could als put some links in the start menu to additional software (including my LDCad Smile )
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#9
Roland Melkert Wrote:Maybe the AIOI could als put some links in the start menu to additional software (including my LDCad Smile )

I'd rather ship your entire prog if only you would let me.

w.
LEGO ergo sum
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#10
I was under the impression that my 'free for non commercial use' license wasn't compatible with the AIOI. Also when you asked to include my other software (LD4DStudio) I didn't feel comfortable signing the weaver for some reason. I don't know exactly why anymore since the link for it is dead:

http://www.ldraw.org/Article484.html
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#12
Roland Melkert Wrote:I was under the impression that my 'free for non commercial use' license wasn't compatible with the AIOI.

This is the first time I hear about such concerns.

w.
LEGO ergo sum
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#11
Roland Melkert Wrote:I think he means the AIOI still uses 3.6, as described in this thread's top message.

Indeed. It says "Kept Pov-Ray 3.6 though 3.7 has been officially released. There is currently an issue with the license of the Editor.dll, which therefore is not part of the redistribution package. Will switch to 3.7 as soon as this has been solved."

My concern is with a new user arriving at the LDraw site, and installing the package. There is no warning or guidance about the software levels. But if they install the LGEO and POV-Ray components from the AIOI they will get a combination that doesn't work.

Options:
  • Put the old version of LGEO in the package, as resolved by following the link in the list
  • Keep the new version of LGEO, but patch it so that it works with both versions of POV-Ray. (Change all the "srgb"s to "rgb"s, and set the default gamma to 2.2. At least it will produce the same output using wither POV-Ray 3.6 or 3.7.)
  • Resolve the licensing issue with POV-Ray 3.7, and put that in the package. (By far the best option from a user perspective - 3.7 is much better, and faster, than 3.6.)

--
Martin James
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#6
Martin James Wrote:I thought it was time I checked out the latest AIOI to see if anything has radically changed. (I support a load of users who do weird and wonderful things with LDraw. When new users come on board I like to think I'm giving them valid advice and assistance.) I've hit a problem with the LGEO component.

Would I be right in thinking that the version of LGEO included in the AIOI is the one Owen Burgoyne has been updating and publishing at Eurobricks? The thing is, I can't get it to work with POV-Ray 3.6 (the version still officially recommended). It throws syntax errors in lg_color.inc. However it does work fine with POV-Ray 3.7. I think it's objecting to syntax like:

srgb <33,33,33>/255

rather than

srgb <33/255, 33/255, 33/255>

Adding to the confusion, the LGEO link on the AIOI download page takes you to Lutz Uhlmann's 2008 version, which does work with POV-Ray 3.6.

...or have I simply managed to do something silly?

--
Martin James

As far as I know, Owen's LGEO library is optimized for POV-Ray 3.7, which has better support for srgb. If you remove the s from srgb, it may work, but I'm not sure about that. You could better ask Owen (aka C3POwen) in this EuroBricks topic. I believe I saw the same issue a few more times in that topic.
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#7
Then the good news is it wasn't me :-)

But that does raise an issue with the latest AIOI. Anybody installing it is going to come unstuck, since it bundles that new version of LGEO with POV-Ray 3.6. Maybe it should treat LGEO the same way as POV-Ray -- include the matching older versions in the bundle, and give links to the new ones as an alternative pairing. (Or just go gor the new versions.)

--
Martin James
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#5
Willy Tschager Wrote:There is currently an issue with the license of the Editor.dll, which therefore is not part of the redistribution package. Will switch to 3.7 as soon as this has been solved.

If you're waiting on POV-Ray to resolve this issue, my impression is that it will be a very long wait. They have an editor-only installer available, though, released under the same license as POV-Ray 3.6. See here:

http://www.povray.org/download/wineditdll/
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#8
I'll read through all the license stuff to see how and if it could all be shipped together.

w.
LEGO ergo sum
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#13
I need to know where the 3.7 installer puts the povrayay.ini and pvengine.ini files on a XP machine. I know, I know I could browse the POV FAQ, but I have other things to do right now.

w.
LEGO ergo sum
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#14
Willy Tschager Wrote:I need to know where the 3.7 installer puts the povrayay.ini and pvengine.ini files on a XP machine.

Under "My Documents", in C:\Documents and Settings\[user]\My Documents\POV-Ray\v3.7\ini

--
Martin James
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#15
Hi,

a beta where POVRay 3.6 has been substituted with 3.7 can be found here:

http://www.holly-wood.it/tmp/LDraw_AIOI_...bit_v2.zip

I would appreciate if you could do some testing before I replace the Version 1.

w.
LEGO ergo sum
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#16
Willy Tschager Wrote:a beta where POVRay 3.6 has been substituted with 3.7 can be found here...
...I would appreciate if you could do some testing before I replace the Version 1.

Tested on 32-bit Windows XP with default settings, and on 64-bit Windows 7 with all paths changed. Works fine on both. All the software packages appear to match and work with each other.

Just one tiny "oddity" with the installation of POV-Ray 3.7. After the program has been installed, a message pops up:

--------------------------------

Completing the POV-Ray for Windows Setup Wizard

POV-Ray for Windows has been installed on your computer.
As the installer does not include the editor DLL's, unless you
clear the Download Editor DLL's checkbox, clicking Finish will
launch your browser to download them.

--------------------------------

Unchecking the box, to see what happens (i.e. don't download the DLLs) then gives:

--------------------------------

POV-Ray for Windows Editor DLL's

The installer will add the editor DLL's to your installation of
POV-Ray for Windows v3.7.

Press Next to continue.

--------------------------------

It proceeds to install all the DLLs anyway, even though it never tries to connect to anything first. It looks like the question about downloading them is redundant, and they are in the package already. But I don't know if you have any control over this sequence, or if it is internal to POV-Ray.

--

Martin James
Reply
Re: LDraw All-In-One-Installer 2013-02 now available
#17
Hi,

the POV-Ray for Windows Setup Wizard AND POV-Ray for Windows Editor DLL's are part of the AIOI and will be installed. Problem is I don't have any control about the checkboxes of the wizard. If I had I would remove them.

w.
LEGO ergo sum
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 1 Guest(s)
Forum Jump:


Users browsing this thread: 1 Guest(s)