New Forums Public Preview


New Forums Public Preview
#1
The new forums are up for previewing at:
http://beta.ldraw.org/mybb/

The intent of the preview period is to find things that didn't convert well. This is not a live copy of the current forums but a static snapshot from a few hours ago. Anything you post will be wiped out when the actual conversion happens.

Please post bug reports as replies to this thread.
Reply
Re: New Forums Public Preview
#2
Thanks for fixing the encoding bug!
Reply
Re: New Forums Public Preview
#3
made some test and browsing, seems to work fine!
...and so I have the rank of "Posting Freak" ?!? Oh well... Wink
Reply
Re: New Forums Public Preview
#4
Philippe Hurbain Wrote:...and so I have the rank of "Posting Freak" ?!? Oh well... Wink

And Reputation: 0 :-D

w.
LEGO ergo sum
Reply
Re: New Forums Public Preview
#5
The admin part is overwhelming! I was looking for how to add a link to LDraw.org home but found myself totally lost.

w.
LEGO ergo sum
Reply
Re: New Forums Public Preview
#6
Yah the template section is really granular and intimidating at first. Thankfully if you look at the source in your browser, the comments usually point you to the right template.
I actually had the double logo and a bunch of other things added and then I stupidly wiped them away when I transferred the database to the live server. Won't happen next time.
Reply
Re: New Forums Public Preview
#7
Is it intentional that users have the "Receive private messages from other users." option turned off by default?
Reply
Re: New Forums Public Preview
#8
Nope. That's an artifact of the conversion. I can fix that next time I run the conversion.

Plus you let the cat out of the bag. We will be allowing PMs for users who meet certain criteria (>10 posts and >3 days registered)
Reply
Re: New Forums Public Preview
#10
Orion Pobursky Wrote:Nope. That's an artifact of the conversion. I can fix that next time I run the conversion.

Plus you let the cat out of the bag. We will be allowing PMs for users who meet certain criteria (>10 posts and >3 days registered)
This is what I call The Improvement, many thanks for this!

However, this is another extreme: there are two independent systems and it is not even clear for users there are two of them: somewhere, you find a button "send an e-mail" and elsewhere "send PM". I do not understand the reason for these parallel systems. What about turning the e-mail function off and let users to set e-mail notifications if/when they want to? Everything private will be a PM then.

EDIT: Both can be achieved in your profile options: disable e-mail address and set PM notifications. I believe it makes sense to make this the default.

The e-mail notification footer says that only a notification about one PM is sent and then all others are discarded until you check forum via www interface. I do not find this convenient and I did not find the option to change this behavior to "send me all notifications". Is that possible?

And from the other end: the e-mail notification header has no e-mail address in "From" field. Only the forum name. It looks like it is simply not filled in the main admin configuration. Orion, may you check this, please?
Reply
Re: New Forums Public Preview
#11
Milan Vančura Wrote:This is what I call The Improvement, many thanks for this!

I realized that I was being a bit stubborn about this so I changed my mind in favor of inclusion. That said, we will make it clear that PMs are not private in the strictest sense of the word and will be monitored from time to time by the admins. Additionally I will not fail to disable PMs for a given user at the slightest hint of abuse or inappropriateness.

Milan Vančura Wrote:However, this is another extreme: there are two independent systems and it is not even clear for users there are two of them: somewhere, you find a button "send an e-mail" and elsewhere "send PM". I do not understand the reason for these parallel systems. What about turning the e-mail function off and let users to set e-mail notifications if/when they want to? Everything private will be a PM then.

EDIT: Both can be achieved in your profile options: disable e-mail address and set PM notifications. I believe it makes sense to make this the default.

This can be fixed on the backend with database edits.

Milan Vančura Wrote:The e-mail notification footer says that only a notification about one PM is sent and then all others are discarded until you check forum via www interface. I do not find this convenient and I did not find the option to change this behavior to "send me all notifications". Is that possible?

And from the other end: the e-mail notification header has no e-mail address in "From" field. Only the forum name. It looks like it is simply not filled in the main admin configuration. Orion, may you check this, please?

I'll look into both of these.
Reply
Re: New Forums Public Preview
#9
I like the new forum a lot! Here are things that I observed:

- I find the top left button "User CP" confusing. I did not know what "CP" could mean (for the curious: "control panel"). I suggest to simply retitle that button to just: "You" or to "My Account" or "My Menu"

- Inserting an image into a post works with URLs starting with http://, but not with data:. The editor displays the image, but after saving the post, the image is displayed as source code - see my example post

- I find the button "insert PHP source code" in the post editor not needed for LDRAW work, and suggest removal (if that's not possbile by an option, then maybe adjusting our custom CSS does the job)

Good job! The forum looks all wonderful and shiny
Reply
Re: New Forums Public Preview
#12
Steffen Wrote:I like the new forum a lot! Here are things that I observed:

- I find the top left button "User CP" confusing. I did not know what "CP" could mean (for the curious: "control panel"). I suggest to simply retitle that button to just: "You" or to "My Account" or "My Menu"

Anyone else have any feedback in this regard?

Steffen Wrote:- Inserting an image into a post works with URLs starting with http://, but not with data:. The editor displays the image, but after saving the post, the image is displayed as source code - see my example post

This is a user settings issue I can fix on the back end. Go to User CP->Edit Option (on the left sidebar). Under Thread settings you can tick show images in posts. Like I said, I'll fix this for all users on the back end.

Steffen Wrote:- I find the button "insert PHP source code" in the post editor not needed for LDRAW work, and suggest removal (if that's not possbile by an option, then maybe adjusting our custom CSS does the job)

I'll look into this. I may see if I can change it for LDraw syntax highlighting.
Reply
Re: New Forums Public Preview
#14
Orion Pobursky Wrote:
Steffen Wrote:I like the new forum a lot! Here are things that I observed:

- I find the top left button "User CP" confusing. I did not know what "CP" could mean (for the curious: "control panel"). I suggest to simply retitle that button to just: "You" or to "My Account" or "My Menu"

Anyone else have any feedback in this regard?
Sure, I absolutely agree with Steffen. This is a great example of "magic abbreviation" good for nothing but be magic. "My Account" or "My Menu" is much better.
Reply
Re: New Forums Public Preview
#15
All the default user setting problems have now been fixed and the conversion script updated so the changes stick.
Reply
Re: New Forums Public Preview
#16
One funny bug: the link "Please report any bugs you find" does not work Smile

Another bug: clicking on "View new posts" does not show anything. Even when there are/were new messages I could see in "Today post". (There were some test comments from Steffen and Philippe.) This probably needs more testing but I have one account only so I cannot test it (I cannot write a comment as Milan1 and let Milan2 test if he sees that among new ones.)
Reply
Re: New Forums Public Preview
#17
The broken link is intentional. I don't want people reporting bugs on the beta forum.

I think the new posts link will work once the switch happens. I can't really tell if it's broken until more people are posting on a regular basis.
Reply
Re: New Forums Public Preview
#22
Is it also intentional that links to other treads in the forum, don't work in the beta forum?
Reply
Re: New Forums Public Preview
#23
They will work after the shift.
Reply
Re: New Forums Public Preview
#13
The conversion will happen on Friday, 6-8pm Hawaii time. The total process should take under an hour and both forums will be down for that time.
Reply
default date format
#18
Hey, I just noticed that the default date format (displayed when not logged in) is something like MM-DD-YYYY,
which is completely confusing (seems to be a US american date order, but with - instead of / ).

I suggest to change the default to the internationally understood
YYYY-MM-DD
(international ISO date format https://en.wikipedia.org/wiki/ISO_8601#Calendar_dates )
Reply
Re: default date format
#19
Easy one. Done!
Reply
Re: New Forums Public Preview
#20
Seems very nice, had to get used to the brightness though Smile

Also great work on keeping the site contained in its own domain (no gravatar/google tie in etc).
Reply
Re: New Forums Public Preview
#21
Roland Melkert Wrote:Seems very nice, had to get used to the brightness though Smile
I want to emphasize I also like the new forum. It's much easier to see/find everything there on new pages. Very easy to read, very fast to operate there.

I just took the job of finding bugs so it might look I do not like that - that's far from truth, I just tried to do the job best I can Wink
Reply
Re: New Forums Public Preview
#25
Due to the lack of show stoppers, I'm going to go ahead to do the switch early. Object now or I go at 2:00 GMT (16:00 Hawaii time)
Reply
Re: New Forums Public Preview
#24
There's is stuff for gravatar etc but I like self contained. The only offsite thing we use is reCaptcha for new user registrations
Reply
RE: New Forums Public Preview
#26
I don't have access anymore the the website administration subforum. I don't know if that was intentional or not, just a small heads-up.
Reply
RE: New Forums Public Preview
#27
(2016-04-01, 6:47)Merlijn Wissink Wrote: I don't have access anymore the the website administration subforum. I don't know if that was intentional or not, just a small heads-up.

This is now fixed
Reply
« Next Oldest | Next Newest »



Forum Jump:


Users browsing this thread: 4 Guest(s)