LDraw.org Discussion Forums
DATHeader - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: Parts Author Tools (https://forums.ldraw.org/forum-24.html)
+--- Thread: DATHeader (/thread-66.html)

Pages: 1 2

DATHeader - Michael Heidemann - 2011-07-24

I just release version of DATHeader. Please leave all comments for this version as response to this topic.
Have fun.
Download from http://mikeheide2.kilu.de

Re: DATHeader - Michael Heidemann - 2011-11-12

Sort order for History entries should change, so that brackets {} will be sorted in front of [] brackets.

Re: DATHeader - Chris Dee - 2011-11-13

!HISTORY sequence should be strictly by date. In the entries prior to the 2008-01 release it's quite possible for a {} quoted RealName to come after a [] quoted UserName. See official 2345p44.dat for a valid example of this.


Re: DATHeader - Daniel Goerner - 2012-03-31

I don't know what happened, but I can't open DATHeader anymore.

I reinstalled all things LDRaw to a new directory (on the very same HDD), also DATHeader. And now, when I try to open DATHeader it says "write protected folder: The folder for the lists can not be written to. Can not use it. I use instead: C:\....\Documents." After I click OK the program crashes. I use Windows 7 64bit, it worked before, now it doesn't work anymore. I tried to change authorisations, ownership of the folder and whatnot.

Different program versions, different hdds, everywhere the same thing...

[EDIT] I reinstalled Java, now the program doesn't crash anymore, but the error message comes as soon as I click any button. The program knows all the old directories, also my username etc. Maybe there's a registry entry I have to delete, so the program starts fresh. But where in the registry is this program stored?

Re: DATHeader - Daniel Goerner - 2012-04-01

Now I installed a one month old backup of my system, before I installed DATHeader. Now it works. I think it's a registry thing.

Re: DATHeader - Michael Heidemann - 2012-04-01

Datheader does not use the registry. Instead in your documents folder there is a file called datheaderini.xml. In that file all pathes are stored and also your preferences and your name. Just delete that file and fill in the necessary pathes again in DATheader.
I am sorry for the inconviences DATHeader caused to you.

Re: DATHeader - Daniel Goerner - 2012-04-01

Let me say that in German: "Na toll!"

I take that with humor. It was frustrating, yes, but now it works, and for the future I know what causes the problems. So, nevermind.

Re: DATHeader - Michael Heidemann - 2012-04-01

In case you think about reinstalling your system in the future, just because of one of my apps, please send me an email.
I do not look into this forum every day, but I check my emails every day (normally Wink ). So you will get very soon a reply from me.
But I hope you will continue using my apps and enjoy the benefit they give to you.

If you have any idea for improving - please do not hesitate to contact me!

Re: DATHeader - Daniel Goerner - 2012-04-01

Thanks Michael.

Here's another problem (?) with DATHeader. I don't know what it means, but I get an error message most of the time DATHeader checks the body:
"Error in LDraw_IsErrorLines in modLdraw at check no. 8
Der Index war au├čerhalb des Arraybereichs."

Re: DATHeader - Michael Heidemann - 2012-05-06

Sorry for my late reply.

Please send the file where this error occure to my email address. So I can check here what is going wrong.

Thanks for your patience.