LDraw.org Discussion Forums
LEOCAD - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: LDraw Editors and Viewers (https://forums.ldraw.org/forum-11.html)
+--- Thread: LEOCAD (/thread-5261.html)

LEOCAD - Andrea Mifsud - 2012-06-24

I Have a problem regarding LEOCAD.

I'm designing my robot in MLCAD and when I try to open it in LEOCAD some parts are missing.
I tried to update the pieces list of LEOCAD but with no success.

Any suggestions please?
Thanks in Advance,

Re: LEOCAD - Philippe Hurbain - 2012-06-25

One problem with LeoCAD is that it doesn't use directly LDraw library. It must import LDraw parts to convert them to its own format. AFAIK LeoCAD official library is up to date, so you need to import only unofficial parts you use. To do that, File -> Pieces Library manager -> import pieces. There, select all parts you want to import in your LDraw folder. When it's done (it may take a while), close LeoCAD and reopen it. The new parts should be there...

Re: LEOCAD - Andrea Mifsud - 2012-06-25

I tried to import pieces but every time I try, no matter what the piece is, but I get an error at the end of the import: Failed to open file for writing.

The thing is that I have the parts already in LeoCad, but when I import a file made by MLCAD, these parts are not present in the design in LEOCAD. These being, Lego NXT, Motor, Light Sensor, Touch Sensor and UltraSonic Sensor, among several others.

Thanks in Advance and regards,

Re: LEOCAD - Philippe Hurbain - 2012-06-25

Weird... Can you share your MLCad file?

Re: LEOCAD - Andrea Mifsud - 2012-06-25

Yep it is ...


Re: LEOCAD - Philippe Hurbain - 2012-06-25

Clear now Wink
...well, almost! Your motors are named 53787_2.dat instead of 53787.dat. Same extraneous _2 for NXT, US sensor, Technic Pin Connector Perpendicular 3 x 3 Bent 90 with 4 Pins... This explains why LeoCAD didn't found these parts (but not where does these _2 come from???). You have also unknown (at least by me!) 21249200a, b and c...

Re: LEOCAD - Andrea Mifsud - 2012-06-25

Owww Great ... Thx Smile
You're awesome ^_^
I know why :")

Thanks Again!!

Re: LEOCAD - Leonardo Zide - 2012-07-05

You didn't mention what OS you're using so I'm going to assume Windows but it's basically the same problem under Linux.

The error you're getting means you don't have permissions to write to the folder where you installed LeoCAD (the default is c:\Program Files\LeoCAD), this happens if you have UAC enabled in Windows 7 or Vista.

You can either run as administrator or move the installation folder somewhere else (your desktop for example), run from there, import the parts you want and then move the folder back.

Re: LEOCAD - Philippe Hurbain - 2012-07-05

Welcome here, Leonardo!