LDraw.org Discussion Forums
LDView 4.2 Beta 1 Released - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: LDraw Editors and Viewers (https://forums.ldraw.org/forum-11.html)
+--- Thread: LDView 4.2 Beta 1 Released (/thread-4278.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12


Re: Part loading problem - Christoph Mierowski - 2014-01-03

I reported this error to Sergio at the SR 3D builder forum and got this answer.
So, who has now to chance what??
Ldraw library or the application using it?


Re: Part loading problem - Tim Gould - 2014-01-03

As far as I know Sergio is correct that the shortcut part should not reference primitives. It should only reference components.

But... good programming does not expect perfect inputs. He should really fix that bug.

Tim


Re: Part loading problem - Michael Heidemann - 2014-01-03

Code:
As far as I know Sergio is correct that the shortcut part should not reference primitives. It should only reference components.

But... good programming does not expect perfect inputs. He should really fix that bug.

Tim

A quick look at the PT shows that:
1) this is currently an unofficial part, so there might be errors Smile
2) there is no direct reference to a primitive
3) the subparts should be changed to be parts
4) Tim is quite right with the last statement Smile 1+


Re: Part loading problem - Christoph Mierowski - 2014-01-03

Quote:2) there is no direct reference to a primitive

Really? I looked again at x581c01.dat and found 4-4cyli.dat, 4-4cylo.dat as reference in it. I think these are primitive.
I'm no part author so maybe I got something wrong. These primitivs are beneath a BFC statement, but chance that anything?


Re: Part loading problem - Michael Heidemann - 2014-01-03

Grr....
You are completely right and I am stupid Sad

As those files are from me, i think I need to update them quickly Smile