LDraw.org Discussion Forums
Parts in LDCad - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: LDraw Editors and Viewers (https://forums.ldraw.org/forum-11.html)
+--- Thread: Parts in LDCad (/thread-24177.html)

Pages: 1 2 3 4 5 6 7


RE: Parts in LDCad - Roland Melkert - 2020-09-15

(2020-09-15, 21:10)N. W. Perry Wrote: There's a thread about it here in the forum:
https://forums.ldraw.org/thread-23697.html

That thread is about the prototype version of the solver, the one in 1.6d is more user friendly Smile


RE: Parts in LDCad - N. W. Perry - 2020-09-15

(2020-09-15, 21:17)Roland Melkert Wrote: That thread is about the prototype version of the solver, the one in 1.6d is more user friendly Smile

Yes, and I remember there being some more explicit instructions in a readme or a changelog somewhere, but I couldn't remember exactly where.


RE: Parts in LDCad - Sparky678911 - 2020-09-25

Hi everyone ok so i had to rebuild computer a lost a hard drive i am all sorted nor but for some reason iot is not getting the Unofficial parts up does any one have any ideas thanks


RE: Parts in LDCad - Roland Melkert - 2020-09-26

(2020-09-25, 22:12)Sparky678911 Wrote: Hi everyone ok so i had to rebuild computer a lost a hard drive i am all sorted nor but for some reason iot is not getting the Unofficial parts up does any one have any ideas thanks

Did you download the offical and unoffical zips at the same time, because the offical one has just been updated meaning the old unofficial one will have duplicates.

Otherwise check the latest log file in %appdata%/LDCad/logs  for 'error' and 'warning' lines.


RE: Parts in LDCad - Sparky678911 - 2020-09-29

Hi thanks for the reply i have sorted it now do have a question on the left hand side of the screen where i have the colour and the parts for some reason or somehow i  moved them and now can not get the back where they were thanks


RE: Parts in LDCad - Roland Melkert - 2020-09-29

(2020-09-29, 20:33)Sparky678911 Wrote: Hi thanks for the reply i have sorted it now do have a question on the left hand side of the screen where i have the colour and the parts for some reason or somehow i  moved them and now can not get the back where they were thanks

You undocked them.

To fix it see
http://www.melkert.net/LDCad/faq#faq_dock


This seems to be a very common problem, maybe I should lock the gui by default in clean installations?


RE: Parts in LDCad - N. W. Perry - 2020-09-29

(2020-09-29, 20:42)Roland Melkert Wrote: You undocked them.

To fix it see
http://www.melkert.net/LDCad/faq#faq_dock


This seems to be a very common problem, maybe I should lock the gui by default in clean installations?

I definitely have undocked the panels by mistake on several occasions, and then had to remember how to re-dock them. It might be just a matter of requiring a modifier key to un-dock as well as to re-dock, or perhaps a specific widget or handle in the panels for docking/undocking.


RE: Parts in LDCad - Orion Pobursky - 2020-09-29

(2020-09-29, 20:42)Roland Melkert Wrote: You undocked them.

To fix it see
http://www.melkert.net/LDCad/faq#faq_dock


This seems to be a very common problem, maybe I should lock the gui by default in clean installations?

Yes please.


RE: Parts in LDCad - Sparky678911 - 2020-09-30

Thanks for help


RE: Parts in LDCad - Roland Melkert - 2020-10-01

(2020-09-29, 22:16)N. W. Perry Wrote: It might be just a matter of requiring a modifier key to un-dock as well as to re-dock, or perhaps a specific widget or handle in the panels for docking/undocking.

I think this is the best option, to require a downed ctrl key for both undocking and docking (depending on the current state).