LDraw.org Discussion Forums
3D Viewer work - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: Administrative (https://forums.ldraw.org/forum-4.html)
+--- Forum: Website Suggestions/Requests/Discussion (https://forums.ldraw.org/forum-23.html)
+--- Thread: 3D Viewer work (/thread-23755.html)

Pages: 1 2 3 4 5 6 7


3D Viewer work - Orion Pobursky - 2019-11-17

I'm gonna be refactoring the 3D view code used on the PT, Official Library pages, and OMR. You may notice some irregularities over the next week or so but don't worry it'll get fixed. Now is also the time for requests.


RE: 3D Viewer work - Magnus Forsberg - 2019-12-01

(2019-11-17, 19:52)Orion Pobursky Wrote: You may notice some irregularities

Is the extreme close-up when I use the "Add logo"-button a result of the ongoing re-coding?
btw, A logo is still not added when I use that button.

(2019-11-17, 19:52)Orion Pobursky Wrote: Now is also the time for requests.

Would it be possible to have the Reset/Return-button also reset the origin/orientation/zoom level?
As a user I want the Random and the BFC buttons to work like on/off-buttons, like the logo-button does.


RE: 3D Viewer work - Gerald Lasser - 2019-12-01

When reviewing 18909, I noticed that the 3D Viewer renders a stud logo for stud6, I think it should not.


RE: 3D Viewer work - Lasse Deleuran - 2019-12-01

(2019-12-01, 14:09)Magnus Forsberg Wrote: Is the extreme close-up when I use the "Add logo"-button a result of the ongoing re-coding?
btw, A logo is still not added when I use that button.
I am also looking into why this happens. It works for unofficial parts, but for some reason I can't figure out why the PT fails :S

I committed a bug fix to the source code recently... this could potentially fix the issue, but I am not at all convinced. There is something that we are missing here.


RE: 3D Viewer work - Orion Pobursky - 2019-12-01

(2019-12-01, 19:18)Lasse Deleuran Wrote: I am also looking into why this happens. It works for unofficial parts, but for some reason I can't figure out why the PT fails :S

I committed a bug fix to the source code recently... this could potentially fix the issue, but I am not at all convinced. There is something that we are missing here.

I ran into a snag with my refactored code (not related to your software) and haven't had time to troubleshoot.


RE: 3D Viewer work - Lasse Deleuran - 2019-12-06

(2019-12-01, 19:17)Gerald Lasser Wrote: When reviewing 18909, I noticed that the 3D Viewer renders a stud logo for stud6, I think it should not.
I just checked 18909 in dark blue from the Rexcelsior. The part has LEGO-logos in the bottom. However. The studs appear to be "stud2" rather than "stud6" as there are no flat section of the outer cylinder. Also. The studs should be oriented so the LEGO-logo has the bottom toward the flat cross section (where the other 18909 would be in a cone).


RE: 3D Viewer work - Magnus Forsberg - 2019-12-27

It looks like there's a webGL-viewer on some of the product pages at LEGO.

Ultrakatty and Emmet and Benny workshop

both have a "Explore in 3D" button in the corner.


.png   Image 1.png (Size: 111.45 KB / Downloads: 319)


RE: 3D Viewer work - Magnus Forsberg - 2020-01-11

The 3D viewer doesn't seem to work any longer. No image/model is generated.


RE: 3D Viewer work - Lasse Deleuran - 2020-01-11

(2020-01-11, 9:43)Magnus Forsberg Wrote: The 3D viewer doesn't seem to work any longer. No image/model is generated.
There was some work on it yesterday. Does it work for you when you refresh the page?

Right now it works for me, except BFC mode and the ability to turn on stud logos, see for example: https://www.ldraw.org/cgi-bin/ptdetail.cgi?f=parts/5306c01.dat


RE: 3D Viewer work - Magnus Forsberg - 2020-01-11

(2020-01-11, 9:54)Lasse Deleuran Wrote: Does it work for you when you refresh the page?

Right now it works for me, except BFC mode and the ability to turn on stud logos,

Yes, a refresh helped today. I see the same as you do. No BFC and no logo.
(win10 and firefox)