LDraw.org Discussion Forums
3D Part Preview added to Parts Tracker - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: General (https://forums.ldraw.org/forum-12.html)
+--- Forum: LDraw.org Announcements (https://forums.ldraw.org/forum-1.html)
+--- Thread: 3D Part Preview added to Parts Tracker (/thread-23540.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11


RE: 3D Part Preview added to Parts Tracker - Philippe Hurbain - 2019-10-25

(2019-07-11, 12:36)Orion Pobursky Wrote: To follow up on a couple of feature requests from the internal pre-launch thread:
- BFC Colors
- Random quad/tri colors

Both of these features are possible with Lasse's renderer and will be added at some point in the near future.
Another addition that would be useful (no idea of complexity involved!): possibility to display an origin/axis thingy to allow quick check of part origin and orientation...


RE: 3D Part Preview added to Parts Tracker - Lasse Deleuran - 2019-10-25

(2019-10-25, 12:18)Philippe Hurbain Wrote: Another addition that would be useful (no idea of complexity involved!): possibility to display an origin/axis thingy to allow quick check of part origin and orientation...

I do not know what will be the best place to have these requests, so I have added it to the issues list here: https://github.com/LasseD/buildinginstructions.js/issues/26

I have also found that the 'physical' viewer has found some issues with parts - particularly when lines of type 2 and 5 overlap, when vertices do not overlap properly, and such. 



RE: 3D Part Preview added to Parts Tracker - Magnus Forsberg - 2019-11-12

The "Toggle stud logos"- button doesn't work anymore. No logo is added when I click on it.
(Win 10 1903 + Firefox (updated), but I saw this prior to the latest Win update.)


RE: 3D Part Preview added to Parts Tracker - Philippe Hurbain - 2019-11-12

(2019-11-12, 16:11)Magnus Forsberg Wrote: The "Toggle stud logos"- button doesn't work anymore. No logo is added when I click on it.
(Win 10 1903 + Firefox (updated), but I saw this prior to the latest Win update.)
Confirmed with another OS/browser


RE: 3D Part Preview added to Parts Tracker - Orion Pobursky - 2019-11-12

(2019-11-12, 16:32)Philippe Hurbain Wrote: Confirmed with another OS/browser

Thanks for the report. The way studs are handled has changed so I'll have to retool my stud toggle code. This should be fixed by tomorrow.


RE: 3D Part Preview added to Parts Tracker - Lasse Deleuran - 2019-11-12

(2019-11-12, 17:10)Orion Pobursky Wrote: Thanks for the report. The way studs are handled has changed so I'll have to retool my stud toggle code. This should be fixed by tomorrow.
Sorry about that. I thought I had tested this back when the changes were made (see my post with all the stud types)

Please tell me if there are any issues with the change.


RE: 3D Part Preview added to Parts Tracker - Orion Pobursky - 2019-11-12

(2019-11-12, 19:30)Lasse Deleuran Wrote: Sorry about that. I thought I had tested this back when the changes were made (see my post with all the stud types)

Please tell me if there are any issues with the change.

I knew about the change but didn’t implement because I forgot. I had planned to centralize all the render code into one file but real life got in the way and I didn’t finish that either. I’ll have much more free time in the next few weeks to work on my website todo list


RE: 3D Part Preview added to Parts Tracker - Orion Pobursky - 2019-11-13

(2019-11-12, 20:08)Orion Pobursky Wrote: I knew about the change but didn’t implement because I forgot. I had planned to centralize all the render code into one file but real life got in the way and I didn’t finish that either. I’ll have much more free time in the next few weeks to work on my website todo list

Still working in this. The limited amount of tweaking I did yesterday didn't solve the problem.


RE: 3D Part Preview added to Parts Tracker - Lasse Deleuran - 2019-11-15

Hi Orion,

Which part of the code is it that is causing issues?

There are currently two ways of enabling and disabling logos:

LDR.Studs.makeGenerators() which can be called before the model is loaded to ensure that studs will be constructed correctly. I do not think this is the best option for setting the values here.

and

LDR.Studs.setStuds() which can be called to overwrite the part types for studs. After it has been called, the other parts that use studs will have to be rebuilt. To rebuild, the function removeAllMeshes() on meshCollectors can be used before calling draw() to rebuild.


RE: 3D Part Preview added to Parts Tracker - Orion Pobursky - 2019-11-15

(2019-11-15, 18:38)Lasse Deleuran Wrote: Hi Orion,

Which part of the code is it that is causing issues?

There are currently two ways of enabling and disabling logos:

LDR.Studs.makeGenerators() which can be called before the model is loaded to ensure that studs will be constructed correctly. I do not think this is the best option for setting the values here.

and

LDR.Studs.setStuds() which can be called to overwrite the part types for studs. After it has been called, the other parts that use studs will have to be rebuilt. To rebuild, the function removeAllMeshes() on meshCollectors can be used before calling draw() to rebuild.

I haven't gotten back to this yet. I'll have time this evening to work on a fix.