LDraw.org Discussion Forums
LPub3D 2.1 - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: LDraw File Processing and Conversion (https://forums.ldraw.org/forum-22.html)
+--- Thread: LPub3D 2.1 (/thread-22714.html)

Pages: 1 2


RE: LPub3D 2.1 - David Manley - 2018-02-20

(2018-02-20, 21:34)David Manley Wrote: <snip>
d)  Render set to POV-Ray (executable is the one bundles with LPud3D)
No assembly images shown
No images shown for parts in parts list
Refer to the third page in the same PDF for an an example.

Looking at stderr for thie POV-Ray renderer, this looks like it may be due to a hard-coded directory path in LPub3D? My install of LPub3D is in "D:\Program Files\Lpub3D" yet the stderr output indicates it is searching for "C:\Program Files (x86)\LPub3D\3rdParty\lpub3d_trace_cui-3.8\resources\config\povray.conf". Presumably it should actually be searching for "D:\Program Files\LPub3D\3rdParty\lpub3d_trace_cui-3.8\resources\config\povray.conf", which does exist.

David


RE: LPub3D 2.1 - Jaco van der Molen - 2018-02-20

(2018-02-20, 18:35)Merlijn Wissink Wrote:
(2018-02-19, 21:46)Jaco van der Molen Wrote: Did you install/download? See README.TXT ;-)
Ah of course, stupid me. I can just download the readme without updating LPub  Rolleyes

I did not install but downloaded the zipped version and extracted next to 2.0.20.


RE: LPub3D 2.1 - Jaco van der Molen - 2018-02-21

(2018-02-20, 21:34)David Manley Wrote: I've tried using LPub3D version 2.1. I uninstalled version 2.0.20 via the Windows Control Panel and then installed version 2.1. I am experiencing some bugs.

a) Very slow start up - spends a lot of time at "60% archiving search directory parts"
I suspect this is due to an "unusual" value in the LPub3D configuration. Using the menu option "Configuration/Preferences" and navigating to the "Other" tabbed sheet, the content of the multi-line edit beneath "LDraw Content Search Directories" looked wrong as it contained many, many duplicates of the same directory path. Clicking the "Reset" button and the "Yes" command button in the subsequent dialog window seems to have resolved this slow start-up issue for subsequent invocations.

b) Render set to LDView
Part (NXT motor) which should have been shown as a faded part subsequent to its initial step does not appear at all.
Refer to the first page in this PDF for an example.

c) Renderer set to LDGLite (executable is the one bundled with LPub3d)
Images extending beyond the page (yet the images are sized properly when LDView is the renderer)
Refer to the second page in the same PDF for an example.

d)  Render set to POV-Ray (executable is the one bundles with LPud3D)
No assembly images shown
No images shown for parts in parts list
Refer to the third page in the same PDF for an an example.

I see that Kevin has updated his original post, indicating Trevor is working on some fixes. Once they become available, I will retest issues (b) through (d) to see if they have been resolved.

Regards,

David

a) I do not recognize. Starts fine here.
b) Strange. Has to do something with fade stepping. Have you tried to turn it off?
c) LDGLite puts out larger images then LDView. You'll have to scale.
d) I have not got POV Ray to work either.


RE: LPub3D 2.1 - Balázs - 2018-03-05

Hello everyone Cool ,

I am new here Blush . Sorry if I post to the wrong place, but I have some question about LPub3D.

1/ I am using LDCad to create assemblies in .lpd file format. In LPub I can see all my sub assemblies in the drop-down menu, but some of them did not appearing in the pages. I can see its content in file editor window and steps, but no page, like it is not "visible" or hidden. 
I tried to remove all LPub formatting, manually delete all LPub lines in main assembly .ldr file.

2/ how can I change the order of the sub assemblies in the drop-down menu?

3/ how can I add the complete subassembly in the 1st subassembly instruction page?

Is there any good article/tutorial for commands?

Sorry for my "noob" questions Confused , tried the search function but did not found answers.

Cheers,
Balázs


RE: LPub3D 2.1 - Jaco van der Molen - 2018-03-05

(2018-03-05, 20:10)Balázs Wrote: Hello everyone Cool ,

I am new here Blush . Sorry if I post to the wrong place, but I have some question about LPub3D.

1/ I am using LDCad to create assemblies in .lpd file format. In LPub I can see all my sub assemblies in the drop-down menu, but some of them did not appearing in the pages. I can see its content in file editor window and steps, but no page, like it is not "visible" or hidden. 
I tried to remove all LPub formatting, manually delete all LPub lines in main assembly .ldr file.

2/ how can I change the order of the sub assemblies in the drop-down menu?

3/ how can I add the complete subassembly in the 1st subassembly instruction page?

Is there any good article/tutorial for commands?

Sorry for my "noob" questions Confused , tried the search function but did not found answers.

Cheers,

Balázs

Hi Balazs,
I am not quite sure what you mean exactly but I will try to answer.

1. I think you mean either mpd or ldr format. If you don't see submodels (subassemblies) on the page, you did not use them properly in your model. Please post your LDraw model file or pb me to let me check
2. I think the order is the order the files are in the LDraw file. So to change the order, change the order of the submodels in the file.
3. It is not wise to start a model with a submodel.

I have a nice tutorial here:
https://sites.google.com/site/workingwithlpub/
Just follow the LPub 4 pages (which is generaly the same als LPub3D)

A list of metacommands are here:
https://sites.google.com/site/workingwithlpub/general/advanced-techniques/metacommands

Hope this helps a bit.


RE: LPub3D 2.1 - Jaco van der Molen - 2018-03-05

(2018-02-19, 10:40)Jaco van der Molen Wrote: I will try the Mac version later too.

I cannot get the Mac version to render any bricks or assembly images.
I think I pointed to the LDraw folder but cannot change to the location of the zip?
How to do this?


RE: LPub3D 2.1 - Balázs - 2018-03-05

(2018-03-05, 20:38)Jaco van der Molen Wrote:
(2018-03-05, 20:10)Balázs Wrote: Hello everyone Cool ,

I am new here Blush . Sorry if I post to the wrong place, but I have some question about LPub3D.

1/ I am using LDCad to create assemblies in .lpd file format. In LPub I can see all my sub assemblies in the drop-down menu, but some of them did not appearing in the pages. I can see its content in file editor window and steps, but no page, like it is not "visible" or hidden. 
I tried to remove all LPub formatting, manually delete all LPub lines in main assembly .ldr file.

2/ how can I change the order of the sub assemblies in the drop-down menu?

3/ how can I add the complete subassembly in the 1st subassembly instruction page?

Is there any good article/tutorial for commands?

Sorry for my "noob" questions Confused , tried the search function but did not found answers.

Cheers,

Balázs

Hi Balazs,
I am not quite sure what you mean exactly but I will try to answer.

1. I think you mean either mpd or ldr format. If you don't see submodels (subassemblies) on the page, you did not use them properly in your model. Please post your LDraw model file or pb me to let me check
2. I think the order is the order the files are in the LDraw file. So to change the order, change the order of the submodels in the file.
3. It is not wise to start a model with a submodel.

I have a nice tutorial here:
https://sites.google.com/site/workingwithlpub/
Just follow the LPub 4 pages (which is generaly the same als LPub3D)

A list of metacommands are here:
https://sites.google.com/site/workingwithlpub/general/advanced-techniques/metacommands

Hope this helps a bit.

Hi Jaco,

thanks for the reply and info Wink .
I am not able to send you a private message, I guess because I am registered today. I did not want to post my modell here. I'll pm you when I am able to.
I write my assembly tree (it is a technic vehicle):

main assembly
-body
-complete chassis
  --frame with motors
  --axle&suspensions
  --wheels

You are right, the order is the same as in the .ldr file.

3/ what I mean is I would like a complete picture of the subassembly on the 1st subassembly instruction page to show what it will be looks like.


RE: LPub3D 2.1 - Jaco van der Molen - 2018-03-06

(2018-03-05, 21:27)Balázs Wrote: Hi Jaco,

thanks for the reply and info Wink .
I am not able to send you a private message, I guess because I am registered today. I did not want to post my modell here. I'll pm you when I am able to.
I write my assembly tree (it is a technic vehicle):

main assembly
-body
-complete chassis
  --frame with motors
  --axle&suspensions
  --wheels

You are right, the order is the same as in the .ldr file.

3/ what I mean is I would like a complete picture of the subassembly on the 1st subassembly instruction page to show what it will be looks like.

Ah, regarding question 3: You can only add this as an image that you'll have to make.


RE: LPub3D 2.1 - Balázs - 2018-03-06

(2018-03-06, 7:40)Jaco van der Molen Wrote:
(2018-03-05, 21:27)Balázs Wrote: Hi Jaco,

thanks for the reply and info Wink .
I am not able to send you a private message, I guess because I am registered today. I did not want to post my modell here. I'll pm you when I am able to.
I write my assembly tree (it is a technic vehicle):

main assembly
-body
-complete chassis
  --frame with motors
  --axle&suspensions
  --wheels

You are right, the order is the same as in the .ldr file.

3/ what I mean is I would like a complete picture of the subassembly on the 1st subassembly instruction page to show what it will be looks like.

Ah, regarding question 3: You can only add this as an image that you'll have to make.

Thank you very much for your answers Smile