LDraw.org Discussion Forums
LDCad 1.4 (win+linux) - Printable Version

+- LDraw.org Discussion Forums (https://forums.ldraw.org)
+-- Forum: LDraw Programs (https://forums.ldraw.org/forum-7.html)
+--- Forum: LDraw Editors and Viewers (https://forums.ldraw.org/forum-11.html)
+--- Thread: LDCad 1.4 (win+linux) (/thread-14363.html)

Pages: 1 2 3 4 5 6 7 8


Re: LDCad 1.4 (win+linux) - Roland Melkert - 2015-01-14

Quote:I see... not utterly clear at first sight Wink
Indeed, although most of the time you only have to describe the radius changes inside holes and on pegs. Side note in the previous note I wrote to unzip the .sf file, but I forgot it actually contains another file (.csf) which you also need to unzip first Smile.

Quote:is there a way to duplicate a submodel?
Not currently, but I like the idea I'll add it to my 1.5 todo list.


Re: LDCad 1.4 (win+linux) - Philippe Hurbain - 2015-01-15

Quote:I forgot it actually contains another file (.csf) which you also need to unzip first Smile.
I figured that...
Quote:Not currently, but I like the idea I'll add it to my 1.5 todo list.
In the meantime I'll use a text editor Wink
About submodel duplication, it would be nice to offer the option of mirroring it, at least for flex parts where there are no assymetric parts problems.


Re: LDCad 1.4 (win+linux) - Philippe Hurbain - 2015-01-15

Another sure way to crash: inadvertantly select a submodel, then use models -> delete this submodel...
(you can always count on me for monkey tests Wink
Edit: Seems more complex than that, seem to be unable to delete any submodel. More when I figured out things...
Edit 2: OK, I was actually attempting to delete main model (did I say monkey test?). But this shouldn't crash, and it doesn't with other files, but for some reason this one does (attached).


Re: LDCad 1.4 (win+linux) - Roland Melkert - 2015-01-15

I think it's caused by the groups, as it didn't crash anymore when I removed grouping by select all / ungroup (twice as there is a group using another group.)

So any model containing groups probably causes a crash while deleting that model, thanks for reporting.

I'm going to create a 1.4a soon as this is the second bug regarding groups and 1.5 is still nowhere near the beta stage. So if you or anyone else has additional issues please let me know.

Thanks again.


Re: LDCad 1.4 (win+linux) - Philippe Hurbain - 2015-01-16

Roland Melkert Wrote:I'm going to create a 1.4a soon as this is the second bug regarding groups and 1.5 is still nowhere near the beta stage. So if you or anyone else has additional issues please let me know.
Most probably a video (NVIDIA GeForce GTX 280) driver issue, but... I recommended LDCad to a friend, and he gets this ugly display. Any hint?

   


Re: LDCad 1.4 (win+linux) - Roland Melkert - 2015-01-16

It looks like LDConfig.ldr isn't loaded/found. The color wheel should be empty as well in such a case.

Manually locating the color def file using the prefs/ldraw/configuration files dialog should fix it.


Re: LDCad 1.4 (win+linux) - Philippe Hurbain - 2015-01-16

Sometimes I just feel dumb... should have thought of that!!!


Re: LDCad 1.4 (win+linux) - Trevor Sandy - 2015-01-27

Here you go: Generate LDCad parts bin custom list.

Cheers,
Trevor