LDraw.org Discussion Forums

Full Version: Ldview still pops up even after closed it.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a strange problem. I have LDview installed on my work computer and it poping up with the C++ error, long after the program was closed. Last week it suddenly popped up without opening any related files. I restarted my computer and it still came up after the reboot. After closing it in Task manager it stayed away until this monday.
After loged in on the computer, it suddenly popped up with the C++ error. I found it running with 50% usage. After the second popup it was gone. First time it happen i thinked that i accsedental had clicked a lego file but not the second time.
I'm guessing you have LDView's Explorer Thumbnail generator installed. This causes LDView to be run in the background to generate thumbnails for Windows Explorer for *.ldr and *.mpd files (and maybe *.dat files; I can't remember). To get rid of it, you need to unintall LDView, then reninstall, but uncheck the check box for generating Explorer thumbnails during installation.
I think that was the case. When i uninstalled Ldview i got messaget that ldview was running. I did not check if it was running before i started. But have now uninstalled it on this computer. I may install it later if needed since it is my work computer.

I think we are a bit back to square one on this. Since the same message i got when using it with Lpub also poped up when it was indexing.
To me it looks like it have a serius problem when it pop ut with a message from the C++ library that tell the user that the program need to close. When the case is that the program ran out of memmory. With no specification of what is the required memmory and computer capasity needed to run it. Then all type of users wil try it.
The popup message you see is a result of LDView crashing in a particular way. My sugestion to uninstall, then reinstall with Explorer thumbnail generation disabled, was designed to allow you to have LDView on your system without it causing those popups every time you browse into a folder containing the files that cause LDView to crash. I seem to remember in the last thread that resetting the curve smoothing quality to the second notch helped there. However, that may or may not have been the cause of this thumbnail crash. Unfortunately, the only way I'm likely to be able track down and fix the crash is if I have a file that triggers the crash, and for it to trigger a crash for me. Your last file didn't crash when I loaded it.
The problem with tracking the file is that i did not know it was running, and the error just popped up and told me there was a problem in ldraw and needed to be closed. No way to see where it was or what it did. Is there some way i can see it?
I think the setting you told me to change had been changed on my work computer before I uninstalled it. It was more or less default beside the low setting on memory.

A new challange on the problem. On my home laptop computer i have upgraded the Ldraw with AIO install. Have not turned the indexing on. And i think i have on had any of this earlier on this computer. But after the install I got aware of the activity when inserted a USB memory stick. My cursor had the working symbol next to it flashing on and off ,but i could work. I checked task manager and found a program not related to Ldraw i think ,using resouces. Closing that, I suddenly got message from Ldraw that it must close. 2 times as always.

It looks like the new install have enabled indexing even when it was turned off. Not choiced in the screen. I only reinstalled upon the old. Not remove the old files. But if it was not set at first it should not have been enabled on new install? I was only interested in some additional content in the AIO install this time.

After i wrote my previous message i had to install Ldraw at work computer again after the complete uninstall. This time i didi not check for indexing. So i will see if i get the problem again.
I understand the difficulty in tracking down the problem file, but without a file that makes LDView crash, there's not much I can do to fix the crash.
If it scans for ldr, mpd and dat files, It could be the problem file from an earlier thread.
On my work computer it is only that and the default parts and models from the AIO.
Is there some way to start the indexing manualy?

I was playing with the buttons with the attached model one of my MOCs in LDview.
It was recreated in MLcad some time ago from the actual Lego model.
Before starting LDview the computer used 39% of physical memory. With LDView running on High memory usage it only use 40%. But it Crash. One of the things i did to make a crash was Click on wireframe button. Turn on Remove hidden lines. and then click on Seams. then it crash.
In Task manager with all showing the LDview using 71K showing this model and just 40% memory usage on the computer
Under work it have only hit 114KB
To me it looks like it just crash, not in the case of out of memory. If it not have some internal processes that not shows in Task manager and Resouce monitor. After the crash and loading the model and try to return back to normal makes crashes. even setting the memory back to low Crash.

On low setting it just hits 63KB showing the model.
P.S after the uninstall of LDview and reinstall i still have the white background. Shoud it not have beem black if that is the default color. This time im shure i have not changed the color.
Explorer thumbnail creation happens automatically, and there's not much you can do about how or when. In general, you have to browse into a folder containing LDraw files, or its parent folder, in order to get thumbnails generated. (In the parent folder, it will generate thumbnails for the child folder so that they can be displayed over the folder icon itself for the child folder.)

I tried reproducing the steps you listed, and I couldn't get it to crash. It does sound like your crash isn't related to memory usage, though. If I can reproduce the crash, I can hopefully fix it, so I'll keep trying, but I'm not holding my breath. By the way, I think you mean MB in the places you say KB. LDView uses 31MB on my computer with no model loaded.

When you uninstall LDView, it doesn't delete its settings from the registry. It probably should, but it doesn't. So, when you reinstall it, all the settings you used before are still there. To go back to default settings, hit the reset button on every tab in LDView's preferences, then hit OK.
You are correct about the KB was MB. i was thinking 3 digits for byte and 1000 was KB without reading all. Sorry about that.

The test I did worked fine with Low setting but not in High setting. I tried it a few times and every time it happend as long it was in high mode.

I asumed that was the case that the uninstall did not clean everything up. But thats normal for a lot of programd.