LDraw.org Discussion Forums

Full Version: LSynth and MLCAD not happy.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
Anyhow, if I had to guess at this point I'd say MLCad is trying to make a temporary copy of your ldr file to pass to lsynth, and it wants to make it somewhere in your home directory structure. But that & is confusing it so maybe it tries to put it in the root directory where it has no permission.

I'd consider changing your username from j&j to something normal like jnj.
Ah, looks like you beat me to it.
I did change my user name but sadly it didn't change the directory name, I'm searching for a solution to that. Can imagine it could be a little tough since so many things are tied to it.
I'd do a google search. There's gotta be someone else who's managed to change the directory name.
Ouch. This sounds painful. good luck...

"You cannot change the name on the
User account folder, only the Username itself. The only solution there would
be to create a new user folder for yourself and copy the data from your
current one into it.

How to Copy User Data to a New User Profile

Note that one step not listed in the article is that after creating the
destination profile you must log into it once first to create the necessary
file structure before you do the copy procedure."
Thanks Don. I found some instructions on how to change the directory name and as crazy as the idea sounded I decided to give it a try.
I used this link: http://www.sevenforums.com/tutorials/147...-name.html

It worked and now LSynth actually works BUT... I noticed some things are broken, for some reason Thunderbird won't launch external links anymore and I'm sure I will find more issues. Changing an entire account directory name must have some consequences.

Good to know we solved the problem. Hopefully this thread may help other crazy people who put symbols in their usernames.

Thanks again Don for all your help, greatly appreciated. (tu)

sorry Don, spelled you as Dan...

The ampersand "&" is very often used in programming languages. In the commandline the "&" is used to separate multiple commands on one command line. Cmd.exe runs the first command, and then the second command.

But there is a way to "escape" this function:
You have to add an "^" before the "&". So your path, that you have to write, would be something like this: "C:\Users\J^&J"

Thanks Martin, it was a poor choice for me to use that in my user name, im very surprised that no other program was effected until now. All fixed though so I am happy.
It would be nice if you could sum up the above in a paragraph I can add to my troubleshooting page:


Thx, in advanced,

For sure, I'll take care of it when I get home tonight. But to put it simply, a user cannot have a symbol in the name of their user folder. Haven't tested how it would react with a symbol in any folder in its path, probably just a bad.
Pages: 1 2 3 4