LDraw.org Discussion Forums

Full Version: Lsynth flexible elements not displayed in Lpub...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm using mlcad and lsynth to produce a model including flexible elements (hoses ans wires).

But when I open the .ldr file in Lpub 4, the flexible parts are not visible.

Are there some parameters to set ? or file to instal ?

Thanks in advance for your help,
Looks like a common problem.

Perhaps lpub doesn't recognize the unofficial parts path where the lsynth parts are installed. I believe Willy's tutorial recommends the <LDRAWDIR>Unofficial\LSynth directory for these parts, but some programs only look in the standard paths.

What happens if you copy those part files from <LDRAWDIR>Unofficial\LSynth to <LDRAWDIR>Models?

thx for joining the LDraw forums and posting the above message.

However please respect the spirit of these forums and use your real name when posting. This can be set in the control center.

As for your problem I can only repeat what I've already written in my email, when you have questioned my through Holly-Wood.it:

Quote:You could work around the problem by dumping all LSynth parts and constraints in the PARTS folder and regenerate a new PArts.lst file running MKList - but that's a brutal method. Including the synthesis via a MPD would be more elegant.

Anyway best would be if Kevin could add support for extra dirs as it is handled by LDView.

Many thx and welcome aboard,

LDraw Webmaster
Thanks for your answer here and by E-mail last night.

I tried the first solution first, it didn't work. Then I uninstalled Ldraw, Lsynth, Lpub and re-installed your package "Ldraw all in one" to be certain that the installation is correct, but it still doesn't work.

I didn't try your second solution because I'm not to understand what you mean by "Including the synthesis via a MPD". I try giving the .mpd file extension, but doesn't work or I didn't do it correctly.

If it can help, I can add that it works fine in Ldview.

Thanks in advance for your comments

Are you using ldview as the renderer in lpub? The all in one installer creates a registry entry for ldview to find the lsynth parts, but ldglite won't be able to find them unless you put them in the old search paths.

Does lpub still support POV as a renderer?
Yes, Lpub renderer is LDView
I don't know if it can help because you the path should be known by Lpub but, Lpub created a "model/LPub/parts" directory where there are only the Ldraw parts and not the Lsynth parts of the model.
As you asked in your previous message, I tried to move the Lsynth part files to this directory, but doesn't work.
Ok, that sounds like an issue with the way lpub handles parts (for Bill Of Materials and such). I think we may need a tutorial for this because I suspect you need to move the synthesis bits into separate files to have lpub treat them as parts. These separate files could also be combined into one MPD file. I don't honestly know if MLCad will do that for you, or if you need a separate utility if you don't want to do it in a text editor.

Do you have an ldr file you could share for testing?
Yes the file is available at http://dl.free.fr/r3m7yuVZz
There is no login ("Nom d'utilisateur" in French), but the password (Mot de passe) is: lego

It's a very simple project to test the possibilities, I'm a beginner Smile

Thanks a lot for your help,
I converted it to an mpd (by hand) and it seems to behave a bit better in lpub, but still doesn't treat the cable synthesis file as a part. It seems like it's treating it as a separate model, before the main model.

Ok, I tried separating the mpd into two files and put the cable synthesis pf_cable.dat file into the unofficial\parts directory and I think this is sorta what you're looking for.

[Image: lpub_lsynth_test.png] I wonder if there's a way to do this and still keep it all together in an mpd file... Maybe if the pf_cable.dat file header says it's an unofficial part?

Yes that does work. Add "0 !LDRAW_ORG Unofficial_Part" to the the synthesized part in the mpd file like this.

That reminds me, I really need to read the LPub Manual. Perhaps there's a better way...
Hello Don,

I'm afraid to not fully understand what you did to reach the result. How did you extract the pf_cable.dat file ? by copying the instructions in a .dat file ? and then you include it in the model ?

Thanks a lot for your help.
I edited your file a bit in emacs (a text editor) to convert it into an mpd file.

I took the synthesized cable bits and the two 58124c01.dat cable end parts and moved them to the end of your file and added an mpd file header to tell lpub this is a part.

0 FILE pf_cable_part.ldr
0 !LDRAW_ORG Unofficial_Part

Then I added an mpd file header to the beginning of your file to designate the whole thing as an mpd file.

0 FILE lpubtest.ldr

And finally I added a line to include your new synthesized part in the main construction.

1 16 0 0 0 1 0 0 0 1 0 0 0 1 pf_cable_part.ldr

The resulting mpd file is here (apparently I lost the top 2 lines in my previous pastebin link).

Anyhow, I think you can create mpd files like this directly in mlcad and avoid using a text editor. But I'm can't tell you how to do that because my mlcad skills are quite limited.
Hello Don,

I downloaded your file Fixed_cut-n-paste_error.mpd but it still doesn't work. The electric cable isn't displayed in Lpub. It works fine in MLcad and LDView.
I definitively think that there is something wrong in my configuration Sad but what ? I re-installed everything.

As I don't understand exactly the difference between .ldr and .mpd I will open another discussion in thi forum because I may interest other people.

Thanks for your work.


PS : sorry for the delay to answer, I'm in France and have only time in the evening to work on that.
There's really not much difference between a .ldr file and a .mpd file.

Read this this old .mpd file specification for a simple explanation.
I maybe found the origin of the problem I have to display the electric cable in Lpub.
It seems that "LS70.dat" isn't recognize by Lpub on my computer.
I replaced all "LS70.dat" by "LS10.dat" and it works... except that the cable isn't displayed in the part list for the step.

Probably the file LS70.dat is missing somewhere !

Thanks in advance for all your help.


I am also having this problem with lpub not showing lsynth parts (hose and Pf wire) ,the post above showed that there is a way to do it but i am not so good with computer text editing,so i would be most grateful if you could write down some clear instructions for me to follow.

Edit very sorry i have now got it working.
> That reminds me, I really need to read the
> [url=https://sites.google.com/site/workingwithlpub
> /]LPub Manual[/url]. Perhaps there's a better
> way...

I have not written anything yet on using LSynth in LPub.
I can see if I can add something there.
Hi, I know this thread is quite old but I just had the same problem. I simply moved the Lsynth parts I needed (in this case LS70.dat and LS23.dat) from the Unofficial folder into the actual ldraw parts folder and it worked a charm. For some reason LPUB does not browse the unofficial parts folder where the LSynth files are kept.
Oops, just realized I did not post my message at the end of the thread, so here it is again... Sorry, I am new to this forum.

Hi, I know this thread is quite old but I just had the same problem. I simply moved the Lsynth parts I needed (in this case LS70.dat and LS23.dat) from the Unofficial folder into the actual ldraw parts folder and it worked a charm. For some reason LPUB does not browse the unofficial parts folder where the LSynth files are kept.
Yes, I have not found a better way either. Thanks for posting this as this is a "classical" issue...
As far as I can see, there is no dialog for the unofficial files folder. So I assume that only the official folders (the unofficial folder is unofficial Smile ) and therefore the files located there are not found.

Because of this behaviour of some applications, I decided for my applications to ask for "pure official folder" if I need to verify that the part is an offical part. I also could do it by webaccess to ldraw.org, but that would generate a lot of traffic and slow application.
Hello together.
Here ist one possible solution for this problem:
In my example String Hose (LS60.dat)

1. copy the LS60.dat in the folder with the official parts. Now LPUB will find the part, but in the PLI theres not the correct number of parts (here 341 times)

2. create an "part" for the PLI and save it in the folder for the official parts. (to create this part i use lsynth in mlcad /see attachment [seil1.dat])

3. use the part ignore


4. finished

and sorry for my bad english Wink
Now I have understood how these things work in LPub. Thank you a lot.
May I use his for my LSynth troublshooting page at www.holly-wood.it?

I've learned so many things from holly-wood.it Thank you for it.

If you want you can use it Smile