LDraw.org Discussion Forums

Full Version: LDCad 1.1 (win+linux)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello all,

I've finished the definitive 1.1 version of LDCad.

Mostly bugfixes and some minor improvements over 1.1 beta 1.

Do note, an uninstall of a pre 1.1 version is highly recommended. It isn't necessary for an 1.1 beta 1 upgrade though.

You'll find the new version at


a screenshort for closure, enjoy:

[Image: 1-1-ForumScrShot.png]
I just install LDCad 1.1 on my computer, with Linux Kubuntu 12.04 AMD64 system and when launch I get the follow error message:

"LDCad: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory"

I search on packets manager (Muon) and I can see that libgtk-3-0 is installed

Could you help me?.
I'm a plain Linux user, not a hacker one, but if you only point one way, I can follow it.

Thanks in advance.
Roberto Pla
It seems kubuntu 12 doesn't come with GTK 2.0 libraries by default (I think Ubuntu 12 does).

I'm no Linux expert myself but I think this can simply be solved by installing the GTK 2.0 package ("apt-get install libgtk2.0-0").

Although you might want to consult some other (forum) users first, I don't want you to mess up your kubuntu install.
Just in case you wouldn't have found the solution by yourself since then.
I had the same problem today on Ubuntu 12.04 64bits.

The problem is just a 32 / 64bits version problem, about libraries.
A full LDCad 64bits version would be *greatly* appreciated.

To have the 32bits version run on a (ubuntu) 64bits version, you have to install the whole bunch of 32bits lib versions (ubuntu is able to work at the same time with 32/64bits libs now).

sudo apt-get install ia32-libs-gtk
(about 38mo of installed libraries just for LDCad on my side ......)

After that it works.

I will try and compile a 64 bit version of 1.1 this week as soon I got a 64 bit version of Ubuntu 9 (or 12) running. Last time I tried this it was kind of a problem in my vmware setup. But I suspect this is no longer the case. I was actually planing to setup a multiboot environment using a spare external drive but I haven't found a good boot manager for that jet (more due to time limits than anything else though).

After compiling I also have to retest the app cause I'm not sure 64 bit will cause additional problems.
Feel free to keep us informed once a 64bits bundle is available, i'll be glad to try it to see if there's no problem with it on my side.

At first tests it works nearly fine on my 64 bits ubuntu with the ia32 libs.

The two problems i got :

- a minor one, errors like "(LDCad:14370): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so", resolved with those lines before starting the program :

- the second (unresolved) one : i have an utf-8 (french) installation, and i can't open files with LDCad (let's say .mpd) if they are in a directory with accentuated characters (like "téléchargements"). Nothing happens, the file just don't open. Not a big deal.
Serge Simon Wrote:- the second (unresolved) one : i have an utf-8 (french) installation, and i can't open files with LDCad (let's say .mpd) if they are in a directory with accentuated characters (like "téléchargements"). Nothing happens, the file just don't open. Not a big deal.

I have to look deeper into the first issue, but the filename issue seems to be a general bug, because I just confirmed the windows version has the same problem.

I will fix this in the next (bugfix) version. Thanks for reporting.
I've managed to compile a 64Bit version using 64Bit Ubuntu 10.04 in a vmplayer image.

I currently only have this 'dev' setup as a 64 Bit Linux testing ground, so if somebody could try the below version on a native (clean) 64Bit GTK2 os I would appreciate it a lot.


It's seems to work just fine on the vm machine, but I did have to solve a couple of compile errors/warnings, so it's not exactly the same as other 1.1's. As a result there could be sudden crashes under some circumstances/actions. If so please let me know.

edit: no one cared, so I deleted this version, next release will have a 'official' 64 bit version though.