LDraw.org Discussion Forums

Full Version: LPub Help! Submodels Do Not Load
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Trying to use LPub for my newest instructions, but the submodels in the MLCad
file are not displaying. It only loads the steps for the first model. The submodels
are listed in the drop down menu, but I cannot access them to either add to the
instructions or display them. When I choose one it loads the file properties
on the right, but the instructions display does not change. Really need to know
how to work around this.
If the submodels use the line

0 !LDRAW_ORG Unofficial_Model

LPub treats the submodels as parts. Maybe that's causing the error. Just delete the line ore rename it. At least get rid of the "!LDRAW_ORG"
Thanks for the response. I checked and that was not the issue. Tried many modifications to try and get it to work, but the problem persists.
Remember you can attach files in these forums. And with the MPD file attached I suspect you'd already have the answer Wink

Yes, but the file one I want to share publicly.

I have found another individual who is looking at it and we think we have the issue sorted out. If not I may be back, but thanks for the posts Dan and Tim.
I have found in the past that if the name of your submodel has a dot in it (for example, "seat.1.a") then LPub chokes on the submodel and may skip it or otherwise cause problems. I don't know if this is your issue, but it is one worth keeping in mind. If it is your issue, just rename the submodel and it will work fine.
OK - I am having the same problem, but I don't see an answer on this post.

When I load the attached "mpd" file that was created in MLCAD, I can see the first submodel in the drop down list, but I can't seem to get any of the remaining submodels to render/update instructions for those models. LPub just switches back to the first model (motormount.ldr)

(For those interested in the model, this is a "Hot Potato" machine that I'm going to use for an Integration, Verification, & Validation" class that I'm writing. I intend to provide "incorrect" instructions that create integration problems, which the student has to write-up in problems reports to get addressed. These are the correct instructions - once I figure out how to get them published! Mutliples teams then bring their complete machine to a tournament/game to see how long they can handle the ball without dropping it as the ball is passed between machines.)

I appear to be using the latest and greatest version of LPub
Your problem has a simple solution Wink
LPub expect the main model (complete assembly) to be the first in mpd order. You can change that in MLCad, Multipart menu > model sequence, select main model and press "up" till it's on top.

Otherwise... interesting project Wink
Sweet! That worked! Nice to know about the ordering of model elements, and hope this post helps the next hapless builder find an answer.

Here's another question I've been wrestling with. On the "basket" porion of the model, you can see the angled bracket attached to the front of the basket, but it's also supposed to be attached to the red pin. It fits nicely with the Legos, but I can seem to rotate the angled backet to fit correctly. The rotation is just off enough. It appears that the bracket short leg cannot be aligned vertically. Thoughts on how to make this fit?

Did you try to change MLCad rotation grid? (settings > general > change > Step/grid/snap tab)
Sweet! I didn't know that setting page existed. I hadn't explored to that level, yet. Thanks for the tip!
If you are new to LDrawing and not yet used to MLCad idiosynchrasies, I'd suggest that you try SR3Dbuilder (especially for Technic constructions!). Its output format is LDraw compatible, so you may use LPub for instructions.